
Ammoni
Data Logger Meteo-40 User’s Manual

www.ammonit.com

measuring wind and solar power

www.ammonit.com


Warranty and License Information
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Caution
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environments. The display is readable between -20°C and +70°C.
On site the data logger has to be installed in a robust and weatherproof cabinet (see also at
www.ammonit.com (http://www.ammonit.com/)). The cabinet protects Meteo-40 against
weather and condensation damage, theft and vandalism. If humidity tolerance is exceeded
and moisture penetrates, the electronics of Meteo-40 can be damaged. Users are responsible
for effective humidity control.
Handle Meteo-40 with care, do not drop the device, and avoid mechanical shocks and vibra-
tions to prevent the electronics from being damaged. Do not try to open or break the Meteo-40
housing or any of the slots. Avoid permanent pressure on the data logger.
To ensure that Meteo-40 operates properly, install only equipment, e.g., sensors, adapters and
cables, which is undamaged and approved by Ammonit. Contact Ammonit, if any questions
occur.
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Chapter 1

Introduction

1.1 Opening Remarks

Meteo-40 data loggers from Ammonit are professional measuring devices, which record meteorological details in order
to calculate the wind energy potential of a site. The data loggers can be used flexibly and are well-suited for a wide
range of applications. The implemented standards of measurement evaluation and data security meet the require-
ments of professional specialists. However, you conveniently configure sensors, statistics and the communication via
the user-friendly web interface.

Before installation read this manual carefully. Remember that time spent now setting up the data logger properly, might
save you from losing valuable data!

We recommend to configure and to test sensors and communication before the measuring equipment is installed on
the mast.

We hope you find this manual clear and easy to understand. If you have any comments or suggestions, please let us
know.

1.2 Overview of Meteo-40

Depending on the model, Meteo-40 offers up to 34 measurement channels: There are up to 12 analog differential
voltage inputs, up to 2 analog current inputs. Furthermore, Meteo-40 has up to 12 counter inputs and up to 8 digital
channels.

In addition, Meteo-40 is able to support up to 8 smart sensors via the RS485 interface.

In general, Meteo-40 is divided into two main units: A communication unit and a measuring unit. The communication
unit offers 3 USB slots to connect a PC, modem, web camera, or flash drive, and 1 Ethernet slot to connect a camera
or router. Additionally, the Meteo-40 can be connected to the network via Ethernet.

Note
Meteo-40 Revision C offers a standard RS232 slot. Meteo-40 Revision D is equipped with an Ethernet slot.
The production of Meteo-40 Revision C stopped in October 2012.

The basic concept is shown in detail in Figure 1.1.
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LEDs communication unit

current sources measuring unit RS485

power supplybuttonsLC display

Figure 1.1: Overview of Meteo-40L

1.3 Meteo-40 Series

The Meteo-40 series differs mainly in the number of input and output channels and in the measurement data storage
capacity. Some basic information about the different models (Meteo-40S, Meteo-40M and Meteo-40L) are shown in
Table 1.1.
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Feature Meteo-40S Meteo-40M Meteo-40L

Input channels

Counters 4 8 12
Periods 0 2 4
Digital 2 4 8
Analog (U) 4 8 12
Analog (I) 1 1 2
RS485 Up to 8 sensors

Output channels
Switches 2 4 8
Constant Current 1 1 2
RS485 1 for SCADA

Memory Size
Source Data 1 GByte 2 GByte 2 GByte
CSV Data > 50 MByte

Connectivity
USB 2 USB host, 1 USB device
Ethernet 1 for router, LAN

Display and keys
LC display with backlight (4 lines each with 20 characters),

five keys
Power supply 9 - 36 V (DC)

Table 1.1: Meteo-40 feature overview

Note
The predecessor of the current Meteo-40 Revision D, Revision C, is equipped with a standards RS232 slot
instead of the Ethernet slot.

Find below an overview of the terminals. The white areas indicate available connectors.

Figure 1.2: Meteo-40L Terminal
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Figure 1.3: Meteo-40M Terminal

Figure 1.4: Meteo-40S Terminal

1.4 The Two Systems of Meteo-40

Meteo-40 consists of two basic systems: the Measurement And Recording System (MARS) and the Configuration,
Evaluation and Communication System (CECS).

For measuring and recording data, only MARS is needed. MARS is designed to work with minimal power consumption.
It controls the analog data logger hardware, measurement channels and data storage. It has no access to the display
or to the devices that could be connected via USB or Ethernet (RS232 for Meteo-40 Revision C).

In order to use connected devices and to operate the display or the web interface, CECS has to be started. CECS
is a fully operational embedded Linux™ computer. Starting it, allows using Meteo-40’s features, but increases power
consumption.

To save power during a measurement campaign, CECS is usually powered down and only MARS is running. MARS
starts, when the power connector is plugged in.

The booting process of the MARS software is indicated by the illumination of the two lower LEDs (red and yellow).
Both LEDs will turn off, when the MARS is started successfully.
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CECS can be started either manually or automatically. To manually start CECS, press the middle button of the keyboard
and hold it until the display turns on. A manual start of CECS is necessary for the initial configuration of Meteo-40.

Later on, during a measurement campaign, CECS will be started by MARS according to the configured time schedule,
e.g., to upload measurement data. After the scheduled actions have been executed, CECS turns off automatically to
reduce power consumption.

Meteo-40

CECS - Configuration, Evaluation, and Communication System

MARS - Measurement And Recording System

LC Display Keys

System Storage
for software
and statistics
(CSV files)

USB-A

Ethernet*

USB-B

RS485 Slave

e.g. USB modem

e.g. PC, LAN, router,
SCADA master, or modem

PC

SCADA master

read data

write data

Source Data Storage Power System Power Supplyconfiguration

Real-Time Clock (RTC),
battery buffered

RS485 master RS485 sensors

Switches e.g. Relais

Measurement Inputs Analog and digital sensors

Current Sources e.g. PT1000

*RS232 on older Meteo-40

Figure 1.5: Block diagram of Meteo-40
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1.4.1 CECS: Switch on / off behavior

CECS is configured to run for 20 minutes, before it automatically turns off. When the time is expired and an action is
still running, e.g., sending an email, the system will wait until the action is finished and will switch off afterwards. The
remaining time is displayed in the status box (see Section 3.2) of the Meteo-40 web interface.

Note
With every user action, e.g., click in the web interface or pressing a button on the keyboard, the remaining
time will be reset to 20 minutes.

For SCADA operation, CECS has to run permanently. This is possible by means of the CECS always active mode. If
CECS always active mode is selected, it will be displayed in the status box (see Section 3.2) in the web interface
with the infinity symbol (∞) as well as on the Meteo-40 display with the word Always.

Note
The CECS always active mode is not selected by default. If the SCADA server is activated, the CECS
always active mode is automatically set.

If power supply is disconnected and the data logger shuts down while CECS was running in the CECS always active
mode, it will start automatically as soon as power is available again.

Important
When CECS is configured to be permanently on, you cannot manually shut down the system by pressing
the middle button on the data logger.

1.5 Data Storage

CECS and MARS both have access to the common measurement data storage (shared source data memory). It is
possible to view or download the source data via the web interface, see Section 6.7.

Note
For optimal data recording, it is recommended to format the data storage before starting a new measure-
ment campaign. Formatting is a very fast process, which only takes a few milliseconds and can be per-
formed via the web interface under the System → Administration menu. For further details see Section 4.2.

1.6 User Interfaces

There are two ways to control and configure the data logger: via web interface or by using the buttons of Meteo-40. The
second method is only intended for checking and testing, since this control menu does not provide as many possibilities
to configure Meteo-40. However, the web interface offers all available configuration options and is recommended for
the configuration of the device. To use the web interface a TCP/IP or USB connection is required.

Thanks to its web interface, Meteo-40 can also be operated via Internet with mobile devices, i.e., smartphone, tablet
PC.
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Important
The Meteo-40 web interface is accessed via HTTPS connection, which uses high-grade encryption (AES-
256, 256 bit). This connection cannot be decrypted using today’s technologies.

1.7 Communication Methods and Required Devices

Depending on the project, Meteo-40 offers various methods for communication and data retrieval. All available meth-
ods are commonly used as well as easy to handle and to configure. In order to set up the connection to Meteo-40,
devices like Ethernet cable or modem are necessary as shown in the following table.

Method /
Action

Configura-
tion

Software
Update

Data
Download

Required
Devices Comment

Meteo-40
(stand-alone)

no (only a
few settings
can be
changed)

no no -
Using the display (see
Section 4.4.1 and
Chapter 9).

USB flash
drive
(connected
to data
logger)

no no yes
USB flash
drive

Manual data download on
pre-configured USB flash
drive (see Section 4.2).

LAN (data
logger
connected to
LAN)

yes
yes (Internet
access
required)

yes (Data
transfer via
email,
FTP/SCP,
AmmonitOR
or manual
data
download via
web
interface)

Ethernet
cable

Recommended for initial
configuration and software
updates (see Section 2.3).

W-LAN (PC,
laptop etc.
connected to
data logger’s
W-LAN)

yes no

yes
(Download
via web
interface)

USB W-LAN
stick

Recommended on site for
maintenance (see
Section 7.8).

Point-to-
Point
Ethernet
(data logger
connected to
PC)

yes no

yes
(Download
via web
interface)

Ethernet
cable

PC has to be configured
(see Section 2.4).

USB (data
logger
connected to
PC)

yes no

yes
(Download
via web
interface)

USB (A/B)
cable

Backup access. Driver file
might be required (see
Section 2.5).

USB (data
logger
connected to
smartphone)

yes

yes, tethering
function of
the
smartphone
needs to be
activated

yes
(Download
via web
interface)

USB cable of
the
smartphone
(accessory)

Convenient for remote
servicing or software
upgrades, when no
modem is installed.
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Method /
Action

Configura-
tion

Software
Update

Data
Download

Required
Devices Comment

Modem
access (data
logger
connected to
modem, e.g.,
GPRS/GSM,
directional
radio,
satellite)

yes
yes (Internet
access
required)

yes (Data
transfer via
email,
FTP/SCP,
AmmonitOR
or manual
data
download via
web
interface)

Modem and
accessory
cable

Thanks to the tunnel server
design a standard SIM
card can be used in a GSM
modem. The tunnel server
manages IP addresses.
SIM card with static IP
address is not necessary.
(see Section 7.9)

SCADA over
RS485
(Modbus
RTU)

no no
yes (Modbus
protocol)

-
Modbus register map has
to be configured for data
retrieval (see Section 8.1).

SCADA over
Ethernet
(Modbus
TCP/IP)

no no
yes (Modbus
protocol)

-
Modbus register map has
to be configured for data
retrieval (see Section 8.1).

Note
If you are working with a Meteo-40 Revision C with RS232 slot, you need an USB Ethernet adapter to
connect the data logger to your LAN. The production of Meteo-40 Revision C stopped in October 2012.
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Chapter 2

Getting Started with Meteo-40

2.1 Introduction

Before you start working with Meteo-40, connect the data logger to the power supply. In the moment Meteo-40 is
connected to the power supply, the lower LED lights turn on and indicate that the Measurement And Recording System
(MARS) is booting. Both LEDs turn off, when MARS has successfully started and is running. To access the web
interface, the second system Configuration, Evaluation and Communication System (CECS) has to be started. Press
the middle button of Meteo-40’s keyboard and hold it until the display turns on (see Section 1.4).

In order to access the web interface, it is necessary to establish a TCP/IP connection between Host PC and Meteo-40.
There are multiple ways to create this connection:

1. If you connect the data logger to your LAN using an Ethernet cable (see Section 2.3) and DHCP method, any
other device in the lan (e.g. your PC) will have access to the web interface of the data logger, as long as the
CECS is running.
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LAN connection between Data Logger and PC

Ethernet cable

Ethernet
port

Ethernet
port

Local Area Network (LAN)
with DHCP Server

Ethernet or
WLAN connection

Figure 2.1: Accessing Meteo-40 via LAN (see Section 2.3)

2. A direct, point-to-point connection using an Ethernet cable (see Section 2.4), either with the link-local
method or with static IP addresses. The link-local method is recommended.

Point-to-point Ethernet connection between Data Logger and PC

Ethernet cable
Ethernet

port
Ethernet

port

Figure 2.2: Accessing Meteo-40 via Point-to-Point Ethernet Connection (see Section 2.4)

3. A direct, point-to-point connection using a standard USB 2.0 A/B cable, (see Section 2.5). The same type of
cable is typically used to connect a USB printer to a PC.
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USB Connection between Data Logger and PC or Mobile Phone

USB A/B cable

Micro USB cable

USB B
port

USB A
port

USB A
port

Micro
USB B
port

Figure 2.3: Accessing Meteo-40 via USB-B (see Section 2.5)

Important
If you establish a connection via USB, a driver file might be needed for Windows PCs. The driver file
can be downloaded from the Ammonit website in the Support → Software (http://www.ammonit.
com/) section. For further details refer to Section 2.5.

Note
If you are working with Meteo-40 Revision C with RS232 slot, you need an USB Ethernet adapter to connect
the data logger to your LAN or via Ethernet to your PC (Point-to-Point). The production of Meteo-40 Revision
C stopped in October 2012.

Note
After having configured Meteo-40 for W-LAN, the data logger web interface can be accessed by using a
W-LAN USB device (see Section 7.8).

© 2011 — 2017 Ammonit Measurement GmbH 11
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2 USB-A ports 1 Ethernet port 1 USB-B port

Figure 2.4: Ethernet / USB ports of Meteo-40L

Tip
We recommend connecting Meteo-40 via Ethernet to your LAN. It is the easiest method, no additional driver
file is needed and updates can be performed immediately.

2.2 Using Bonjour™ on Windows™

For Windows Vista™ and later versions, this procedure can be simplified by installing the software Bonjour Print
Services for Windows from Apple (http://support.apple.com/kb/DL999). It provides automatic resolution of
computer host names and the data logger can be accessed via its serial number. Unfortunately, our tests have revealed
that this software can cause problems when installed on Windows XP.

Warning
Do not use Bonjour with Windows XP™, as it might cause communication problems!

After the installation of Bonjour Print Services just type the serial number as follows in your web browser https://
Dnnnnnn.local with Dnnnnnn as your data loggers serial number. The untrusted connection alert page will appear
and should be accepted as described in Section 2.5.1.
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URL:	http://d171234.local/

Meteo-40	D171234
Username:

Password:
Show	password

Login

中文(简) 	 English 	 Español 	 Português 	 Français 	 Deutsch 	 Türkçe ©	2011-2017	Ammonit	Measurement	GmbH
www.ammonit.com

Figure 2.5: Meteo-40 web interface initial screen

2.3 Connecting Meteo-40 via Ethernet to your LAN

In order to connect Meteo-40 with your PC via Ethernet, both devices have to be connected to your local network. Your
computer should be connected via LAN or W-LAN to your network. To connect Meteo-40 to the network, a standard
Ethernet cable is needed. If you have only one Ethernet port in your office, use a switch or a hub to multiply the
available Ethernet ports. See Figure 2.1.

Note
If you are working with Meteo-40 Revision C with RS232 slot, you need an USB Ethernet adapter to connect
the data logger to the LAN. Connect the USB side of the adapter to the data logger and plug in the Ethernet
cable on the other side. The production of Meteo-40 Revision C stopped in October 2012.

To see that Meteo-40 has been connected successfully, use the buttons on the data logger to navigate through the
menu. In the Communication → Devices → LAN menu you can find a list of connections, which displays all available
connections. If eth Activated is displayed, the connection has been successfully established.

By opening this menu item (click on the right button of the data logger keyboard), you can browse for the connection
properties such as IP address, which was automatically assigned to the data logger by DHCP server. To access the
web interface, start your web browser. Enter https:// and the IP address shown in the data logger display, e.g.,
https://192.168.12.30.

Tip
We recommend using Mozilla Firefox (http://www.mozilla.com/) as your web browser to access
Meteo-40. Other modern web browsers, including mobile web browsers, should work as well, but are not
systematically tested by Ammonit.

After entering the address in your web browser, a confirmation prompt may appear. Click I understand the risks and
press Add Exception.
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Figure 2.6: Firefox Connection Untrusted alert page

In the next step download the certificate by clicking on Get Certificate and Confirm Security Exception to access the
Meteo-40 web interface. In order to save the exception Permanently store this exception should be checked.

Figure 2.7: Add Security Exception

Important
In order to prevent misuse of the certificate, Ammonit deliberately did not store the security certificate on
each data logger. After downloading the certificate, its validity can be verified.
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URL:	https://192.168.43.21/

Meteo-40	D171234
Username:

Password:
Show	password

Login

中文(简) 	 English 	 Español 	 Português 	 Français 	 Deutsch 	 Türkçe ©	2011-2017	Ammonit	Measurement	GmbH
www.ammonit.com

Figure 2.8: Meteo-40 web interface initial screen

Important
In order to use all functions of the web interface, activate JavaScript and Cookies in your web browser!

Go to Chapter 3 to proceed with the configuration.

2.4 ConnectingMeteo-40 to yourWindows 7™PC via point-to-point
Ethernet connection

In order to connect Meteo-40 with your Windows 7™ PC, a crossover Ethernet cable is required. No additional driver
file is needed for a direct point-to-point connection via Ethernet. See Figure 2.2.

Note
If you are working with Meteo-40 Revision C with RS232 slot, you need an USB Ethernet adapter to connect
the data logger via point-to-point Ethernet connection to your PC. Connect the USB side of the adapter to
the data logger and plug in the Ethernet cable on the other side. The production of Meteo-40 Revision C
stopped in 2012.

Before you connect the devices, Meteo-40 has to be configured to use either a link-local connection or a static IP
address. The former is much easier to use, because it does not involve any manual configuration of the PC, if it has
the standard configuration of obtaining an IP address automatically.

2.4.1 Using link-local connection

To use a link-local address, you have to make sure your PC is configured to obtain an IP address automatically. In
most cases, this is already be the case.

In the next step Meteo-40 has to be configured for the link-local Ethernet connection. Open the Communication
→ Devices → LAN → Ethernet menu and select Ethernet (Offline). Move to Method and press the right button on the
Meteo-40 keyboard until Link-local is displayed as shown in Figure 2.9. DHCP is configured by default to support
the standard LAN (see Section 2.3) connection via Ethernet.
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IP / Netmask
DNS Servers
Routes

> Method: Link-local

Figure 2.9: Meteo-40 display with activated link-local connection

Open your browser, e.g., Mozilla Firefox. When you are using a Mac or a Linux computer, or when you have installed
Bonjour on a Windows PC, you can just enter https://Dnnnnnn.local in the URL field of your web browser.

Otherwise, look up the IP number in the menu and enter the number as follows https://169.254.nnn.nnn as
URL. For link-local connection, IP addresses start always with 169.254., while the remaining numbers are random
and change every time.

2.4.2 Using static IP address

To use a static IP address, you need to configure your PC and Meteo-40. To configure the PC, open the Network and
Sharing Center in the Control Panel of your computer and click on LAN Connection (see Figure 2.10). In most cases,
the link-local connection Section 2.4.1 is preferable.

Figure 2.10: Network and Sharing Center of Windows 7™

To configure the LAN connection, click on Properties (Figure 2.11) in the LAN Connection Status window.
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Figure 2.11: LAN Connection Status

Select Internet Protocol Version 4 (TCP/IPv4) and open the Properties of the Internet protocol as shown in Figure 2.12

Figure 2.12: Properties of LAN Connection

Choose Use the following IP address and enter the following IP address 192.168.40.1 as shown in Figure 2.13. By
pressing the TAB button the Subnet mask will be filled automatically. Save the configuration with OK.

Important
If you do not have the rights to configure the settings, contact your system administrator.
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Figure 2.13: Properties of Internet Protocol

After having configured the LAN connection, connect your PC with Meteo-40 using a standard Ethernet cable. Switch
on Meteo-40 by pressing the middle button of the keyboard.

In the next step Meteo-40 has to be configured for the static IP point-to-point Ethernet connection. Open the Com-
munication → Devices → LAN → Ethernet menu and select Ethernet (Offline). Move to Method and press the right
button on the Meteo-40 keyboard until Static IP is displayed.

IP / Netmask
DNS Servers
Routes

> Method: Link-local

Figure 2.14: Meteo-40 display with activated link-local connection

Open your browser, e.g., Mozilla Firefox. When you are using a Mac or a Linux computer, or when you have installed
Bonjour on a Windows PC, you can just enter https://Dnnnnnn.local in the URL field of your web browser.

Otherwise, just enter https://192.168.40.40, where 192.168.40.40 is the preconfigured IP address of each
Meteo-40 data logger.

Afterwards a confirmation prompt appears. Click I understand the risks and press Add Exception as shown in Fig-
ure 2.15.
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Figure 2.15: Mozilla Firefox Connection Untrusted Alert Page

In the next step download the certificate by clicking on Get Certificate and Confirm Security Exception to access the
Meteo-40 web interface. In order to save the exception, Permanently store this exception should be checked.

Figure 2.16: Add Security Exception

After confirming the certificate, the Meteo-40 login page is shown. Use your login details (Meteo-40 certificate) to enter
the web interface. To proceed with the configuration, go to Chapter 3.
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URL:	https://192.168.40.40/

Meteo-40	D171234
Username:

Password:
Show	password

Login
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Figure 2.17: Meteo-40 web interface initial screen

Tip
By using this point-to-point connection (without Internet access), the modem connection can be tested, e.g.,
sending emails via modem.

Note
Do not forget resetting the LAN configuration on your PC (Internet protocol properties) and enabling DHCP
on Meteo-40 (if needed).

2.5 Connecting Meteo-40 with your Windows 7™, Windows Vista™
or Windows XP™ PC via USB

Meteo-40 requires a standard RNDIS USB driver from Microsoft™ Corporation. With the driver, it should be automat-
ically recognized and installed. If any incompatibility problems occur, refer to Section 2.5.2. Otherwise proceed to
Section 2.5.1.

Tip
You can also connect Meteo-40 to your tablet PC or smartphone by using a micro USB cable as shown in
Figure 2.3. In doing so, you can easily connect to the data logger for maintenance reasons in the field or
for performing updates using the tethering function of your mobile device (see also Section 4.3.1).

2.5.1 Standard RNDIS USB Driver

Start Meteo-40 and connect the USB-B side of the cable to the data logger and the USB-A to the computer. Win-
dows will find the new hardware and will automatically search for appropriate software. After a few seconds the USB
Ethernet/RNDIS Gadget is installed and ready to use.
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Figure 2.18: Windows Driver Software Installation

If the installation does not start automatically, open the Device Manager, right click on the device, select Update Drivers
and Search automatically for updated driver software. Access to the Internet is required for this step.

Figure 2.19: Windows Driver Update Installation

Once the software installation is completed, a new RNDIS/Ethernet Gadget device will appear on the Network adapters
list in the Device Manager.

Figure 2.20: Windows Device Manager
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The local connection is established. An IP address is automatically assigned to the data logger, which can be found
on its display in the menu Communication → Devices → LAN → USB under IP/Netmask. To start using Meteo-40,
type the address in your web browser, e.g., https://169.254.12.25/. The address always starts with 169.254,
the remaining part is random.

Tip
We recommend using Mozilla Firefox (http://www.mozilla.com/) as your web browser to access
Meteo-40. Other modern web browsers, including mobile web browsers, should work as well, but are not
systematically tested by Ammonit.

Important
In order to use all functions of the web interface, activate JavaScript and Cookies in your web browser!

After entering the address in your web browser, a confirmation prompt may appear. Click I understand the risks and
press Add Exception.

Figure 2.21: Firefox Connection Untrusted alert page

In the next step download the certificate by clicking on Get Certificate and Confirm Security Exception to access the
Meteo-40 web interface. In order to save the exception, Permanently store this exception should be checked.
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Figure 2.22: Add Security Exception

Important
In order to prevent misuse of the certificate, Ammonit deliberately did not store the security certificate on
each data logger. After downloading the certificate, its validity can be verified.

URL:	https://169.254.43.21/

Meteo-40	D171234
Username:

Password:
Show	password

Login
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Figure 2.23: Meteo-40 web interface initial screen

2.5.2 Driver Update

When installing Meteo-40 for the first time, driver incompatibility problems may occur. A new RNDIS/Ethernet Gadget
device should appear in the Device Manager under Network Adapters, but a warning sign (△! ) indicates that the
hardware driver software was not correctly installed.
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In this case download the driver file from the Ammonit website. Therefore, go to http://www.ammonit.com/, open
the Support page and browse to the software section under Downloads. After downloading the Meteo-40 driver file,
extract the ZIP file and save the Meteo-40.inf file on your PC.

Figure 2.24: New USB Ethernet/RNDIS Gadget in Device Manager

Right click on the device and select Update Driver Software.... An update wizard opens. Click on Browse my computer
for driver software.

Figure 2.25: Update Driver Software dialog box

Locate and select the Meteo-40.inf file, which has been downloaded from the Ammonit website to your PC.
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Figure 2.26: Update Driver Software dialog box

Note
During the installation of the drivers, Windows may show a warning message: ”Windows can’t verify the
publisher of this driver software”. If this happens, select ”Install this driver software anyway” to complete
the installation.

Figure 2.27: Windows Security Advisory

The driver software for Meteo-40 should now be correctly installed. The warning sign (△! ) should have gone and
the name of the device in the Hardware Manager should have changed from RNDIS/Ethernet Gadget to Ammonit
Meteo-40.
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Figure 2.28: Windows Device Manager

2.6 Connecting Meteo-40 to your Windows 8™ PC via USB

In order to connect Meteo-40 to a Windows 8™ PC, some PC settings have to be modified. Unlike its predecessor
Windows 7, Windows 8 strictly enforces a driver signature check - verifying the signatures with its own local database.
If your PC is not configured to install unsigned driver files, the installation of Meteo-40 will fail. The problem can be
solved by disabling a checkbox in the PC settings in a few steps:

1. Open the PC settings in the Charms bar for example by pressing the ”Windows” key + ”C” on the keyboard.
Click on General.

Figure 2.29: Windows 8 PC settings (1)
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2. Select Advanced startup and click on Restart now.

Figure 2.30: Windows 8 PC settings (2)

3. Go to Troubleshoot and click on Advanced options. Select Startup Settings.

Figure 2.31: Windows 8 PC settings (3)
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4. The Windows Startup Settings are displayed. The first option is Disable driver signature enforcement. In order
to disable this feature, click on Restart. After reboot, press F7 to modify the settings. Thereafter the Meteo-40
driver file should be installed properly.

Figure 2.32: Windows 8 PC settings (4)

After having configured the settings of your Windows 8™ PC, the Meteo-40 driver file has to be installed. To do so,
follow the instructions in Section 2.5.2.

2.7 Using Meteo-40 with Linux

Recommended is any up-to-date Linux distribution with installed Network Manager (http://projects.gnome.
org/NetworkManager/) (at least version 0.8), such as Debian 6.0, Ubuntu 10.04 or later. Configure the RNDIS-
/Ethernet Gadget to use link-local and connect the Meteo-40 with the PC. You should be able to access the Meteo-40
with your web browser now.
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Chapter 3

Login at Meteo-40

3.1 Login Options

Once you access the login page of the data logger over the web interface, you may log into one of four accounts,
which have different access rights: Guest, Viewer, User or Admin.

URL:	http://d171234.local/

Meteo-40	D171234
Username:

Password:
Show	password

Login
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Figure 3.1: Login Screen

The original password for each account is enclosed in the data logger’s delivery. The passwords are unique for each
Meteo-40. All passwords can be changed (see Change Passwords: in Section 4.2) by the administrator.

Warning
Be careful with changing the password for the Admin account. A forgotten Admin password cannot be
recovered. The data logger has to be returned to Ammonit to restore the original password.
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Account Permissions

Guest
• Look at all configuration pages
• Look at live data

Viewer
• All of the above
• Download measurement data

User
• All of the above
• Configure the data logger

Admin

• All of the above
• Change the name of the data logger
• Upgrade the data logger software

Table 3.1: Accounts and permissions

The Meteo-40 web interface is available in seven languages: Chinese, English, French, German, Portuguese, Span-
ish, and Turkish.

Important
In order to use all functions of the web interface, activate JavaScript and Cookies in our web browser!

After login, two links are shown in the upper right corner:

Help Access online help.

Logout Close the session, when access to the data logger is no longer needed.

Under these links the account you are logged into (Guest, Viewer, User or Admin) is shown, followed by the serial
number of the data logger.

Warning
Be aware that due to security reasons it is not possible to reset the passwords. Furthermore, if you change
the Admin password and forget it, there is no way to recover it, not even for Ammonit. In this case, you
have to send the data logger to Ammonit, so that we can restore the original passwords.

3.2 Global Control Elements

A Status Box is shown in the upper left corner of the Meteo-40 web interface. It always shows the most important
information and control options.
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Help Logout
(Admin on D130080)

Recording: On Switch off

Configuration: Saved Save

Connection: USB, Ethernet, Tunnel

Remaining: ∞ ( 1 )

Date/time: 2013-11-29 11:43:25 UTC

System Information

File Edit View Go Bookmarks Tabs Help

Back https://d130080.local/measurement/sensors/?saved=true

Help Logout
(Admin on D130080)

Top Anemometer Anemometer Generic
Anemometer

100.0 1 s C1 Change Delete

Backup
Anemometer

Anemometer Generic
Anemometer

99.0 1 s C2 Change Delete

Middle
Anemometer

Anemometer Generic
Anemometer

50.0 1 s C3 Change Delete

Low Anemometer Anemometer Generic
Anemometer

10.0 1 s C4 Change Delete

Top Wind Vane Wind Vane Thies Wind Vane
10 Bits Serial
Synchron

100.0 1 s D1 Change Delete

Backup Wind Vane Wind Vane Thies Wind Vane
10 Bits Serial
Synchron

99.0 1 s D2 Change Delete

Low Wind Vane Wind Vane Thies Wind Vane
10 Bits Serial
Synchron

50.0 1 s D3 Change Delete
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System
Information
Administration
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System Log
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Statistics
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Communication
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E-Mail
Online
FTP/SCP
SCADA
LAN
WLAN
Modem

https://d130080.local/data/statistics/

measurement data is recorded 
confi guration is saved

measurement data is not 
saved to memory 

confi guration has been changed

Figure 3.2: Meteo-40 Status Box displaying Status of Recording

The Status Box displays whether Meteo-40 is recording data and whether the current configuration is saved. You can
switch on or off recording here and save the configuration after having made any changes.

Note
If you switch Recording on, the Configuration will be saved automatically, because recording cannot
work without a saved configuration.

Important
If you switch Recording off, no measurement data will be saved to memory. The measurement is still
going on and you will be able to see live data, but you cannot generate CSV files and you will not be able
to access measured data afterwards!
If Configuration is not saved, you have changed the configuration and the changed configuration is
active. You must save the configuration to use the new configuration permanently. If you do not save the
configuration, your settings will be lost after disconnecting the power supply!
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Figure 3.3: Meteo-40 Status Box displaying Connection and Power Mode

The Meteo-40 Status Box displays, in which way the data logger is accessed (Connection), e.g., tunnel connection
via modem or using Ethernet without tunnel in the office. Additionally, the web interface informs about the remaining
time until shut down or whether CECS is configured to run permanently (Remaining). In brackets the number of
running actions are displayed, e.g., online access or upload of CSV file.
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3.3 Menu of the Web Interface

The menu of the Meteo-40 web interface consists of four main menu items: System, Measurement, Evaluation and
Communication. Each menu item is explained in the following chapters (See Chapter 4 to Chapter 7).

Menu Submenu Item

System

Information
Administration
Upgrade
Device
Camera
Switches
Logbook

Measurement
Sensors
Channels
Evaluation

Data
Live
Statistics
Gusts

Source

Communication

Schedule
Online
AmmonitOR
Email
FTP/SCP
SCADA
LAN
WLAN
Modem

Table 3.2: Menu of the Web Interface
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Chapter 4

System Configuration

4.1 System Information

This page gives an overview of important system properties, such as data logger type, serial number, available memory,
software versions and number of channels.
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Help Logout
Admin	on	Meteo-40	Site	1	D171234

URL:	http://d171234.local/system/information/

Data	logger
type

Meteo-40L

Serial
number

D171234

Number	of
channels

12	analog	voltage,	12	counters,	2	analog	current,	2	current	sources,
8	digital,	8	switches,	8	RS-485,	4	period	measurement

Active	input
channels

None

Installed
sensors

None

Data	logger
location

52.50176,	13.43479	@	36.5m

RAM Total:	123MiB,	Used:	34MiB	Free:	89MiB
Source	data
storage

1961.51MiB	(52.20%	used,	current	page-id:	2097152)

System
storage

Total:	461MiB,	Used:	104MiB	Free:	358MiB,	Type:	MT29F4G08ABBDAHC[7,0]

Uptime CECS:	1	day,	10:17:36;	MARS:	11	days,	10:20:54
Software
version

1.6.4	(2017-05-05)

Bootloader
version

5641

Production
date

2017-01-02	10:11:12

AmmonitOR EWNP
SCADA Modbus	TCP
Current
connections

Admin	(127.0.0.1)

No	file	selectedChoose	File
Upload	configuration	file

Recording: Off Switch	on
Configuration: Saved Save
Connection: ETHERNET,	Tunnel
Remaining: ∞
Date/time: 2017-05-11	15:05:04	UTC+01:00

System	Information

Meteo-40
System
Information
Administration
Upgrade
Device
Camera
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Measurement
Sensors
Channels
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Data
Live
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Source

Communication
Schedule
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Figure 4.1: System Information Page

UnderCurrent connections all current logins are displayed with IP address, e.g., via LAN, W-LAN (WiFi), USB or tunnel.
If a connection has been established via tunnel (see also Section 7.3), the letter T after the IP address indicates the
tunnel.

Source data storage shows the amount of memory which is already in use for storing source data. Please note, that
more than 100% are possible. A value beyond 100% means that the data logger is overwriting the oldest source data
by storing new data.

Use Download Current Configuration to download the configuration file. The configuration file is an INI file (http://
en.wikipedia.org/wiki/INI_file), which is a widely-used file format. This file contains configuration settings
related to modem, Ethernet, server upload, email, data evaluation, SCADA as well as activated channels and sensors.
By saving a configuration file, the configuration can quickly be uploaded and effectively applied to other data loggers.
The file name is config-Dnnnnnn.txt with Dnnnnnn as the serial number of the data logger.
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Warning
Be careful with uploading a changed INI file to the data logger. Inconsistencies can lead to malfunctions of
the data logger.
We strongly advice not to change manually any entry in the configuration file.

4.2 System Administration

This page contains different administration aspects of the data logger. Only users logged in as Admin can access
the complete functionality of this section. If you are logged in as User, Viewer or Guest, changes in the System
→ Administration menu are not possible.

Data Logger Name: By giving each Meteo-40 a name, the data loggers can be identified easier. The name appears
in the source data files header, on AmmonitOR (http://or.ammonit.com/) and in the config.txt file.

Data	Logger	Name

Data	logger	name
Meteo-40	Site	1

Save	name

Figure 4.2: Assigning a Data Logger Name

Note
The data logger serial number is the most important ID to identify the data logger. Use the Data
Logger Name to give the data logger a custom name, e.g. Meteo-40 Site 1.

CECS Power Mode The standard operation mode keeps CECS running for 20 minutes. Each user interaction resets
the remaining time before automatic shutdown to 20 min. The CECS always active mode is not selected by
default.

In order to keep CECS permanently running, e.g., for SCADA wind farm monitoring, Meteo-40 offers the CECS
always active mode. This mode prevents the automatic shutdown of CECS. It can be configured via web
interface (System → Administration) or by using the display (Status → CECS) of the data logger. To do any
changes of the CECS mode via display, permissions have to be defined in the web interface (System → Display
(see Section 4.4.1). If the CECS always active mode is selected, it will be displayed in the status box of the web
interface with the infinity symbol (∞) as well as on Meteo-40 display with the word Always.
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CECS	Power	Mode
Restart	CECS

Shutdown	CECS

	CECS	is	always	active	(only	recommended	for	SCADA	and	laboratory	use)
Automatic	CECS	reboot
Weekly

Save	CECS	power	mode

Power	CECS	on	digital	status	signal
None

Save	channel

select digital channel for manual
CECS start with voltage peak

choose automatic reboot interval

switch on CECS permanently

Figure 4.3: Configuring the CECS always active Power Mode

Note
If the power supply for Meteo-40 is disconnected while CECS is running in the CECS always active
mode, CECS will restart automatically as soon as Meteo-40 is powered again.

To ensure reliability of Meteo-40 function, it is highly recommended, that the CECS is rebootet regularly. In
cases, where CECS is always on, e, e.g. for SCADA, Meteo-40 has an automatic reboot function. The default
behavior of Meteo-40 is to reboot just before the start of the week, i.e. every Sunday five minutes before
midnight. Alternatively, you can choose to reboot every day five minutes before midnight, or never.
To restart the CECS, click on Restart CECS.
To shutdown the CECS, e.g., during remote access, click on Shutdown CECS.

Important
When CECS is configured to be permanently active, you cannot shut down the system, neither by
pressing the middle button on the data logger nor using the Shutdown CECS button at the web
interface. You can still restart the CECS with the Restart CECS button.

Important
MARS (for measuring and recording) continues without stopping during the restart. You will not loose
any measurement data unless the recording is explicitly switched off or the power supply has been
disconnected. For further details about the systems refer to Section 1.4.

By applying a voltage peak for at least one second to the selected digital channel, CECS can be turned on. This
might be useful to prevent climbing up the met mast to switch on the data logger during maintenance work. The
CECS will automatically turn off after 20 min, when no action on the data logger is performed. The voltage peak
can be triggered by a cable / switch close to the ground (see also Section 12.2.4).
The digital channel has to be selected from the list of available digital channels in the Power CECS on digital
status signal dropdown list. This change on data logger’s configuration will stop the measurement for some
seconds, until it is automatically or manually restarted (see Section 3.2).

Date and Time, Location: Time synchronization of the data logger is a primary concern. In order to synchronize date
and time automatically to NTP servers, select Set data and time automatically. Additionally the time zone has
to be set.
Optionally, you can also choose to Set date, time and location using GPS.
If date and time should be set manually, enter date (date format YYYY-MM-DD) and time (time format hh:mm:
ss) in the appropriate fields. Date and time format are validated while typing the values.
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Date	and	Time,	Location

Time	zone
UTC+01:00	(Germany,	Spain,	Algeria)

	Set	date,	time,	and	location	using	GPS
	Set	date	and	time	using	NTP	(Internet)

NTP	servers:
0.pool.ntp.org	1.pool.ntp.org	2.pool.ntp.org	3.pool.ntp.org
	Set	date	and	time	using	SCADA

Date	(YYYY-MM-DD):

Time	(hh:mm:ss):

Latitude	(decimal):
52.50176
Longitude	(decimal):
13.43479
Altitude	(meters):
36.5

Save	date/time	and	location

Download	KML	file

synchronize date and time with NTP servers

set date, time, and location using GPS

select the local timezone

download KML file to view location
in Google Earth™ or Marble

enter the location manually

set date and time via SCADA

Figure 4.4: Configuring Date, Time and Location of the Data Logger

In order to view the data logger location in GIS programs or Google Earth™, you can set the data logger location
(not altitude) either automatically via a GPS device, or manually by entering latitude, longitude, and altitude in
the appropriate fields. Enter latitude and longitude in the decimal format (dd.dddddd°), not in degrees and
minutes (dd°mm.mmmm′, like GPS) nor in degrees, minutes, and seconds (dd°mm′ss.ss″).

After downloading the KML file, you can open the file in Google Earth™.
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Figure 4.5: Data Logger Location displayed in Google Earth™

Change Passwords: User passwords can be changed here. To do so, select a user name (role) from the drop-down
list and enter the new password.

Change	Passwords

Username
Admin

New	password
Show	password

Change	password

Figure 4.6: Changing Passwords
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Warning
Be aware that due to security reasons it is not possible to reset passwords. If you loose a modified
Admin password, there is no way to recover it, not even for Ammonit. In this case, return the data
logger to Ammonit. Only Ammonit is able to restore the original passwords.

Note
Only the first eight characters of the password are significant, i.e., Ammonit_1 and Ammonit_2
would be treated the same. Eight characters give the choice of at least 10¹� variations.

Signing and Encryption Files send by Meteo-40, such as CSV data or logbook files, can optionally be digitally signed
or encrypted using GnuPG. The signature guarantees, that the files have been really produced by a specific
data logger and not been altered. The encryption ensures, that nobody can open the files without the right
password.

Signing	and	Encryption

	Unsigned	and	unencrypted
	Sign	data	(GnuPG)
	Sign	and	encrypt	data	(GnuPG)

Encryption	password:
••••••••••••• Show	password

Fingerprint:
ABCD	ABCD	ABCD	ABCD	ABCD	ABCD	ABCD	ABCD	ABCD	ABCD

	Force	encryption
Save

Download	public	key	(GnuPG)

enable to prevent any
unencrypted access to data

required for signature verification

select security level, signing is recommended

enter a password for file encryption

download public key for import in client

Figure 4.7: Signing and Encryption

For additional security, the user Admin can set the option Force Encryption. If this option is set, users other
than Admin have only restricted access to measurement data:

• CSV files can only be downloaded in encrypted form.
• CSV files can only be copied to USB flash drive in encrypted form.
• Live data can be seen only for 2 minutes on the web interface, but still unlimited on the LC display.
• Source data cannot be downloaded nor copied to USB flash drive.
• Data transfer settings (AmmonitOR, Email, FTP/SCP, SCADA) cannot be changed.

Note
The signature for a CSV file refers to the canonical, uncompressed CSV file. Before version 1.4.2,
the signature referred to the compressed CSV file as sent by the data logger, however.

Note
If the Meteo-40 data logger has been produced before 2014-08, the digital signature is not available,
only encryption (since firmware version 1.0.1). Please contact Ammonit, if digital signature is required
on a previously purchased data logger.

Allow Manufacturer Administration In some cases it is necessary that Ammonit developers have access to your
data logger to check configurations or to modify any settings. The mode is only used for maintenance purposes.
Activate the Manufacturer Administration mode to allow Ammonit developers accessing your data logger.

© 2011 — 2017 Ammonit Measurement GmbH 39



By default the Manufacturer Administration mode is inactive.

Allow	Manufacturer	Administration

	Allow	manufacturer	administration
Save

Figure 4.8: Allow Manufacturer Administration

Important
Without your permission, Ammonit will never access any of your data loggers!

Reset Data: In order to delete all measurement data in one step, click on Delete all measurement data. The user will
be asked to approve a confirmation prompt.

Help Logout
Admin	on	Meteo-40	Site	1	D171234

URL:	http://d171234.local/confirm/format

Are	you	sure,	you	want	to	delete	all	measurement	data?
No,	cancel

Yes,	delete

Recording: Off Switch	on

Configuration: Saved Save
Connection: ETHERNET,	Tunnel
Remaining: ∞
Date/time: 2017-05-11	15:08:05	UTC+01:00

Confirm	Memory	Format
If	you	click	"Yes",	all	source	data	will	be	deleted!

Figure 4.9: Deleting All Measurement Data

Important
Recording stops after deleting measurement data. Start recording by clicking Switch on in the status
box.

In order to delete all configurations, passwords and measurement data, click on Factory reset, delete all data.
The data logger will be set back to the condition at delivery. The user will be asked to approve a confirmation
prompt before the reset is performed.
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Help Logout
Admin	on	Meteo-40	Site	1	D171234

URL:	http://d171234.local/confirm/factory_reset

Are	you	sure,	you	want	to	delete	all	settings	and	measurement	data?
No,	cancel

Yes,	delete

Recording: Off Switch	on
Configuration: Saved Save
Connection: ETHERNET,	Tunnel
Remaining: ∞
Date/time: 2017-05-11	15:08:17	UTC+01:00

Confirm	Factory	Reset
If	you	click	"Yes",	all	settings	and	data	will	be	deleted!

Figure 4.10: Factory Reset

Note
After performing a factory reset, recording stops. Recording can be started after at least one sensor
has been configured.
The data reset is logged in the Meteo-40 logbook.

Scanning disk for errors Used to scan the file systems of the data logger. Perform the scan only on demand of
Ammonit. For further details, ask the Ammonit developers.

4.3 Upgrade Data Logger Software

The development of Meteo-40 is in constant process. Ammonit is continually adding new features to the data logger
according to user needs.

Important
In order to perform a software upgrade, the data logger has to be connected to the Internet, e.g., via modem
or LAN or using the tethering function of a mobile phone (Section 4.3.1). It is not sufficient to connect Meteo-
40 to a PC over USB, because a PC is not necessarily configured to work as a router.
You have to be logged in as Admin to perform an upgrade.
If you do not have an Internet connection, you may upgrade the data logger offline, using a USB flash drive.
See Section 4.3.3 for details.

Update software list: In this step the data logger browses for updates and displays the number of available software
packages. Below the progress bar the currently installed version is displayed; the latest version describes the
available upgrade.

Note
The new software itself will not be downloaded and installed after clicking on Update software list.
The software version is not changed in this step!
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Update	software	list

Update	software	list

Installed:	1.6.4	Rev.	24.	Latest:	1.6.5	Rev.	4.
Required	download:
5	Packages,	1.060	MiB
Upgrade	data	logger	software

Download	software

Install	software

	

	

	

100%

0%

0%

check for software upgrade

software upgrade for download with size

Figure 4.11: System Upgrade

Upgrade data logger software: The software upgrade can easily be performed by pressing the Upgrade data logger
software button. The software packages will be downloaded and installed.

After the installation is completed, CECS is restarted.

Note
In older firmware versions the data logger has to be restarted after the upgrade. Press the Restart
data logger button.

Important
Before upgrading the data logger via modem, make sure that the corresponding switch is configured
correctly in the Communication → Modem menu of the data logger web interface.
Depending on the installed firmware version, the software packages needed for the upgrade can be
large. So the download and installation process can take some time depending on the speed of your
Internet connection.
In rare cases the progress bar in the Meteo-40 web interface may seem to have stopped. Wait! If
the progress bar does not move for a certain time, we recommend restarting the upgrade process.
Do not disconnect the power supply or reboot the system during the whole upgrade process.
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Update	software	list

Update	software	list

Installed:	1.6.4	Rev.	24.	Latest:	1.6.5	Rev.	4.
Required	download:
0	Packages,	1.060	MiB

Upgrade	data	logger	software

Download	software

Install	software

	

	

	

100%

100%

50%

progress of download

progress of installation

start download and installation

Figure 4.12: System Upgrade

4.3.1 Upgrading Meteo-40 using a Smartphone

The Meteo-40 data logger can only be upgraded, when the data logger is connected to the Internet.

By connecting your smartphone to the data logger, you can set up an Internet connection via the tethering function of
the smartphone.

Connect your smartphone to your Meteo-40 data logger via USB (USB-A slot of the data logger and micro USB slot
of the smartphone). Make sure, that the data logger has no Ethernet LAN connection during the procedure, i.e. in
doubt just unplug the Ethernet cable from the data logger. Open the settings for Tethering and portable hotspot of the
smartphone operating system (see Figure 4.14) and activate USB tethering.

Important
Before starting the upgrade via tethering, make sure that Use DHCP for wired network is selected in the
Communication → LAN menu of the Meteo-40 web interface. Additionally, make sure Connect to Internet
via modem only is not selected in the Communication → LAN menu of the Meteo-40 web interface.

File Edit View Go Bookmarks Tabs Help

Back https://d130080.local/communication/lan/

usb0 Unavailable Unknown
eth0 Activated 192.168.12.61

 LAN online, whenever CECS is on

 Use DHCP for wired network

 Connect to internet via modem only (recommended e.g. for SCADA)

LAN switch (typically S1):
S3

IP address
192.168.40.40

DNS server
192.168.40.1

Gateway
192.168.40.1

Subnet mask
255.255.255.0

Additional subnets

Save

System
Information
Administration
Upgrade
Display
Web Camera
Switches
Logbook

Measurement
Sensors
Channels
Evaluation

Data
Live
Statistics
Source

Communication
Schedule
Online
AmmonitOR
Email
FTP/SCP
SCADA
LAN
WLAN
Modem

important settings for upgrade via tethering

Figure 4.13: Settings for Firmware Upgrade via Tethering

Browse for the IP address of your Meteo-40 data logger using the keys (Communication → Devices → LAN → USB
(Activated) → IP settings). Enter the data logger’s IP address in your smartphone browser, login and perform the
upgrade.
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Figure 4.14: Tethering Settings of an Android™ smartphone

Tip
The tethering function can also be very useful for remote servicing.

4.3.2 Software Upgrade Behind a Firewall

For most firewalls, that allow outgoing HTTPS and HTTP traffic, no special configuration is needed. Only in some
very restrictive environments, you may need to configure your firewall for the Meteo-40 software upgrade or ask your
network administrator to do so. If Meteo-40 is in a separated subnet, you may also need to specify a Gateway in the
LAN settings of the data logger.

Meteo-40 needs to connect the server archive.ammonit.com via HTTPS (port 443, since version 1.5) or HTTP (port
80, before version 1.5) as outbound connection to perform a software upgrade. Make sure, that these connections
are allowed. There is no need for Meteo-40 to connect any other servers, use any other protocols or use any kind of
inbound connections.

4.3.3 Offline Upgrade using USB Flash Drive

Warning
Note, that this method is not the preferred software upgrade method. If possible, please use the online
upgrade method.
Make sure, you have saved all your data and your configuration before performing an offline upgrade.

4.3.3.1 Prepare the Offline Upgrade

1. Make sure, the data logger has version 1.6 or higher. Older versions of the data logger software do not support
offline upgrade.

2. Make sure, the software version you like to upgrade to is actually newer than the software version already
installed on the data logger. Downgrades are not supported. Always use the latest offline update image from
Ammonit, because errors of older versions might be fixed!

3. You need a prepared USB flash drive of at least 512 MiB capacity. The flash drive must formatted as FAT32.
The file meteo-40.bin must be placed in the top-level of the flash drive, not in a directory. You will get the file
on request from Ammonit.
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4.3.3.2 Performing the Offline Upgrade

1. Switch off the CECS of the data logger. In doubt, remove the power supply.

2. Plug the prepared USB flash drive into one of the two USB-A slots of the Meteo-40.

3. If necessary, reconnect the power supply of the data logger. Switch on the CECS.

4. You will see the following text on the LC display:

Found image
for USB upgrade.

Press the > button
to proceed.

Figure 4.15: Press the right arrow button

You have to press the right arrow button within ten seconds, otherwise the boot process continues normally and
no upgrade will be performed.

5. For around half a minute, the following message appears:

Reading
image for
USB upgrade.

Please wait...

Figure 4.16: Reading the image

Warning
After that step interrupting the process, unplugging the USB flash drive, or a power failure can lead
to an non-functional data logger!

6. The complete process takes around eight minutes, until the following message appears:

SUCCESS:
Remove power plug,

wait 3s, and
remove USB drive.

Figure 4.17: Successful upgrade

which should be performed accordingly: Remove the power supply of the data logger, wait at least three sec-
onds, remove the USB flash drive, and re-enable the power supply of the data logger.

4.4 The Device Page

4.4.1 Display Access

The display page shows, what can be seen on the LCD.
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>	System												
		Status												
		Channels										
		Communication					

Remote	Display

Figure 4.18: Remote Display

In order to give users without access to the web interface the chance of configuring the data logger, permissions of
display users can be selected, e.g., switch on recording or (de-)activate W-LAN.

Display	Settings

Permissions	of	Display	User
	Change	CECS	mode
	Switch	between	DHCP,	static	IP,	and	link-local
	Switch	off	recording
	Switch	on	recording
	Change	the	state	of	switches
	(De-)	Activate	WLAN
	Run	an	action,	e.g.	go	online

Other	Settings
	Activate	display	backlight
Save

Figure 4.19: Display Settings

Note
To view the display in the web interface, it is advised to enable JavaScript in your web browser.

4.4.2 Connected USB Devices

Also on the device page, you can find a list of the USB devices, that are currently connected to the data logger and
recognized by it, e.g. a modem, a flash drive, or a camera.

Note
The list of devices is not updated automatically. You have to reload the page to see any changes.
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4.4.3 USB Flash Drive Copy

Meteo-40 offers the possibility to download created CSV statistics files with measurement data (statistics see Sec-
tion 6.3), the source data in CSV format, and/or the logbook in CSV format on an USB flash drive, which is connected
to the data logger. Before you use this function, data logger and USB flash drive have to be configured.

USB	Flash	Drive	Copy

USB	passphrase	(at	least	eight	characters)
•••••••• Show	password

Save	USB	passphrase

Show	USB	Files

enter passphrase to enable
USB flash drive copy,

at least eight characters

show files on USB flash drive

Figure 4.20: Configuring the USB Flash Drive Copy

Important
A file system like FAT32, NTFS, ext4, ext3, or ext2 is required on USB flash drive.

In order to format the USB flash drive with FAT32 on your Windows™ PC, connect the USB stick to the PC. Open the
Windows™ Explorer. Right-click on the USB flash drive shown under Computer. Click on Format... and select FAT32
as File system. Start the formating process.

Figure 4.21: Formatting the USB flash drive (Windows™ PC)

Create a INI file named keyfile.txt, which has to be saved on the USB flash drive used to download CSV files
(statistics and/or source data). This INI file must include the data logger serial number and a password in a the INI file
format. The INI file is necessary to prevent unauthorized data download. Example:

[D123456]
password = yoursecretpassword
statistics = all

Note
The passphrase for the USB stick must have at least 8 characters!
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The passphrase has to be entered in the field shown in Figure 4.20.

It is possible to use one USB flash drive for several data loggers. To do so, in the keyfile.txt the details of the
data loggers have to be entered section by section, e.g.,

[D123456]
password = passwordone
statistics = since 2016-01-01
gustdata = since 2016-01-01
config = save
logbook = all

[D234567]
password = passwordtwo
statistics = newest 10
config = save
sourcedata = all

[D345678]
password = passwordthree
statistics = month 2016-01
config = save
sourcedata = day 2016-01-07

The following entries are possible:

password Mandatory, must have at least eight characters

statistics One of the time period values, see below. Copies the primary statistics files.

secondary One of the time period values, see below. Copies the secondary statistics files.

tertiary One of the time period values, see below. Copies the tertiary statistics files.

config Value save to copy the configuration file. Other values are not yet implemented.

logbook One of the time period values, see below.

gustdata One of the time period values, see below.

sourcedata One of the time period values, see below.

Warning
Copying source data may take a very long time, even some hours.

The time period values are:

all Copy all files of this type.

since DATE Copy files of this type since and including DATE in format YYYY-MM-DD.

until DATE Copy files of this type until and including DATE in format YYYY-MM-DD.

month DATE Copy files of this type in the month of DATE in format YYYY-MM.

day DATE Copy files of this type at the day of DATE in format YYYY-MM-DD.

newest NUMBER Copy newest files of this type, max. NUMBER.

oldest NUMBER Copy oldest files of this type, max. NUMBER.

Meteo-40 has to be switched on for download. If the USB flash drive is configured correctly, it will be recognized by the
data logger. If the passphrase, entered in the web interface and in the keyfile.txt does not match, data download
is not possible.

Meteo-40 shows in its display the number of downloaded files. When the download is finished, the data logger menu
is shown and the USB flash drive can be disconnected.

By using this function, always all available files are copied to the USB flash drive. All data files are compressed to
keep them as small as possible.
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Note
If encryption and/or digital signature is switched on for the data logger, copying to the USB flash drive
behaves accordingly, i.e. data will be encrypted and/or signed.
If the Force Encryption option is enabled, copying source data to USB flash drive is prohibited.

4.4.4 Access to USB Drive Files

4.5 Using a Camera

It is possible to connect either a USB webcam to one of the two USB-A slots of the Meteo-40 data logger or to access
an Ethernet connected camera by HTTP/HTTPS.

You can send the image to AmmonitOR, as an email attachment, or copy it to an FTP/SCP file server. See the respec-
tive checkboxes in the Communication → AmmonitOR, Communication → Email, and Communication → FTP/SCP
submenus.
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Help Logout
Admin	on	Meteo-40	Site	1	D171234

URL:	http://d171234.local/system/camera/

Current	Camera	Image

Camera	Image	Settings
Camera	Image	URL:
http://192.168.12.34/image.jpeg
	Copy	Camera	Image	to	USB	Drive
Save	camera	settings

Recording: Off Switch	on
Configuration: Saved Save
Connection: ETHERNET,	Tunnel
Remaining: ∞
Date/time: 2017-05-11	15:36:54	UTC+01:00

Camera

Meteo-40
System
Information
Administration
Upgrade
Device
Camera
Switches
Logbook

Measurement
Sensors
Channels
Evaluation

Data
Live
Statistics
Gusts
Source

Communication
Schedule
Online
AmmonitOR
Email
FTP/SCP
SCADA
LAN
WLAN
Modem

中文(简) 	 English 	 Español 	 Português 	 Français 	 Deutsch 	 Türkçe ©	2011-2017	Ammonit	Measurement	GmbH
www.ammonit.com

Figure 4.22: Camera Image

If one or more photos should be taken by an outdoor camera, enter the URL of the photo in the web interface. The
URL depends on the installed camera, e.g., http://nn.nn.nn.nn/ or https://nn.nn.nn.nn/. In doing so,
Meteo-40 will attach a photo to the measurement data.

In general, it is recommended to use a static IP address for both the camera and Meteo-40. You need to configure
both data logger and camera to two different addresses in the same network, e.g. 10.13.0.197 for the camera and
10.13.0.200 for the data logger. In this case, the netmask would be 255.0.0.0. DNS and servers and gateways
are not relevant here.

For example, a Mobotix M25M camera image URL typically is http://10.13.0.197/record/current.jpg.
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Camera	Image	Settings

Camera	Image	URL:
http://192.168.12.34/image.jpeg
	Copy	Camera	Image	to	USB	Drive
Save	camera	settings

enter URL of camera
to attach photos to data

copy camera image to
USB flash drive, if present

Figure 4.23: Attaching Camera Images

Important
If you connect the cammera via Ethernet, configure both devices, Meteo-40 and camera, with a static IP
address. In order to configure the camera, use the software delivered with the camera. The static IP
address of Meteo-40 can be configured in the Communication → LAN menu (see Section 7.7).
If a modem is connected to Meteo-40 and Ethernet is used for the camera, it is necessary to select Connect
to Internet via modem only in the Communication → LAN menu.

Note
If the camera should be used for monitoring purposes, a steady power supply has to be connected.

4.6 Configuring Switches

Switches can be used to control and optimize the power consumption of the measurement system. External devices
connected to Meteo-40, such as modem, camera or heating can be controlled via the data logger. Meteo-40 will close
(turn on) the configured switch when the correspondig device is needed, e.g., to send data via the modem connection,
and open it again (turn off) when not needed.

In a solar power plant, a switch can be used to orient the solar trackers for protection of the payloads in case of high
wind.

Meteo-40L data logger provides eight switches intended for the following tasks:

• Control the modem power supply (recommended). See Section 7.9 for GSM and Section 7.7 for satelite.
• Control camera power supply. See Section 7.7.
• Toggle sensor’s power supply in case the polling rate is very low. See Switch Pretime in Section 5.1.4 and follow

sensor specifications.
• Control of the selected switch according to the configured measurements and thersholds Section 4.6.1.

A switch can only fulfill one of the duties. It can either be shared between several sensors or used to control modem’s
power supply or at the Switch Manager.

To manually toggle one or more of the switches individually, go to the System → Switches menu.
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Switches

Id

Id

Label

Label

State

State

Action

Action
S1 Modem Off Turn	on
S2 LAN Off Turn	on
S3 Off Turn	on
S4 Off Turn	on
S5 Off Turn	on
S6 Off Turn	on
S7 Off Turn	on
S8 Off Turn	on

switch id
change state

current state

label of
corresponding

device

Figure 4.24: Switch Configuration

Warning
We highly recommend configuring a switch for the modem in the Communication → Modem menu. If the
modem is switched manually via the System → Switches menu, you risk the shutdown of the modem after
rebooting the data logger or after problems with the power supply.
In Meteo-40 firmware version higher than 1.0 Rev.13915 switch S1 is set by default for the modem. In case
the switch is not used for the modem, it can be deselected.

Note
Refer to Chapter 13 for more information about physically connecting the supply using a switch.

4.6.1 Switch manager

The Switch manager is designed to autimatically toggle a switch deppending on measured temperature, humidity,
voltage and/or wind speed values. It is commonly used for sensor’s heating control. In order to use this function,
select a switch as well as one or more switching conditions. Only configured sensors and free switches are listed. If
more than one condition is configured, the switch will only be closed (i.e. On) when all conditions are fulfilled. If the
inverted logic is selected, the switch will remain closed as long as the conditions are not fulfilled.

The state of the selected switch is reviewed according to the values calculated at the end of the configured statistics
interval for SCADA, Switch manager and snaphots in the Data → Statistics menu. The default statistics interval is 10
min. The average value is used for temperature, humidity and voltage whereas the maximum is used for wind speed.

Important
It is necessary to have the CECS always on if the switch manager is deployed. The state of the switch
can only be closed (i.e. On) when CECS is running, i.e., to perform an action (see Section 7.2) or if CECS
is configured to be Always on (see Section 4.2). On CECS shut down, the selected switch is is opened
(turned Off).
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Switch	Manager

Managed	switch
None

	Invert	switch	behaviour
Label:
Switch	Manager
Temperature
None

Minimum	temperature	(°C)
-10

Maximum	temperature	(°C)
2

Humidity
None

Minimum	humidity	(%)
70

Voltage
None

Minimum	voltage	(V)
0

Wind	speed
None

Minimum	wind	speed	(m/s)
20

Save

Figure 4.25: Switch Manager

If the sensor heating should be supplied by an external power supply via relay, check the connection plan Figure 13.17.

4.7 Using the Logbook

Events, which are not related to measurement data, are listed in the logbook. The logbook displays for example all
user logins and the user’s IP address. A calendar is shown with a monthly overview. Green highlighted boxes indicate
days with logbook entries. By clicking on the day, the entries are displayed. Click on the arrows shown above the
calender to go to the previous or next month.

It is also possible to add entries to the logbook, e.g., to record replacements of sensors or any maintenance work that
is important for data interpretation. Record messages by clicking on Log a message. A short text message can be
edit.

Logbook entries of a day can be downloaded by clicking on the Download button.
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2017 01 02 03 04 05

◁ 2015-06
Mon Tue Wed Thu Fri Sat Sun

1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 	 	 	 	 	

Date/Time
Date/Time

Message
Message

Measurement	and	Recording	Errors

RS485_TIMEOUT

Reset	measurement	errors

▶

Log	a	message Download Download	month Download	year Download	all

Figure 4.26: Logbook

MARS errors are indicated by the red LED (second from bottom). A detailed list containing error codes is reported
below Measurement and Recording Errors. By clicking on Reset Measurement Errors the list of errors can be deleted.

Note
The MARS error codes can be important for Ammonit engineers to locate errors in the data logger.

4.7.1 Logbook Events

The following actions or events are logged to the logbook:

• User note to logbook
• Log in of a user and failed login attempt
• Factory reset
• Memory format
• Setting date and time via GPS, NTP, EKO sun tracker, SCADA or Admin (manually)
• Setting location via GPS or EKO sun tracker
• Copying data to USB flash drive
• Software upgrade
• Password reset by manufacturer
• CECS start/stop
• Actions execution
• Actions initiated by a short message (SMS)
• RS485-M Serial Console
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Chapter 5

Measurement

5.1 Sensor Configuration

5.1.1 Difference between Sensors, Channels, and Evaluations

To have a better understanding of the sensor management, it is important to know the difference between sensors,
channels, and evaluations.

In general, a sensor is an electro-mechanical device, which records physical values. The physical values are trans-
formed into an electrical value by the sensor. For example, wind speed can be transformed into a frequency. To map
these electrical values on the corresponding physical values, an evaluation process has to be performed.

A sensor may be connected to more than one electrical channel of Meteo-40. The number of used electrical channels
depends on the kind of sensor and also on the kind of electrical wiring of the sensor. For example, wind vane POT
(potentiometer) may use the two analog channels A1 and A2. Another example is the pyranometer Delta-T SN1 that
emits two analog voltage signals and one digital status signal. The two analog output signals have to be connected to
two analog voltage channels and the digital status signal has to be connected to one digital input.

The evaluation process of the measured values is done by the software of the Meteo-40 data logger. Both pieces of
data are saved: the measured physical value at every channel and the evaluated value. Some typical formulas are
displayed below.

Most anemometers deliver a rectangle pulse output signal with a frequency proportional to the instant speed. Con-
necting it to a counter input (i.e., C1 to C12), its frequency will be measured. For the evaluation of wind speed a linear
formula will be applied using slope and offset values given in the configuration of the Measurement → Sensors menu.

vwind =

{
slope · Cx+ offset : Cx > 0
0 : Cx = 0

Equation 5.1: Linear Equation for Wind Speed

A counter value of 0 will always result in 0, i.e. the offset is ignored in this case.

The output signal of many pyranometers is an analog voltage. To measure and record this signal, the output of the
pyranometer should be connected to an analog voltage input (i.e., A1 to A12). To interpret the value of the apparent
solar radiation, the measured value is internally divided by the specific sensitivity of this sensor. In this case sensitivity
has to be configured.

5.1.2 Configuring Sensors

In the Measurement → Sensors menu, sensors can be added and basic parameters can be configured by using the
Sensor Helper (see Section 5.1.4). At the resulting list of sensors, two buttons are visible on the right side of each row:
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Delete and Change. These allow a user to delete the sensor or to change the existing configuration with the Sensor
Helper.

Label
Label

Type
Type

Model
Model

Height
Height

Serial	No.
Serial	No.

Rate
Rate

Channels
Channels

Change
Change

Delete
Delete

Top	Anemometer Anemometer Thies
Anemometer
First	Class
Advanced

120 1	s C1 Change Delete

Backup
Anemometer

Anemometer Thies
Anemometer
First	Class
Advanced

118 1	s C2 Change Delete

Middle
Anemometer

Anemometer Thies
Anemometer
First	Class
Advanced

60 1	s C3 Change Delete

Low	Anemometer Anemometer Thies
Anemometer
First	Class
Advanced

10 1	s C4 Change Delete

Top	Wind	Vane Wind	Vane Thies	Wind	Vane
10	Bits	Serial
Synchron

120 1	s D1 Change Delete

Backup	Wind
Vane

Wind	Vane Thies	Wind	Vane
10	Bits	Serial
Synchron

118 1	s D2 Change Delete

Low	Wind	Vane Wind	Vane Thies	Wind	Vane
10	Bits	Serial
Synchron

60 1	s D3 Change Delete

Hygro/Thermo
@10.0m

Hygro/Thermo Galltec	Hygro-
Thermo	Active	KP

10 1	s A1,	A2 Change Delete

Barometer
@10.0m

Barometer Barometric
Pressure	Sensor
AB60

10 1	s A3 Change Delete

Add	sensor

Undo

Delete	all	sensors

RS485-M	serial	console

sensor
label

sensor
type

sensor
model

installation
height

change
settings

sensor
serial

number
measurement

rate

delete all sensors in one step

delete
sensor

sensor
channels

add sensor with sensor helper

Figure 5.1: Sensor Definitions

Below the sensor definitions overview you can find four buttons: Add sensor, Undo, Delete all sensors and RS485-M
serial console.

Add sensor: Opens the Sensor Helper to configure a new sensor.

Undo: Click on this button to undo your last action.

Delete all sensors If all sensors should be deleted, e.g., after a completed measurement campaign, you can click on
Delete all sensors to remove all sensors from the configuration in one step.

RS485-M serial console Occasionally send a command to a sensor connected to the RS485 Master port. This can
be useful for debugging communication problems or to change sensor’s configuration (see Section 5.1.5).

Note
By clicking on a column headline in the sensor definitions overview, you can sort the selected column in
ascending or descending order.
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Important
For some estimations related to solar sensors, the GPS location of the measurement station has to be
added in the System → Administration menu (see also Section 4.2).

Warning
Adding or deleting a sensor, switches off recording. The new configuration is unsaved! By clicking on
Switch on, recording will be activated and the configuration will be saved automatically in one step.

5.1.3 Order of Sensors and Evaluations

The order of sensors and evaluations in the web interface and the LC display is always consistent.

Sensors are ordered by

1. sensor type (anemometers, wind vanes, thermo/hygro sensors, barometers, precipitation sensors, solar sen-
sors, ultrasonics, power meters, other sensors),

2. height (from highest to lowest),

3. and finally the textual label (alphabetically).

Evaluations are ordered by

1. evaluation type (wind speed, wind direction, humidity, temperature, differential temperature, air pressure, air
density, etc.)

2. height of the corresponding sensor (from highest to lowest),

3. and finally the textual label (alphabetically).

5.1.4 Sensor Helper

In order to simplify the configuration of sensors, Meteo-40 offers a Sensor Helper in the Measurement → Sensors
menu. The Sensor Helper is a wizard, which guides you through the sensor configuration. It can be started by clicking
on Add sensor or Change.

Note
The Sensor Helper also starts by clicking on Change in menu Measurement → Channels and in menu
Measurement → Evaluation.

The sensor helper provides a list of various sensor types (e.g., anemometer, wind vane, barometric pressure sensor,
solar sensor, etc.) with common models. If the sensor is given in the list, the appropriate channel settings for each type
are selected automatically as shown in Figure 5.2. Depending on the sensor, further settings can be configured, e.g.,
Slope, Offset, Sensitivity, etc. Additionally, measurement rate, channel as well as switch and switch pretime
(if necessary) can be selected or changed.

Note
The sensor helper offers only channels and switches, which are not used for other sensors.
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File Edit View Go Bookmarks Tabs Help

Back https://d110017.local/helper/sensor?sensor_type=anemometer&sensor_model=Thies+Anem

Help Logout
(Admin on D110017)

Sensor type:
Anemometer

Sensor:
Thies Anemometer First Class Advanced

Installation height (m):
100

Label:
Top Anemometer

Serial number:
xxxxxxxxx

Wind Speed Slope (m/s/I), e.g. ~0.0462
0.0462

Wind Speed Offset (m/s), e.g. ~0.21
0.21

Measurement rate:
1 s

Counter Channel:
C1

Add more

Finish

Recording: On Switch off

Configuration: Saved Save

Connection: Ethernet,Tunnel

Remaining: ∞

Sensor Helper

System
Information
Administration
Upgrade
Display
Web Camera
Switches
System Log

Measurement
Sensors
Channels
Evaluation

Data
Live
Statistics
Source

Communication
Schedule
E-Mail
Online
FTP/SCP
SCADA
LAN
WLAN
Modem

中文(简) English Español Português Français Deutsch Türkçe © 2011-2012 Ammonit Measurement GmbH
www.ammonit.com

select sensor type

choose sensor from a list 
of common models

enter values from 
calibration protocol

select measurement rate

assign channel(s) for 
selected sensor

Figure 5.2: Sensor Helper with Sensor Settings

Important
For many sensors slope and offset values are pre-configured according to the manufacturer’s information.
Carefully check the values. If calibrated sensors are installed, use the slope and offset resp. sensitivity
values indicated in the calibration protocol of the sensor.

If the desired sensor is not given in the list, it is possible to configure the sensor manually. In this case select Other
Sensor in the Sensor Helper. Afterwards choose between analog current, analog voltage, counter input or status input.

5.1.5 RS485 Master Serial Console

During the installation process or in case of communication problems, it can be useful to send a special command to
a connected RS485 sensor.
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Send	Request	over	RS485-M

Protocol:
ASCII

Modbus	address
1

Modbus	start	register	(0..65535)
0

Modbus	register	quantity	(1..20)
1

Modbus	function	code
3

Command:

Latest	Response:
Not	available

Send	request

RS-485	master	general	configuration
RS-485	speed:
19200	bps

RS-485	data	format:
8N1

Save	serial	setting

Figure 5.3: RS485-M Serial Console

First of all, the RS485 Master general serial settings must be set matching sensor’s configuration. These settings
affect not only the serial console but any other RS485 sensor configured.

If Modbus protocol is selected, the telegram will be internally composed, according to the selected address, start
register (PDU addressing, first reerence is 0), register quantity and function code, and shown in the command box.
If ASCII protocol is selected, the command must be typed by the user in the command box. The following escape
sequences representations are recognized for the ASCII commands:

Escape Sequence Symbol
<CR> \x0d
<LF> \x0a
<STX> \x02
<ETX> \x03

Table 5.1: ASCII escape sequences for RS485-M serial console

The communication will be reflected in the logbookincluding a timestamp. Example of ASCII communication: ”RS485-
M Request: ’01TR00003<CR>’, Response: ’<STX>000.1 096 +24.6 M 0E*1D<CR><ETX>’”. Example of Modbus
communication: ”RS485-M Request: ’0104277400063aa6’, Response: ’01040c41375c2942c0000041e800006d3d’”.
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Note
The RS485-M serial console is only available for Admin.

5.2 Measurement Channels

In the Measurement → Channels menu a table is shown, which displays all connected channels with details such as
label, value, rate, range, protocol and selected switch. To modify sensor settings, click on Change to start the Sensor
Helper (see also Section 5.1.4).

Id
Id

Label
Label

Value
Value

Unit
Unit

Rate
Rate

Range
Range

Protocol
Protocol

Addr.
Addr.

Sw.
Sw.

Switch
Switch

Sw.	Pretime
Sw.	Pretime

Change
Change

A1 Hygro/Thermo
@10.0m

4.832 V 1	s -10	V..+10	V Change

A2 Hygro/Thermo
@10.0m

0.39140 V 1	s -1	V..+1	V Change

A3 Barometer
@10.0m

5.2776 V 1	s -10	V..+10	V Change

C1 Top	Anemometer 23 I 1	s Change
C2 Backup

Anemometer
17 I 1	s Change

C3 Middle
Anemometer

0 I 1	s Change

C4 Low	Anemometer 0 I 1	s Change
D1 Top	Wind	Vane 0 1	s Thies	10-

Bit Change

D2 Backup	Wind	Vane 0 1	s Thies	10-
Bit Change

D3 Low	Wind	Vane 0 1	s Thies	10-
Bit Change

Digital	test

channel id

sensor label

current
value

measurement
unit

change
settings

switch
pretime

used switch

switch active

Modbus
address

measurement
range

measurement
rate

used
protocol

Figure 5.4: Measurement Channels Overview

Note
Click on a column headline in the measurement channels overview to sort the selected column in ascending
or descending order.

5.3 Configuring the Evaluation

In the Measurement → Evaluation menu the settings for data evaluation are shown. A table displays the configured
sensors with their measured and estimated values. The order of evaluations is explained in Section 5.1.3. If the
settings should be modified, click on Change to start the Sensor Helper (see also Section 5.1.4).
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Label
Label

Evaluation
Evaluation

Origin
Origin

Value
Value

Unit
Unit

Slope
Slope

Offset
Offset

Clip
Clip

Change
Change

Top
Anemometer

Wind	Speed C1 21.300 m/s 0.0462 0.21 Change

Backup
Anemometer

Wind	Speed C2 20.100 m/s 0.0462 0.21 Change

Middle
Anemometer

Wind	Speed C3 0.0000 m/s 0.0462 0.21 Change

Low
Anemometer

Wind	Speed C4 0.0000 m/s 0.0462 0.21 Change

Top	Wind	Vane Wind	Direction D1 0.0000 ° 0.3515625 0 Change
Backup	Wind

Vane
Wind	Direction D2 0.0000 ° 0.3515625 0 Change

Low	Wind
Vane

Wind	Direction D3 0.0000 ° 0.3515625 0 Change

Hygro/Thermo
@10.0m

Humidity A1 81.261 % 100 0 100 Change

Hygro/Thermo
@10.0m

Temperature A2 34.140 °C 100 -30 Change

Barometer
@10.0m

Air	Pressure A3 960.654 hPa 60 800 Change

Add	evaluation

sensor
label

type of
evaluation

configured
channels

current
value

change
settings

measuring
unit

evaluation
parameters

Figure 5.5: Screenshot of the Configuration for the Evaluation

In order to combine evaluations, new evaluations can be added in the Evaluation Helper by clicking on Add evaluation.
See Section 5.3.1.

Important
Only the measured values are saved by default to the CSV statistics file. Estimated values are for infor-
mation purposes. In order to save estimated values to the CSV statistics file, select the values in the Data
→ Statistics.

Note
Click on a column headline in the evaluation configuration overview to sort the selected column in ascending
or descending order.

5.3.1 Evaluation Helper

In order to add evaluations, which combine already configured evaluations, click Add evaluation in the Measurement
→ Evaluation menu. Select from a list of formulas, e.g., linear equation, differential temperature, density of moist air.

5.3.1.1 Linear equation

The linear equation can be applied to any existing evaluation in order to apply an slope and offset. It can also be
used to provide a dimensionless measurement (e.g. from a previously configured Other sensor) with a unit and an
evaluation type for better interpretation.
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Note
The original evaluation can be removed from the CSV files if so configured in Figure 6.4.

5.3.1.2 Differential temperature

By selecting Differential temperature in the Evaluation Helper, the difference between two temperature measurements
can be recorded every second. Choose two temperature sensors from the list for theta 1 and theta 2. According to
the following equation the difference is calculated.

Δϑ[K] = ϑ1[°C] − ϑ2[°C]

Equation 5.2: Calculation of the Temperature Difference [Δtheta]File Edit View Go Bookmarks Tabs Help

Back https://d130080.local/helper/evaluation?formula=temperature_differential&param_1=Eval_9&param_2=Eval_15&label=

Formula:
Differential temperature

ϑ1 - ϑ2

Temperature ϑ1
Hygro/Thermo 1

Temperature ϑ2
Hygro/Thermo 2

Label:
Differential Temperature

Save

Delete

System
Information
Administration
Upgrade
Display
Web Camera
Switches
Logbook

Measurement
Sensors
Channels
Evaluation

Data
Live
Statistics
Source

select formula

choose temperature 
sensor as subtrahend

choose temperature 
sensor as minuend

Figure 5.6: Evaluation for Differential Temperature

5.3.1.3 Density of moist air

According to IEC 61400-12-1 it is required to measure air density, which is calculated from air temperature and air
pressure. Air density has a significant influence on the wind energy calculation. See calculation of wind energy in
Section 10.1.

At high temperatures measuring relative air humidity is recommended according to IEC 61400-12-1. In order to cal-
culated density of moist air, Meteo-40 offers two options: with or without relative humidity.

If air density should be calculated without humidity, choose only a temperature and a barometric pressure sensor from
the list in the Evaluation Helper (see Section 5.3.1). Meteo-40 calculates air density for evaluation with original 1-sec
measurement data according to the following formula:

ρ =
p

R0 · T

Equation 5.3: Calculation of Density [ρ] of Dry Air

(where p is the air pressure, T the air temperature and RO the gas constant of dry air 287,05[J/kgK])

If relative humidity should be considered for air density calculation, choose also a humidity sensor from the list in the
Evaluation Helper (see Section 5.3.1). With selected humidity sensor, Meteo-40 calculates density of moist air for
evaluation with original 1-sec measurement data according to the following formula:
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ρ =
1
T

(
p

R0
− RH · pH2O

(
1

R0
− 1

RH20

))

Equation 5.4: Calculation of Density [ρ] of Moist Air

(where T is the air temperature, p the air pressure, R0 the gas constant of dry air 287,05[J/kgK], RH2O the gas constant
of water vapour 461,5[J/kgK], pH2O the vapor pressure, RH the relative humidity)File Edit View Go Bookmarks Tabs Help

Back https://d120001.local/helper/evaluation?formula=air_density&param_1=Eval_3&param_2=Eval_4&param_3=Eval_2&label=

Formula:
Density of moist air

kg/m^3

Temperature
Hygro/Thermo @20.0m

Air Pressure
Barometer

Humidity
Hygro/Thermo @20.0m

Label:
Density of Moist Air

Save

Delete

System
Information
Administration
Upgrade
Display
Web Camera
Switches
Logbook

Measurement
Sensors
Channels
Evaluation

Data
Live
Statistics
Source

Communication
Schedule
Online
AmmonitOR

select formula

select humidity sensor 
(for complex  calculation)

select barometric 
pressure sensor

select temperature 
sensor

Figure 5.7: Evaluation for Air Density

5.3.1.4 Obukhov length

The Obukhov Length can be useful for turbulences analysis and is typically associated with a 3D ultrasonic sensor.
To add this evaluation, the measurement of wind speed, wind direction, vertical wind speed and virtual temperature at
one height are needed.

L = u*
3 / ( K x g / avg(T) x σ(VZ,T) )

Equation 5.5: Calculation of the Obukhov Length

(where u* is the friction velocity [m/s], g the graviatitonal acceleration 9.81[m/s²], σ(VZ,T) the covariance of vertical
wind speed and virtual temperature and K the von Kármán constant 0,41)

5.3.1.5 Obukhov stability parameter

Dimensionless stability parameter given by the normalized measuring height above ground z with the Obukhov length
L. Can be useful for turbulences analysis and is typically associated with a 3D ultrasonic sensor. To add this evaluation,
the measurement of wind speed, wind direction, vertical wind speed and virtual temperature at one height are needed.

ζ = z / L

Equation 5.6: Calculation of the Obukhov stability parameter

(where z is the height above ground and L is te Obukhov length as in Section 5.3.1.4)
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5.3.1.6 Sensible heat flux

Sensible heat flux measured with the eddy covariance method. In meteorology, the conductive heat flux from the
Earth’s surface to the atmosphere.

QH = ρ x Cp x σ(VZ,T)

Equation 5.7: Calculation of the sensible heat flux

(where ρ is the air density 1.2[kg/m3], Cp the specific heat with constant pressure 1004.67[J/K/kg] and σ(VZ,T) the
covariance between the vertical wind speed and the temperature)

5.3.1.7 Inflow angle

Angle off the horizontal plane at which the wind flow comes into the sensor.

φ = arctan(Vz / Vh)

Equation 5.8: Calculation of the inflow angle

(where Vz is the vertical wind speed and Vh is the horizontal wind speed)
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Chapter 6

Data Evaluation

6.1 Introduction

As soon as Recording in the status box (see Section 3.2) is switched on, Meteo-40 records and stores measurement
data. In order to check current data, the web interface offers the possibility to have a closed look at live data (see
Section 6.2). In the Data menu, measurement data can be downloaded (see Section 6.7 and Section 4.2) and statistics
can be configured, which will be saved as CSV file.

6.2 Live Data Page

This page displays the currently measured data. The data is presented in a table and in a line chart.

Click on Start to display currently measured values. Stop ends displaying data. The table shows the total amount of
available data. In comparison, the line chart can be customized by choosing sensors and connected channels.

Note
Enable JavaScript in your web browser to display live data in a chart.

6.3 Statistic Data Files

In the Data → Statistics menu CSV files with statistics are listed and can be downloaded. Meteo-40 shows a calendar
with available statistics. Click on a month to highlight days with available CSV files. To navigate through the calendar,
click on a month or use the arrows to move one month ahead or back. Click on a highlighted day to list all CSV files,
which have been generated for this day.

To view the available CSV files for a whole month, click on Show month; for a complete year, click on Show year. You
can jump between the years and months by clicking on a month resp. year in the calendar.

All CSV files for the selected period are listed in a table, the file name refers to the time interval covered. For each file,
a link to download the corresponding signature, its size in bytes, the methods through which the file has been shared
and a link to visualize the matching source data are available. To display the source data corresponding to a file, click
on the arrow in the Source column.

Below the list of CSV files it is indicated how many statistics CSV files are currently visible, from the available files in
the data logger, e.g., 1 of 53 files.

If CSV files have been uploaded to an AmmonitOR project, sent per Email or copied to a configured SCP/FTP server,
it will be tagged by a checkmark in the corresponding box.
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To manually download or delete one or more files, select them and Click Download selected or Delete selected re-
spectively. For the download, the CSV files will be compressed in one ZIP file. If you want a certain file to be sent or
copied again, you can also mark the selected files as not sent with the option Mark as not sent

Important
Deleting CSV statistic files does not delete the corresponding source data, statistic files can be generated
again as long as the matching source data are still in the Source data storage.

To immediately generate statistic files form the available source data, click on Generate now. Meteo-40 will generate
new files for the configured file interval, containing a line with the calculated statistics for each statistics interval. For
the standard configuration of daily file interval and ten minutes statistics interval, there will be 144 lines.

If Generate partial files is selected, not only the files for a complete file interval will be generated but also a file with
the residuary data until the moment of the generation. This setting is only recommended for testing porpouses.

Under Maintenace we provide some options for trouble-shooting in case of CSV files generation problems. Delete sent
statistics will replace all existing CSV files which have already been shared in any of the ways (AmmonitOR, Email or
SCP/FTP) with an empty file in order to create more space in the system storage. This process is also automatically
performed on CECS reboot if the available system storage is too low for the normal operation of the system. Try to fix
possibly inconsistent files will check all existing files, search for known incidences and regenerate the files if needed.
This option is only available if the data logger detects any suspicious files.

Download	selected Generate	now Delete	selected

Mark	all	as	not	sent Try	to	fix	possibly	inconsistent	files

Statistics	calendar

2016 06 07 08 09 10 11 12
2017 01 02 03 04 05

2017-05 ▷
Mon Tue Wed Thu Fri Sat Sun

1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31 	 	 	 	

Select
Select

File
File

Sig
Sig

Size
Size

AmmonitOR
AmmonitOR

Email
Email

Copy
Copy

Check
Check

Source
Source

2017-05-10	00:00:00
—
2017-05-11	00:00:00

↴ 36626 ✓ ↴

1	of	333	files

Show	month Show	year

◀

Figure 6.1: Downloading Statistics

6.3.1 Configuring Statistics and CSV files

In order to configure statistics and CSV files, go to the Data → Statistics menu. You can define content and interval
of the statistics.

Meteo-40 automatically suggests the standard statistics for each evaluation and channel. Additional statistics can be
selected manually.
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Click on Select statistics in the Configure statistics section to create the statistics, e.g., average, maximum, minimum,
standard deviation, count, sum and median. Tick checkboxes to include evaluators / channels in the statistics. Remove
checkboxes to exclude evaluators / channels. Additionally, Meteo-40 displays internal current and internal voltage in
the CSV files.

Configure	statistics

Statistics	interval	for	files
10	min

File	interval
Daily

	Generate	partial	files
Statistics	interval	for	SCADA,	Switch	manager	and	snaphots
2	s

SCADA	Summary	interval
Every	five	minutes

Save

Select	statistics

Secondary	files

Tertiary	files

Figure 6.2: Configuring the Statistics

The options are:

Select statistics Select individual statistics for every evaluator and channel. See Figure 6.4.
Statistics interval for files Defines over which time interval statistics are calculated, generating a new line in the

CSV file. All current data that has been collected since the last generated file is considered to generate new
aggregate data. Several intervals are available from 1/4s to 1h.

File interval Determines, how often a new aggregate data file in CSV format has to be created. Selecting Hourly,
produces one file per hour that includes data from the last hour. Daily generates only one file per day, etc.
Several intervals are available from every 5 minutes to weekly. The file interval is also applied to Gust data files.

Generate partial files Generate CSV files up to the current moment, even if the file interval has not yet finished.
Statistics interval for SCADA, Switch manager and snaphots Defines over which time interval statistics are cal-

culated. The calculation occurs at the end of the interval and the data are available over SCADA, applied to
Switch manager or sent/copied as a snapshot. All current data from that period is considered to generate new
aggregate data. Several intervals are available from 1/4s to 1h.

SCADA Summary interval Applied only to the Summary statistic of the SCADA Modbus server. Typically used to
obtain a daily summary of sun status or precipitation measurements.

Secondary Files Suplementary statistics files can be generated with a different interval for the statistics calculation.
Secondary statistics can be configured here. See Section 6.4.

Tertiary Files A further suplementary statistics interval can be configured here. See Section 6.4.

Warning
Be careful with setting the statistics interval and the file interval! Low values for the statistics interval lead
to huge statistics files, which you might need to remove manually once in a while. Low values for the file
interval lead to many small CSV files, which might be hard to handle.
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For solar-related evaluations Meteo-40 estimates certain values in addition to the measured values, i.e., estimated
sun status, estimated direct normal irradiation. In order to create the estimated values, the GPS location of the mea-
surement station has to be entered in the System → Administration menu. By default the estimated values are not
included in the CSV file. If required, select the values for the statistics.

Meteo-40 uses vectorial calculations for wind direction, i.e., vectorial average, direction maximum, direction minimum,
and vectorial standard deviation (Yamartino method). Hence, the calculated minimum value for the wind direction can
be higher than the maximum in case of wind from northern directions.

d = atan2

(
n∑

i=1

sin(ϑi),
n∑

i=1

cos(ϑi)

)

Equation 6.1: Calculation of wind direction average

The equation for the average wind direction d is given by Equation 6.1. If d is less than zero, 2π is added.

max. value 5°

90°

min. value 345°

180°

270°

Figure 6.3: Vectorial Calculation for the Wind Direction

Evaluator/Channel
Evaluator/Channel

Avg
Avg

Max
Max

Min
Min

SDv
SDv

Cnt
Cnt

Sum
Sum

Med
Med

Val
Val

Int.	Voltage	(Analog	Voltage)
Int.	Current	(Analog	Current)
Int.	Temperature	(Temperature)
Save

Back	to	statistics

Figure 6.4: Statistics Configuration Page

Press Save to finish the configuration of statistical values.

6.4 Secondary and Tertiary Statistics Files

Sometimes it is necessary, to have additional statistics on top of the standard. E.g. with a different statistics interval
or a different selection of values. You can activate the supplementary generation of statistics files with two different

68 © 2011 — 2017 Ammonit Measurement GmbH



Data Logger Meteo-40 User’s Manual 69 / 234

configurations. The files will be listed in a similar table as the main statistic files (see Figure 6.5 and Figure 6.6). If the
files are generated, they will be automatically sent per Email or AmmonitOR additionally to the main statistic files.

Warning
Beware, that having more CSV files

1. is more work for the data logger, more time and energy is consumed

2. fills the memory of the data logger faster

3. more bandwidth for sending is used

6.4.1 Secondary Statistics Files

Select Generate additional files with secondary interval to activate the generation of the secondary files. You can
configure a statistics interval different from the main statistics interval. To select the statistics which will be calculated
and included in the secondary files, clik on Select statistics.

Download	selected Generate	now Delete	selected

Secondary	statistics	files	calendar

2016 06 07 08 09 10 11 12
2017 01 02 03 04 05

2017-05 ▷
Mon Tue Wed Thu Fri Sat Sun

1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31 	 	 	 	

Select
Select

File
File

Sig
Sig

Size
Size

AmmonitOR
AmmonitOR

Email
Email

Copy
Copy

Source
Source

2017-05-10	00:00:00
—
2017-05-11	00:00:00

↴ 113 ↴

1	of	333	files

	Generate	additional	files	with	secondary	interval

Secondary	statistics	interval
1	h

Save

Show	month Show	year

◀

Select	statistics

Figure 6.5: Secondary Statistics Page
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6.4.2 Tertiary Statistics Files

Select Generate additional files with tertiary interval to activate the generation of the tertiary files. You can configure
an statistics interval different from the main and the secondary statistics interval. To select the statistics which will be
calculated and included in the secondary files, clik on Select statistics.

Download	selected Generate	now Delete	selected

Tertiary	statistics	files	calendar

2016 06 07 08 09 10 11 12
2017 01 02 03 04 05

2017-05 ▷
Mon Tue Wed Thu Fri Sat Sun

1 2 3 4 5 6 7
8 9 10 11 12 13 14

15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31 	 	 	 	

Select
Select

File
File

Sig
Sig

Size
Size

AmmonitOR
AmmonitOR

Email
Email

Copy
Copy

Source
Source

2017-05-10	00:00:00
—
2017-05-11	00:00:00

↴ 113 ↴

1	of	333	files

	Generate	additional	files	with	tertiary	interval

Tertiary	statistics	interval
1	h

Save

Show	month Show	year

◀

Select	statistics

Figure 6.6: Tertiary Statistics Page

6.5 Gust Data Files

Detecting extreme wind events or gusts can be interesting to compare different geographical terrains or to estimate
wind turbines load. Meteo-40 offers the possiblity to genere extra CSV files including the sensible measurement values
with the highest available measurement rate. To generate gusts data files you must activate this option in menu Data
→ Gusts.

One gusts CSV file will be generated per day (or the configured file interval in Data → Statistics menu) including all
wind gusts of that period. If no gust was registered during the period, an empty file is generated. Empty files will not
be visible in the Gust data files calendar but will be listed beneath.

To be considered a gust, the selected trigger evaluationmust exceed the configured threshold value a minimum number
of consecutive repetitons (minimum repetitions parameter) and not more than the selected maximum repetitions. The
gust as well as the previous and posterior number of seconds specified by time overhang parameter are included in
the gusts CSV file (see .
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Download	selected Generate	now Delete	selected

Gust	data	files	calendar

2016 06 07 08 09 10 11 12
2017 01 02 03 04 05

2017-05 ▷
Mon Tue Wed Thu Fri Sat Sun

1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31 	 	 	 	

Select
Select

File
File

Sig
Sig

Size
Size

AmmonitOR
AmmonitOR

Email
Email

Copy
Copy

Source
Source

2017-05-07	00:00:00
—
2017-05-08	00:00:00

0 ↴

1	of	333	files

Show	month Show	year

◀

Figure 6.7: Gust Data Calendar

Not every existing measurement is related to gusts analysis. The relevant evaluations must be selected. Press the
Select evaluations button to access the evaluations selection site and select which evaluations must be included in
gusts CSV files.

Evaluator
Evaluator

Include
Include

Anemometer	(Wind	Speed)
Wind	Vane	(Wind	Direction)
Hygro/Thermo	(Humidity)
Hygro/Thermo	(Temperature)
Save

Back	to	gust	data

Figure 6.8: Gust Evaluations Selection

Important
If the gusts data generation is activated in a running project, all existing source data will be analyzed and
gusts CSV files will be generated. This process could take several hours.

6.6 The CSV File Format

Meteo-40 stores measurement data in standard Comma-Separated Value (CSV) format with appended information
in ini file format. The CSV file is documented in RFC 4180 (http://tools.ietf.org/html/rfc4180) and well

© 2011 — 2017 Ammonit Measurement GmbH 71

http://tools.ietf.org/html/rfc4180


explained, e.g., in Wikipedia (http://en.wikipedia.org/wiki/Comma-separated_values). Ini files are de-
scribed, e.g., in Wikipedia (http://en.wikipedia.org/wiki/INI_file) as well. CSV files can easily be read
by many programs and software tools, as is the ini file format.

Note
In almost all cases, the CSV files created by Meteo-40 are compressed using GNU gzip (http://www.
gzip.org/) with the typical file extension .gz. gzip compressed files can be decompressed on all oper-
ating systems, see, e.g., Wikipedia (http://en.wikipedia.org/wiki/Gzip) for further details.

6.6.1 Ammonit Meteo-40 specific details

The measurement data files of the Meteo-40 use the , (comma) as field separator, " (double quote) for embedding
commas in textual strings and UTF-8 as character set.

The statistics files generated by Meteo-40 data loggers are structured in two parts, the data in standard CSV format
and additional information in so-called ini file format. Both parts are separated by one empty line.

6.6.1.1 Data part (CSV format)

The CSV part starts with a header line. This line is a comma-separated list of the statistics for each active channel
and evaluator. The first item of the list is the date/time entry; followed by the evaluator statistics, which have the
form Sensor;Evaluation;Statistic (e.g., Anemometer;wind_speed;Avg or WindVane10bit;wind_dire
ction;Count). Thereafter, the channel statistics are displayed in the form Channel;Statistic (e.g., A2;Avg or
C1;StdDev).

The following evaluation types are possible:
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wind_speed: Wind Speed,
wind_direction: Wind Direction,
humidity: Humidity,
temperature: Temperature,
temperature_differential: Differential Temperature,
air_pressure: Air Pressure,
air_density: Air Density,
solar_irradiance: Global Horizontal Irradiance,
solar_irradiance_diffuse: Diffuse Horizontal Irradiance,
solar_irradiance_direct: DNI·cosθ,
solar_DNI: Direct Normal Irradiance (DNI),
solar_irradiance_direct_sw: Estimated DNI,
solar_DNIcos_sw: Estimated DNI·cosθ,
sun_status: Sun Status,
sun_status_sw: Estimated Sun Status,
precipitation: Precipitation,
precipitation_intensity: Precipitation Intensity,
precipitation_status: Precipitation Status,
precipitation_sum: Precipitation Sum,
wind_speed_vert: Vertical Wind Speed,
counter: Counter,
voltage: Analog Voltage,
current: Analog Current,
status: Status,
active_power: Active Power,
power_factor: Power Factor,
reactive_power: Reactive Power,
apparent_power: Apparent Power,
obukhov_length: Obukhov Length,
dir_max_speed: Direction at max. Speed,
brightness_max: Brightness max. Value,
brightness_direction: Direction of Brightness,
frequency: Frequency,
inclination_angle: Angle of Inclination,
vibration_frequency: Vibration Frequency,
vibration_amplitude: Vibration Amplitude,
other: Other Evaluation,
any: Any Evaluation

The statistics can individually be selected per sensor in the Data → Statistics menu (see Figure 6.4).

Meteo-40 offers the following statistics:

Avg: Average,
Max: Maximum,
Min: Minimum,
StdDev: Standard deviation,
Count: Count of valid values,
Sum: Summary,
Med: Median,
Val: First valid value

According to the configured statistics interval, Meteo-40 calculates the statistics. Each time period is represented in a
line of the CSV file. The values are generally decimal numbers, using a point (.) as decimal mark.

Language settings of the data logger do not have an influence on the CSV file. In the first column of the CSV file the
date and time for each statistic is given. The date and time is the start time of the statistics interval. Date and time
format are similar to ISO-8601, e.g., 2014-07-17 15:50:00.

The date and time values are always the local time of the data logger. The timezone is stated in the second part of
the file.
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6.6.1.2 Information part (Ini file format)

The information part contains data logger information as well as sensor details like installation height, slope and offset
values, as well as unit and sensor name.

The information part is included in every file. It can be found below the statistical data. The overall format of the
configuration is the following:

[Section 1]
key1=value
key2=value
[Section 2]
key1=value

All section names, keys and values are case-sensitive and may contain unicode characters in UTF-8 encoding. While
sections and values may contain spaces; keys will not. Each section is unique; each key is unique within its section.
Neither the order of sections nor the order of entries within the sections are significant or guaranteed.

• [System]: Serial number in the format

serial=D123456

and type of the data logger in the format

type=Meteo-40L

the assigned name; timezone in the format

timezone=UTC+01:00

(the offset can be positive or negative or be missing, which indicates UTC); the location in decimal degrees and
altitude in meters:

latitude=0.0 longitude=0.0 altitude=0.0

as well as the software version and important system settings, e.g., cecs_power_permanent=true.
• [Summary] comprises the date and time when the CSV file has been created, the used source data storage and

the summary over the file time interval for configured precipitation, precipitation intensity, status and sun status
evaluations.

• [Evaluation] indicates file_interval and stat_interval (see also Section 6.3).
The file_interval, usually daily, can have the following values:
fiveminutes
tenminutes
fifteenminutes
twentyminutes
thirtyminutes
hourly
twohours
threehours
fourhours
sixhours
twelvehours
daily
weekly

The stat_interval, usually 10 min, can have the following values:
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1 s
2 s
3 s
5 s
10 s
20 s
30 s
1 min
2 min
5 min
10 min
15 min
20 min
30 min
1 h

• [Adjustment]: CS1 and CS2 are the calibration values for the current source of Meteo-40. The values are for
informational purpose only.

• [Master]: The rate of RS485 is given in s, min or h; serial_setting for RS485 includes speed without unit,
as well as data format in conventional notation (e.g., 9600 8N1).

• [Sensor;Evaluator]

– statistic: List of statistics, which are calculated for the sensor, e.g., average, min, max.
– unit: Unit for the data, e.g., m/s.
– sensor_label: Name, which has been entered by the user in the sensor configuration.
– sensor_height: Installation height in meters, which has been entered by the user in the sensor configuration.
– sensor_type: Indicates the type of the sensor, e.g., anemometer. The following values are possible:

anemometer: Anemometer,
wind_vane: Wind Vane,
hygro_thermo: Humidity / Temperature Sensor,
barometer: Barometric Pressure Sensor,
precipitation: Precipitation Sensor,
pyranometer: Solar Sensor,
ultrasonic: Ultrasonic Anemometer,
power_meter: Power Meter,
other: Other Sensor

– sensor_model: The model of the sensor, e.g., Thies First Class Advanced.
– formula: The type of formula used to convert the electrical values, e.g., linear.
– formula_params: Parameters, which are referenced to in the formula, including related channels and evaluator

parameters, e.g., A5 A6 var_offset var_slope. Values of the parameters are displayed in the lines below
the formula parameters, e.g., var_offset, var_slope, var_period, var_sensitivity.

• [Channel]

– statistic: List of statistics, which are calculated for the channel/sensor. For each statistic a column is displayed
in the upper part of the CSV file.

– unit: Unit of the calculated data. This is the SI unit for the type of quantity, however the unit for barometric
pressure might be either hPa or mbar, and the temperature unit is °C or K for differential temperature.

– rate: Configured rate for the channel with unit (not applicable for Master channels).
– range: Configured range for analog voltage channels (Ax) with unit.
– protocol: Protocol, which is used for digital channels (Dx).

6.6.2 CSV import in LibreOffice or OpenOffice

Tip
Use LibreOffice (http://www.libreoffice.org/) Calc or OpenOffice.org (http://www.
openoffice.org) Calc. These are free, professional spreadsheet programs to process your CSV
files.

The recommended settings to import the CSV file are shown in Figure 6.9.
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Figure 6.9: LibreOffice CSV-file import settings

6.6.3 CSV Import in Microsoft Excel 2010™

Depending on the version of Microsoft Excel™ the procedure can be slightly different. In general, we recommend
using the import assistant of Microsoft Excel™.

Note
Save CSV files always in a directory. The described process in Microsoft Excel™ does not work, when files
are opened via your email program.

1. Launch Microsoft Excel™ and open the Options window, which can be found in the File menu. Open the
Advanced menu. In the Editing options section deselect Use system separators and use . (dot) as decimal
separator and , (comma) as Thousands separator. See figure Figure 6.10.
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Figure 6.10: Microsoft Excel 2010™ CSV Import (1)

2. After setting the options, click on the Data tab as shown in Figure 6.11. In order to import the CSV file, click
on From Text in the group Get External Data, locate and double-click the file you want to import. Follow the
instructions in the Text Import Wizard.
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Figure 6.11: Microsoft Excel 2010™ CSV Import (2)

3. In the first step of the wizard choose Delimited as Original data type and select Unicode (UTF-8) for the file
origin. See Figure 6.12.

Figure 6.12: Microsoft Excel 2010™ CSV Import (3)

4. In next step define Comma as delimiter and ” as text qualifier as shown in Figure 6.13.
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Figure 6.13: Microsoft Excel 2010™ CSV Import (4)

5. In the last step of the wizard, select Text for the data format columns. See Figure 6.14.
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Figure 6.14: Microsoft Excel 2010™ CSV Import (5)

6. By clicking on Finish the file opens in your selected sheet. See Figure 6.15.

Figure 6.15: Microsoft Excel 2010™ CSV Import (6)

7. In order to change the cell format of the date and time columns from text to date time format, highlight the
column(s) and open Format Cells in the Numbers group on the Home tab. Select Custom and enter YYYY-MM-
DD hh:mm:ss.000 as shown in Figure 6.16.
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Figure 6.16: Microsoft Excel 2010™ Format Cells

6.7 Access to Source Data

Source data contains all electrically measured values neither interpreted nor with any statistical evaluation applied.
If source data is available and the used sensors are known, it is possible to re-evaluate a complete measurement
campaign.

Important
Source data is only recorded, when recording is switched on!

The source data storage is organized as a ring buffer, which means that the oldest data will be overwritten, when
the storage is filled entirely. For compactness reasons data is saved in a binary format and cannot be read directly.
However, you can view or download data.

To view or download source data, go to the Data → Source menu. Meteo-40 displays all months and related days, on
which source data is available. As shown in Figure 6.17, select month, day and time period to display related source
data in the table below.
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2016 07 08 09 10 11 12
2017 01 02 03 04 05

2017-05 ▷
Mon Tue Wed Thu Fri Sat Sun

1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31 	 	 	 	

HH:MM
HH:MM

HH:MM
HH:MM

HH:MM
HH:MM

HH:MM
HH:MM

HH:MM
HH:MM

HH:MM
HH:MM

Date	and	Time A1 A2 A3 C1 C2 C3 C4 D1 D2 D3 sw V I T addr
2017-05-11	12:25:00.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x000
2017-05-11	12:25:01.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x001
2017-05-11	12:25:02.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x002
2017-05-11	12:25:03.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x003
2017-05-11	12:25:04.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x004
2017-05-11	12:25:05.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x005
2017-05-11	12:25:06.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x006
2017-05-11	12:25:07.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x007
2017-05-11	12:25:08.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x008
2017-05-11	12:25:09.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x009
2017-05-11	12:25:10.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x010
2017-05-11	12:25:11.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x011
2017-05-11	12:25:12.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x012
2017-05-11	12:25:13.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x013
2017-05-11	12:25:14.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x014
2017-05-11	12:25:15.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x015
2017-05-11	12:25:16.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x016
2017-05-11	12:25:17.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x017
2017-05-11	12:25:18.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x018
2017-05-11	12:25:19.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x019
2017-05-11	12:25:20.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x020
2017-05-11	12:25:21.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x021
2017-05-11	12:25:22.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x022
2017-05-11	12:25:23.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x023
2017-05-11	12:25:24.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x024
2017-05-11	12:25:25.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x025
2017-05-11	12:25:26.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x026
2017-05-11	12:25:27.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x027
2017-05-11	12:25:28.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x028
2017-05-11	12:25:29.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x029
2017-05-11	12:25:30.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x030
2017-05-11	12:25:31.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x031
2017-05-11	12:25:32.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x032
2017-05-11	12:25:33.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x033
2017-05-11	12:25:34.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x034
2017-05-11	12:25:35.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x035
2017-05-11	12:25:36.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x036
2017-05-11	12:25:37.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x037
2017-05-11	12:25:38.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x038
2017-05-11	12:25:39.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x039
2017-05-11	12:25:40.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x040
2017-05-11	12:25:41.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x041
2017-05-11	12:25:42.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x042
2017-05-11	12:25:43.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x043
2017-05-11	12:25:44.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x044
2017-05-11	12:25:45.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x045
2017-05-11	12:25:46.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x046
2017-05-11	12:25:47.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x047
2017-05-11	12:25:48.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x048
2017-05-11	12:25:49.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x049
2017-05-11	12:25:50.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x050
2017-05-11	12:25:51.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x051
2017-05-11	12:25:52.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x052
2017-05-11	12:25:53.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x053
2017-05-11	12:25:54.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x054
2017-05-11	12:25:55.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x055
2017-05-11	12:25:56.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x056
2017-05-11	12:25:57.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x057
2017-05-11	12:25:58.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x058
2017-05-11	12:25:59.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x059
2017-05-11	12:26:00.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x060
2017-05-11	12:26:01.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x061
2017-05-11	12:26:02.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x062
2017-05-11	12:26:03.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x063
2017-05-11	12:26:04.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x064
2017-05-11	12:26:05.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x065
2017-05-11	12:26:06.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x066
2017-05-11	12:26:07.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x067
2017-05-11	12:26:08.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x068
2017-05-11	12:26:09.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x069
2017-05-11	12:26:10.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x070
2017-05-11	12:26:11.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x071
2017-05-11	12:26:12.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x072
2017-05-11	12:26:13.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x073
2017-05-11	12:26:14.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x074
2017-05-11	12:26:15.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x075
2017-05-11	12:26:16.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x076
2017-05-11	12:26:17.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x077
2017-05-11	12:26:18.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x078
2017-05-11	12:26:19.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x079
2017-05-11	12:26:20.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x080
2017-05-11	12:26:21.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x081
2017-05-11	12:26:22.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x082
2017-05-11	12:26:23.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x083
2017-05-11	12:26:24.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x084
2017-05-11	12:26:25.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x085
2017-05-11	12:26:26.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x086
2017-05-11	12:26:27.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x087
2017-05-11	12:26:28.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x088
2017-05-11	12:26:29.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x089
2017-05-11	12:26:30.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x090
2017-05-11	12:26:31.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x091
2017-05-11	12:26:32.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x092
2017-05-11	12:26:33.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x093
2017-05-11	12:26:34.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x094
2017-05-11	12:26:35.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x095
2017-05-11	12:26:36.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x096
2017-05-11	12:26:37.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x097
2017-05-11	12:26:38.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x098
2017-05-11	12:26:39.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x099
2017-05-11	12:26:40.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x100
2017-05-11	12:26:41.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x101
2017-05-11	12:26:42.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x102
2017-05-11	12:26:43.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x103
2017-05-11	12:26:44.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x104
2017-05-11	12:26:45.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x105
2017-05-11	12:26:46.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x106
2017-05-11	12:26:47.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x107
2017-05-11	12:26:48.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x108
2017-05-11	12:26:49.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x109
2017-05-11	12:26:50.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x110
2017-05-11	12:26:51.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x111
2017-05-11	12:26:52.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x112
2017-05-11	12:26:53.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x113
2017-05-11	12:26:54.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x114
2017-05-11	12:26:55.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x115
2017-05-11	12:26:56.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x116
2017-05-11	12:26:57.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x117
2017-05-11	12:26:58.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x118
2017-05-11	12:26:59.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x119
2017-05-11	12:27:00.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x120
2017-05-11	12:27:01.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x121
2017-05-11	12:27:02.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x122
2017-05-11	12:27:03.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x123
2017-05-11	12:27:04.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x124
2017-05-11	12:27:05.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x125
2017-05-11	12:27:06.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x126
2017-05-11	12:27:07.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x127
2017-05-11	12:27:08.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x128
2017-05-11	12:27:09.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x129
2017-05-11	12:27:10.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x130
2017-05-11	12:27:11.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x131
2017-05-11	12:27:12.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x132
2017-05-11	12:27:13.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x133
2017-05-11	12:27:14.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x134
2017-05-11	12:27:15.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x135
2017-05-11	12:27:16.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x136
2017-05-11	12:27:17.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x137
2017-05-11	12:27:18.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x138
2017-05-11	12:27:19.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x139
2017-05-11	12:27:20.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x140
2017-05-11	12:27:21.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x141
2017-05-11	12:27:22.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x142
2017-05-11	12:27:23.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x143
2017-05-11	12:27:24.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x144
2017-05-11	12:27:25.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x145
2017-05-11	12:27:26.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x146
2017-05-11	12:27:27.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x147
2017-05-11	12:27:28.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x148
2017-05-11	12:27:29.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x149
2017-05-11	12:27:30.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x150
2017-05-11	12:27:31.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x151
2017-05-11	12:27:32.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x152
2017-05-11	12:27:33.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x153
2017-05-11	12:27:34.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x154
2017-05-11	12:27:35.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x155
2017-05-11	12:27:36.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x156
2017-05-11	12:27:37.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x157
2017-05-11	12:27:38.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x158
2017-05-11	12:27:39.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x159
2017-05-11	12:27:40.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x160
2017-05-11	12:27:41.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x161
2017-05-11	12:27:42.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x162
2017-05-11	12:27:43.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x163
2017-05-11	12:27:44.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x164
2017-05-11	12:27:45.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x165
2017-05-11	12:27:46.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x166
2017-05-11	12:27:47.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x167
2017-05-11	12:27:48.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x168
2017-05-11	12:27:49.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x169
2017-05-11	12:27:50.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x170
2017-05-11	12:27:51.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x171
2017-05-11	12:27:52.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x172
2017-05-11	12:27:53.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x173
2017-05-11	12:27:54.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x174
2017-05-11	12:27:55.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x175
2017-05-11	12:27:56.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x176
2017-05-11	12:27:57.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x177
2017-05-11	12:27:58.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x178
2017-05-11	12:27:59.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x179
2017-05-11	12:28:00.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x180
2017-05-11	12:28:01.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x181
2017-05-11	12:28:02.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x182
2017-05-11	12:28:03.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x183
2017-05-11	12:28:04.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x184
2017-05-11	12:28:05.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x185
2017-05-11	12:28:06.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x186
2017-05-11	12:28:07.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x187
2017-05-11	12:28:08.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x188
2017-05-11	12:28:09.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x189
2017-05-11	12:28:10.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x190
2017-05-11	12:28:11.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x191
2017-05-11	12:28:12.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x192
2017-05-11	12:28:13.000 0.1 0.2 0.3 0.1 0.2 0.3 0.4 0.1 0.2 0.3 01h 12.00 125 30 50000x193

600	lines

◀

Source	Data	Only Evaluated	Data	Only Source	and	Evaluated	Data Download	ten	minutes

Download	hour Download	day Download	week

Figure 6.17: Screenshot of the Source Data Page

The displayed source data can be downloaded as CSV file by clicking on the buttons below the table.

Download ten minutes Click to download a CSV file with source data of the selected 10min-period.

Download hour Click to download source data of the selected hour, i.e., source data of one table row. The source
data in the downloaded CSV file starts with 00:00 min and ends with 59:59 min.

Download day Click to download source data of the selected day, i.e., the source data of the whole day from 00:00:00
to 23:59:59. If source data of the current day should be downloaded, the CSV file includes all data up to the
download moment.

Warning
The volume of downloaded source data can be huge, e.g., a filled 2 GB memory can lead to a 10 GB CSV
file.
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Chapter 7

Communication

7.1 Introduction

Depending on the usage of Meteo-40, several communication methods are available:

Measurement
Campaign

Power Plant
Monitoring Maintenance (Site) Configuration

(Office)

Mobile Communiction
(GPRS, UMTS)

Directional Radio

Satellite

USB Flash Drive

Ethernet

RS485

Ethernet

W-LAN

USB cable

Ethernet

W-LAN

USB cable

Table 7.1: Data Transmission with Meteo-40

The Meteo-40 web interface can be accessed via:

• LAN
• W-LAN (WiFi) using a USB WiFi stick
• Modem for GSM/GPRS, directional radio or satellite connection
• USB
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Tip
To download measurement data without accessing the Meteo-40 web interface, a pre-configured USB flash
drive can be used (see Section 4.2).

If Meteo-40 has been connected successfully to one of the above mentioned devices or networks, it is shown on
the data logger display under the menu Communication. USB and Ethernet connections are displayed in menu
Communication → Devices → LAN; a connected modem in menu Communication → Devices → Modem. W-LAN
(WiFi) parameters are displayed in menu Communication → Devices → WLAN.

Note
Although no USB device is connected, Meteo-40 displays one unavailableUSB connection, which refers
to the USB-B slot. As soon as you connect Meteo-40 via USB with your computer the displayed connection
will change to active.

Once the connection has been established, further settings can be configured via the web interface. There are different
ways to collect data from Meteo-40:

• Email
• FTP/SCP server upload
• AmmonitOR upload (also AmmonitOR installation on customer’s server) (AmmonitOR account is required)
• Direct download via web interface
• Direct download from data logger on USB flash drive

Data transmission between Meteo-40 and PC can be automatic (one-way) or interactive (two-way). Automatic com-
munication means that Meteo-40 sends CSV files by email or uploads data via FTP/SCP. Once the actions have been
configured, no further interaction is needed. Active communication implies an action by the user, e.g., accessing the
web interface while Meteo-40 is online. If a modem is used, you can access Meteo-40 via a tunnel server.

Automatic Communication Interactive Communication

• Data Upload to AmmonitOR
• Email CSV and other files
• Data Upload via SCP or FTP

• Online Access via Tunnel Server
• Meteo-40 Configuration
• Data Download via Web Interface

Table 7.2: Automatic vs. Interactive Communication with Meteo-40

The settings for data transmission or online access can easily be configured via the Meteo-40 web interface in the
Communication → Schedule menu (see also Section 7.2). CSV files, which include measurement data, are stored on
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the data logger and can be downloaded directly from the data logger, sent automatically via email to an address of
your choice as well as CSV files can be uploaded automatically to an SCP/FTP server of your choice.

In order to configure the settings for each communication method, use the menu items: Online, AmmonitOR, Email,
FTP/SCP, LAN, W-LAN and Modem.

Tip
We recommend using our online platform AmmonitOR to manage and monitor measurement data. To
register and start using AmmonitOR, go to the AmmonitOR login page (https://or.ammonit.com/
accounts/login/).

Port Direction Configurable Usage

21/tcp (FTP) outgoing yes
file transfer from
Meteo-40 to file server

4040/tcp outgoing no
secure tunnel for
Meteo-40 web
interface

4041/tcp outgoing no

secure file transfer
from Meteo-40 to file
server, e.g.
AmmonitOR

25/tcp (SMTP) outgoing yes
email transfer from
Meteo-40 to mail
server

123/tcp+udp (NTP) outgoing no
network time protocol
to set time and date

443/tcp (HTTPS) incoming no
secure Meteo-40 web
interface

465/tcp (SSMTP) outgoing yes
secure email transfer
from Meteo-40 to mail
server

502/tcp (Modbus) incoming no
Meteo-40 SCADA
service

Table 7.3: Ports used by Meteo-40

7.2 Configuring the Communication Schedule

Actions are processes, which the data logger performs according to the settings in the Communication → Schedule
menu. You select which action should be performed at which time and how often or how long during a day.

Meteo-40 turns on one minute before an action takes place and stays switched on as long as the action is running.
The status box in the web interface informs about the number of running actions.

Note
If CECS is always active has been selected in the CECS power mode section of the System →
Administration menu, Meteo-40 does not switch off automatically. Refer to Section 1.4.1 for further de-
tails.

Configuring the schedule includes defining the communication behavior during a day and selecting on which weekdays
an action should be performed. Each action starts performing at its Start Time and will be repeated according to
the defined Interval until the number of actions (Quantity) is achieved or a new day begins (00:00).
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Online Indicates the periods, at which the Meteo-40 web interface can be accessed over the Internet. If configured,
a tunnel connection is established.

Note
Be carefully selecting the online intervals of the data logger. Connection costs can be very high
depending on the communication method. In most cases up to three online intervals of 20 minutes
are sufficient.

AmmonitOR Indicates, when and how often CSV files should be uploaded to an AmmonitOR account.

Email Indicates, when and how often emails with attached CSV file(s) should be sent. If necessary, CSV files are
generated automatically before emails are sent.

FTP/SCP Indicates, when and how often CSV file(s) should be uploaded to a configured server using FTP or SCP. If
necessary, CSV files are generated automatically before upload.

Only generate CSV Indicates, when and how often CSV files should be generated without sending or uploading
them. Select this option to generate CSV files for the manual download via web interface or on USB flash drive.
According to the configured statistics (see Section 6.3), Meteo-40 generates CSV files on the selected days at
the scheduled times.

Action
Action

Mon
Mon

Tue
Tue

Wed
Wed

Thu
Thu

Fri
Fri

Sat
Sat

Sun
Sun

Start
Start

time
time

Duration
Duration

Quantity
Quantity

Interval
Interval

Next
Next

Online 12:00 00:20 1 0:00 2017-05-12
15:48 Run	now

AmmonitOR 12:00 	 1 0:00 2017-05-12
15:48 Run	now

Email 12:00 	 1 0:00 2017-05-12
15:48 Run	now

FTP/SCP 12:00 	 1 0:00 2017-05-12
15:48 Run	now

Only	generate
CSV

12:00 	 1 0:00 2017‑05‑12
15:48 Run	now

Save

Figure 7.1: Configuring the Schedule

Weekdays Select the weekdays, on which the action should be performed.

Start Time: Determine, when the first action should start. If no Start time is defined, Meteo-40 will schedule the first
action for 00:00.

Enter the Start Time according to the 24-hour format: hh:mm. Enter 14:00, when the action should start at 2
p.m..

Duration (Only applies for Online): Enter the length of time (hh:mm), which the data logger should be connected to
the Internet. The duration begins with every start of an action.

Example: Start time 11:00, Duration 00:20, Quantity 2, Interval 03:00 means that the data logger will be
online at 11 a.m. for 20 minutes. At 2 p.m. Meteo-40 is online again for 20 min.

Enter the Duration according to the following time format: hh:mm.

Quantity: Enter the number of actions, which should be performed during a day. Once a weekday has been selected
to perform the action, the Quantity is set to 1. After changing the Quantity to a number higher than 1, an Interval
can be entered. The last action will be performed at the latest at midnight, even if the user’s defined number of
actions has not been achieved.

Enter the Quantity as integer, e.g., 2, 3, 4.

Interval: Determine the time between the starts of two successive actions. The Interval can be entered once the
Quantity of an action was set to a higher number than 1. Entering 01:00 means that the action will be performed
hourly; entering 24:00 means that there is only one action per day possible.

Enter the Interval according to the following time format: hh:mm.

Next: Displays, when the next action is scheduled indicating date and start time.
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Note
Actions running just before midnight may be interrupted by the automatic CECS reboot. See Section 4.2
for details.

For immediate action, click Run now.

While Meteo-40 is online, the time elapsed is shown in the last column as percentage value. Otherwise, the Run now
button can be clicked to connect Meteo-40 immediately to the Internet.

Note
Consider the time settings for sending emails and uploading CSV files via FTP/SCP. During night hours the
battery’s energy might be too low to send or upload large files.

Do not forget saving your modifications. Without saving the previous values will be reset.

Tip
In order to save or reduce connection costs, we recommend carefully setting the online periods of the data
logger in the schedule. In most cases it is sufficient to configure not more than three time slots of 20 minutes
for Internet activity.

7.3 Configuring Online Access

The Meteo-40 web interface can only be accessed remotely, when the data logger is powered-on and an Internet
connection has been established. Periods for online access can be configured in the Communication → Schedule
menu.

Important
Meteo-40 can be connected to a tunnel server (e.g., Ammonit Tunnel Server; see Figure 7.2) to obtain a
unique subdomain. Thus the GSM modem can be equipped with a standard SIM card with dynamic IP
address. The tunnel server manages the subdomains. Users access the Meteo-40 web interface (when
online) by entering its subdomain, e.g., https://subdomain.tunnel.ammonit.com. Additionally, the
tunnel between data logger and server is encrypted and therefore cannot be accessed by unauthorized
users.

A tunnel connection / tunnel server can be configured in the Communication → Online menu. You can choose between
the Ammonit tunnel, your own tunnel or no tunnel, if you use Meteo-40 for testing purposes in your office.
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Ammonit
tunnel

Access via direct interface (Ethernet or USB)

Ammonit Tunnel Server
(provides public IP address,
at which the data logger can
be reached on the Internet)

Access via HTTPS
connection

Figure 7.2: Communication between Meteo-40 and PC via Ammonit Tunnel Server

Note
If you use a SIM card with static IP address, a tunnel connection is not necessarily needed. The tunnel
connection can be configured additionally, since it is established faster than the connection via static IP
address. The Ammonit tunnel server caches images and history of the last sessions.

File Edit View Go Bookmarks Tabs Help

Back https://d130293.local/communication/online/

Tunnel

Select tunnel server:
Ammonit tunnel

Tunnel login:
logger@D130293.tunnel.ammonit.com

Tunnel port:
0

Tunnel access code (highly recommended):

 Prevent implicit tunnel activation (only recommended for satellite communication)

Save Tunnel Config

Dynamic DNS

Server:

Username:

Password:

Hostname:

Save Dynamic DNS

System
Information
Administration
Upgrade
Display
Web Camera
Switches
Logbook

Measurement
Sensors
Channels
Evaluation

Data
Live
Statistics
Source

Communication
Schedule
Online
AmmonitOR
Email
FTP/SCP
SCADA
LAN
WLAN
Modem

Download SSH Key

Link to tunnel

select your preferred tunnel server

download SSH key for your own tunnel or AmmonitOR installation

click to enter the Meteo-40 webinterface via tunnel connection

activate to avoid blind tunnel activation

prevent unauthorized internet traffi c from reaching the data logger

Figure 7.3: Configuring the Online Access

Meteo-40 offers three tunnel options (see Figure 7.3) in the Communication → Online menu:

No tunnel: Select this option, when you use a SIM card with static IP address or when you are connected directly to
the data logger via LAN (Ethernet) or USB.

Ammonit tunnel: Select the Ammonit Tunnel Server (see Figure 7.2) to access the data logger’s web interface via
an Ammonit tunnel domain link https://Dnnnnnn.tunnel.ammonit.com).

Custom tunnel: Enter Tunnel login and Tunnel port of your own tunnel server. Your server has to authenticate the
Meteo-40 data logger. Download the SSH key of the data logger for authentication. Contact your system
administrator for further details.

Download SSH Key Download SSH Key is only necessary, if you use your own tunnel server or an AmmonitOR
installation. The SSH or public key is used to authenticate the data logger at your server.

Link to tunnel In order to get the URL to access your Meteo-40 data logger via Ammonit tunnel, click on Link to
tunnel.
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Tunnel access code By using a Tunnel access code, you prevent unauthorized Internet traffic from reaching the data
logger. This traffic might slow down your connection and increase Internet costs.

Tip
By entering a tunnel access code, connection costs can be reduced. The login page of the data
logger is not visible for unauthorized users. Thus the URL of the data logger cannot be spammed or
attacked.

Note
Compared with the Tunnel affix (available in older Meteo-40 firmware versions), the Tun-
nel access code does not change the URL of your data logger in the tunnel. It remains
https://dnnnnnn.tunnel.ammonit.com/.

Once the Tunnel access code has been entered in your browser, it is saved as cookie on your PC. The Tunnel
access code has only be entered again on your PC after the cookie has been deleted.

Tip
By using the Ammonit Tunnel server with Tunnel Access Code, you can boost your connection to your data
logger. The Ammonit Tunnel server recognizes the IP address of your data logger in the field. In some cases
the IP address is accessible from outside (routable IP address of the installed SIM card). However, in this
case you can directly access your data logger via its IP address. There is no need to use the circuit via the
Ammonit Tunnel server in Germany. The Ammonit Tunnel server still manages the connection. Thus you
access the web interface of the data logger via a simple URL: https://dnnnnnn-direct.tunnel.ammonit.com.
This feature works with all Ammonit Meteo-40 data loggers, no matter which firmware version is installed.

In order to access the data logger via tunnel, the URL of the data logger has to be entered in your browser, i.e.,
https://dnnnnnn.tunnel.ammonit.com/. On your first access via tunnel you have to enter the Tunnel access code, see
Figure 7.4.
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URL:	https://D151234.tunnel.ammonit.com/

Ammonit	Meteo-40	Tunnel

Please	enter	your	access	code

	 Send

The	tunnel	access	code	or	affix	must	be
configured	on	your	data	logger	under
Communication/Online.	If	no	access	code	is
configured,	try	Ammonit.
The	tunnel	access	code	prevents	unauthorized
access	to	the	login	page	of	the	data	logger.

©	2011-#YEAR#	Ammonit	Measurement	GmbH
www.ammonit.com

Figure 7.4: Entering the Tunnel Access Code

Prevent implicit tunnel activation The data traffic can be reduced by selecting this checkbox. The feature is espe-
cially designed for satellite communication. By activating the checkbox, the tunnel is only established according
to the configured schedule (see Section 7.2). Other tunnel activations are prevented.

Important
Meteo-40 can only be accessed via tunnel server, when the data logger is online! The online periods are
configured in the Communication → Schedule menu.

If Meteo-40 is configured for the Ammonit Tunnel Server and your data logger is currently not online, the following
page (see fig Figure 7.5) will be displayed.
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URL:	https://D151234.tunnel.ammonit.com/

Ammonit	Meteo-40	Tunnel

Your	data	logger	tunnel	is	not	currently	open.

If	you	believe	it	should	be,	please	check	that:
Your	data	logger	is	configured	to	be	online	at
this	time
Your	data	logger	is	configured	to	use	the
Ammonit	tunnel

©	2011-#YEAR#	Ammonit	Measurement	GmbH
www.ammonit.com

Figure 7.5: Communication via Ammonit Tunnel (closed tunnel)

7.4 Configuration for using AmmonitOR

In the Communication → AmmonitOR the AmmonitOR server can be selected, and one can configure which kind of
data is send to AmmonitOR.

If Meteo-40 user Admin set the option Force Encryption, the parameters cannot be changed by user User.

Note
If you do not have an AmmonitOR account yet, go to the AmmonitOR login page (https://or.ammonit.
com/accounts/login/) or click on Link to AmmonitOR to register. Further details about AmmonitOR and
a user manual can be found on www.ammonit.com (http://www.ammonit.com).

AmmonitOR server Select your preferred AmmonitOR server: Ammonit-hosted installation or your own AmmonitOR
server.

If you use the Ammonit-hosted installation, server details are filled automatically. If you use your own installation,
enter the necessary server details. Your local AmmonitOR server has to authenticate each data logger. To do
so, see Section 7.4.1.

AmmonitOR project key Enter the Project key of your related AmmonitOR project. The Project key is displayed in
the project overview of your AmmonitOR project. It consists of four to six uppercase letters. You can connect
more than one data logger to an AmmonitOR project. To do so, use the Project key for all project-related data
loggers.

Server, Port, Username Name or IP address of your AmmonitOR server, TCP port, and username for upload. These
values are automatically set correctly for the Ammonit hosted server.

Start date Files older than this date will not be transmitted to AmmonitOR.
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Select	AmmonitOR	server:
Ammonit	AmmonitOR

AmmonitOR	project	key
EWNP
Server:
upload.ammonit.com
Port:
4041

Username:
upload
Start	date	(YYYY-MM-DD):

	Send	CSV	files
Send	logbook	data
Yes

	Send	configuration	file
	Send	camera	image
	Send	data	snapshot
	Send	gust	data	files
Reset	send	status

Save	and	copy	test	data

Save

Link	to	AmmonitOR

Download	SSH	key

select your preferred AmmonitOR server

enter project key of the
related AmmonitOR project

select which details should be
transferred to AmmonitOR

download SSH key for custom tunnel
or custom AmmonitOR installation

link to related AmmonitOR project

Figure 7.6: AmmonitOR Settings

Decide, which data should be monitored in AmmonitOR:

CSV files Select this, if you want to send all measurement data to AmmonitOR.
If you do not want your measurement data sent to AmmonitOR, deselect this switch.

Logbook data Select this option, to send logbook entries to AmmonitOR.
Configuration file Select this option, to send the data logger configuration file to AmmonitOR. Passwords and the

modem PIN will be stripped of the configuration file for security reasons.
Camera image Select this option, to send camera images to AmmonitOR. The camera image is taken at the moment

of the sending to AmmonitOR.
Data snapshot Select this option, to send data snapshots to AmmonitOR. The data snapshot consists of the mea-

surements just in the moment of sending to AmmonitOR.

Note
This feature is still considered experimental and might not always work.
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File Edit View Go Bookmarks Tabs Help

Back https://or.ammonit.com/projects/376/logger/591/connections/

Messages

Data logger
Overview
All evaluations (7 days)
Connections
Connection alarms
Logbook
Configurations
Photos

Data
Calendar
Data tables
Table of averages
Raw data files
Export data
Upload data

Plots
Correlation plot
Daily profile
Long term comparison profile
Monthly profile
Overlay graph
Shadow zone plot
Simple height profile
Speed direction bar
Speed direction dots
Sunshine hours
Turbulence intensity
Turbulence intensity polar
Wind direction
Wind speed
XY plot

Data logger Roof Mast (D110057)

Earlier connections View text View graphic

Showing connections from 2013-10-31 until 2013-11-30 (30 days)

Time in UTC

Day of month
Access this data logger via tunnel

00:00
01:00
02:00
03:00
04:00
05:00
06:00
07:00
08:00
09:00
10:00
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12:00
13:00
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Figure 7.7: Connection Log in AmmonitOR

Reset send status With this function, Meteo-40 forgets about ever sending files to AmmonitOR. Any files will be sent
again.

Save and copy test data This function sends a test file to AmmonitOR. This is useful to check the connection and
settings, such as the project key.

Save Save the current settings.

Link to AmmonitOR Click on Link to AmmonitOR to set up a new AmmonitOR account.

Download SSH Key Applies only, when you use a local AmmonitOR installation (not the Ammonit-hosted installation).
Your AmmonitOR server has to authenticate each Meteo-40 data logger. To do so, download the SSH key and
see Section 7.4.1 and AmmonitOR user manual on the Ammonit website (http://www.ammonit.com/en/
ammonit-customer-login).

7.4.1 Authenticating Meteo-40 at your local AmmonitOR installation

If data files should be uploaded to a local AmmonitOR installation, the local AmmonitOR server has to authenticate
each Meteo-40 data logger. To do so, download the SSH key from each Meteo-40 data logger. The SSH key can be
downloaded in the Communication → AmmonitOR menu. Copy the SSH key on your local AmmonitOR server.

Open the AmmonitOR administration web interface (admin rights are necessary) and enter the SSH key in the Base
→ SSH keys menu of AmmonitOR. For further details see AmmonitOR manual, which can be downloaded from the
Ammonit website (http://www.ammonit.com/en/ammonit-customer-login). After adding the key, the file
upload can be configured.

7.5 Configuring Email Parameters

In order to receive data via email from the data logger, Meteo-40 has to be connected to the Internet (e.g., via modem)
and an email account has to be configured in the Communication → Email menu.

Important
Do not use your personal email account for data logger emails. We recommend setting up a separate ac-
count. Anyone logged in as either Admin or User on the data logger can access username and password,
and consequently the related email account.
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Tip
It is possible to use email addresses from free service providers, e.g., Yahoo, Gmail, to send data files from
Meteo-40.

Enter server and account details:

SMTP server Enter SMTP server address, e.g., smpt.mail.provider.com. SMTP (Simple Mail Transfer Protocol) is a
standard protocol used to send emails. SMTP server details can be find in our email account data or contact
your email service provider.

SMTP port Enter the SMTP port, e.g., 25 or 465, later servers often use 587. The port number can be found in the
SMTP server details or contact your email service provider.

SMTP username Enter the username, which is used to access your email account. Often the username is the same
as the email address.

SMTP password Enter the password, which is used to access your email account.

From Enter the sender’s email address, which is often also the username of the email account.

To Enter the email address of the recipient. If more than one email address should be entered, use a semicolon (;)
to separate the email addresses.

Cc If required, enter the recipient(s), who should receive the email in copy. If more than one email address should be
entered, use a semicolon (;) to separate the email addresses.

POP server (for POP-before-SMTP authorization) Only required for SMTP servers using POP-before-SMTP or SMTP-
after-POP authentication.

Start date (YYYY-MM-DD) Indicates which data files should be sent via email. No older files than indicated with the
Start date will be sent.

Enter the start date in ISO-8601 format: YYYY-MM-DD (e.g., 2016-01-31)

Send logbook data Whether to send logbook entries. Select No to never send them, Yes to send them always on
the next day, or Immediately to send them with every scheduled email.

Send configuration file Whether to send the configuration file. The file will be sent once, and after configuration
changes with the next email scheduled.

Send camera image If a camera is connected to the data logger, an instant picture can be attached, which is taken
a moment before the email is sent.

According to the settings in the Communication → Schedule menu (see Section 7.2), an email is sent to the specified
account including one or more CSV files. An email includes all CSV files, generated since the last email has been
sent.

Note
An email can include up to 10 attachments. If more files are to be transmitted, multiple emails are send.
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SMTP server:
smtp.mail.server.com

SMTP port: (e.g. 25, 465, or 587)
587

SMTP username:
email@domain.com

SMTP password:
••••••••••••••• Show password

From:
email@domain.com

To:
admin@domain.com

Cc:
user@domain.com

POP server (for POP-before-SMTP authorisation):

Start date (YYYY-MM-DD):
2014-08-01

 Attach image

Signing and Encryption

 Unsigned and unencrypted

 Sign data (GnuPG)

 Sign and encrypt data (GnuPG)

Encryption password:
•••••••• Show password

Fingerprint:
C41E E4BB CD80 2E08 5086 A496 BE6E A60A 4D0E 2B48

Reset send status

Save and send test email

Save

System
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Upgrade
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tick here to attach an image

enter details of your mail server

enter recipient details

Figure 7.8: Configuring Email Parameters

In certain cases it might be necessary to reset the status of the data files sent via email. The data files can be resend,
e.g., to another email address or if old files have gone lost. Press Reset send status to set the send status of CSV files
listed in the Data → Statistics menu to zero. The entered Start date indicates the data files, which should be reset for
email transfer.

Important
Do not forget saving the settings. By clicking the button Save and send test email, the configuration
can be checked.

Note
In order to test the email function, the data logger has to be connected to the Internet via modem, LAN or
W-LAN (WiFi). It is not sufficient to connect Meteo-40 to a PC via USB, because a PC is not necessarily
configured as router. If your smartphone is designed for tethering, you can connect your smartphone and
configure it as router to test the email function of the data logger.

On the Statistics Data Download page in the Data → Statistics menu all CSV files, which have been sent via email,
have a checkmark. See also Section 6.3.

7.5.1 Signing and Encrypting Emails and Attachments

Digital signature and encryption are very complex topics. By digitally signing an email or a file, its authenticity can be
verified. A valid digital signature indicates that the email / file has been created by a known sender, e.g., your Meteo-40
data logger (authentication), and the email has not been manipulated on its way to the receiver (integrity). By using
encryption, you can encode emails and attachments in a way that third parties cannot read the file, only authorized
parties are allowed to open and read the files. A password is required to decrypt emails and files.

Read this section carefully and follow our description step by step to avoid any misunderstandings. For further details
about digital signature and encryption, refer to Chapter 14.

Meteo-40 integrates GnuPG, which is a free software to sign and encrypt data files. GnuPG is based on the inter-
national standard OpenPGP. Refer to Wikipedia (http://en.wikipedia.org/wiki/GNU_Privacy_Guard) or
GnuPG website (http://gnupg.org/) for further details.

In the Communication → Email menu emails and attachments can be signed or signed and encrypted using GnuPG.

Unsigned and unencrypted If emails should be sent neither with digital signature nor password protected, select
this option.
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Sign data (GnuPG) Select this option to digitally sign CSV and logbook files sent via email. The CSV and logbook
files sent by Meteo-40 are signed with a unique digital key. A certificate, indicating the digital signature, is
attached to the email for each CSV and logbook file. The attachments can, however, be opened and saved
without restriction.

As soon as a signed file is modified, the certificate is invalid.

In order to verify the certificate, download the Public key, displayed in the Meteo-40 web interface and import
the key into your local verification software, e.g., Gnp4win (see Section 7.5.1.1).

Sign and encrypt data (GnuPG) Select this option to sign (as above) and encrypt CSV and logbook files sent via
email. Enter an Encryption password, which is required to decrypt the file on the recipient’s side.

In addition to the digital signature Meteo-40 can encrypt CSV and logbook attachments with a Private key.
The encrypted files can only be opened by authorized persons with theEncryption password. To do so, additional
software is required. See e.g. Section 7.5.1.1.

To decrypt the data, download the Public key by clicking on the button in the Meteo-40 web interface. Import
the Public key into your encryption software (see below). The displayed Fingerprint is used to authenti-
cate the Public key.

7.5.1.1 Working with Gpg4win to Decrypt and Verify Files on Windows™ PCs

In order to open and read files, which have been encrypted by Meteo-40, additional software is necessary. We recom-
mend installing GPG4win (GNU Privacy Guard for Windows). Ggp4win enables users to encrypt, decrypt, sign and
verify emails and attachments as well as files in a directory. The software includes the following components:

• GnuPG: encryption tool
• Kleopatra: certificate manager for OpenPGP
• GpgOL: add-in for Microsoft Outlook 2003/2007/2010/2013™ for email encryption
• GpgEx: plug-in for Microsoft Explorer™ for file encryption
• Gpg4win Compendium: documentation for beginners and advanced users

Go to the GPG4WiN website (http://gpg4win.de/download) and download the current software version. Install
the software with the above mentioned components.

Note
If you work with Microsoft Outlook™, the program has to be restarted to implement the GpgOL add-in as
separate ribbon. For decryption via the GpgOL add-in, go to Section 7.5.1.5.

Before working with Gpg4win, the software has to be configured. Download the Public key from the Meteo-40 web
interface, as shown in Figure 4.7.

Important
Each Meteo-40 data logger has it own unique public key. If you work with different Meteo-40 data loggers,
you have to import the public key of each Meteo-40. One user’s private key is sufficient to certify the public
keys (as shown in Figure 7.11).

Import the Public key in Gpg4win via right-mouse click in the Windows Explorer™. A message is displayed after
successfully importing the key.
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Figure 7.9: Importing the Public key into Gpg4win

Open the Kleopatra software. The Public key is listed under Other Certificates.

The Public key of the Meteo-40 data logger has to be certified by your own key. If a user’s private key has already
been generated, skip the following task and go on with Figure 7.11.

If not user’s private key is existing, create a new certificate via the File → New Certificate menu. Select Create a
personal OpenPGP key pair and enter the required details. Click Create key and enter a high quality password. Your
key should have been successfully created.

Figure 7.10: Creating the private key

The Public key of Meteo-40 has to be certified. Go to Other Certificates and select Meteo-40’s key. Open the
context menu via right-mouse click and select Certify Certificate.
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Figure 7.11: Certifying the Public key

Before trusting the certificate, check the displayed Fingerprint with the Fingerprint shown in the Meteo-40 web
interface (see Figure 4.7).

verify finterprint

Figure 7.12: Verifying the Fingerprint

Verify the certificate and enter the password for the Private key. The password is used to unlock the Private
key for the OpenPGP certificate. Finally both certificates are displayed under Trusted Certificates.
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Figure 7.13: Trusted Certificates

7.5.1.2 Verifying digital signatures in the Windows Explorer™

IfSign data (GnuPG) has been selected, each CSV and logbook file sent by Meteo-40 comes with a detached signature
file, i.e., a separate signature file (.sig) is attached to the email. The signature file has the same name as the CSV or
logbook file - ending on .sig.

Download and certify the Public key of Meteo-40 as described in Section 7.5.1.1.

Download both related files to your directory. Choose the data or logbook file, which should be verified. Open the
context menu with a right-mouse click on the .csv.gz, .log or .sig file and select Verify.

Figure 7.14: Verifying signed files

Make sure that Input file is a detached signature is selected. Both related files should be listed, with the signature
ending on .sig in the Input file field. Select Decrypt/Verify. After verification the Kleopatra software indicates the
validity of the signature.
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Figure 7.15: Successfully verified signature

7.5.1.3 Verifying digital signatures in Microsoft Outlook™

IfSign data (GnuPG) has been selected, each CSV and logbook file sent by Meteo-40 comes with a detached signature
file, i.e., a separate signature file (.sig) is attached to the email. The signature file has the same name as the CSV or
logbook file - ending on .sig.

Download and certify the Public key of Meteo-40 as described in Section 7.5.1.1.

Open the email and select the file, which should be verified (ending on .csv.gz or .log). Click on Save and decrypt
in the Attachments ribbon of Microsoft Outlook™.

Figure 7.16: Verifying files in Microsoft Outlook™

Make sure that Input file is a detached signature is selected. Both related files should be listed, with the signature
ending on .sig in the Input file field. Select Decrypt/Verify.
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Figure 7.17: Verifying signatures in Microsoft Outlook™

After verification the Kleopatra software indicates the validity of the signature.

Figure 7.18: Successful validation of the signature
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Note
If test emails sent by Meteo-40 have been signed, a separate signature file is attached, e.g., Meteo-
40.txt.sig. To verify the signature, open the email and select both related attachments, e.g., Meteo-40.txt
and Meteo-40.txt.sig. Choose Save and decrypt in the Attachments ribbon of Microsoft Outlook™.
Both files are listed in the Kleopatra software: Input file and Signed data (see Figure 7.19). Select Decryp-
t/Verify to validate the signature.

Figure 7.19: Verifying signed test mails

7.5.1.4 Decrypting files in the Windows Explorer™

Download and certify the Public key of Meteo-40 as described in Section 7.5.1.1.

Encrypted files can be decrypted in the Windows Explorer™. Right click on the file and select Decrypt and verify.

Figure 7.20: Decrypting files via the GpgEx plug-in for Windows Explorer™
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Start the decryption process by clicking Decrypt and verify.

Figure 7.21: Decryption via Kleopatra Software

For decryption enter the password, which you entered for encryption in the Meteo-40 web interface in the Communi-
cation → Email menu.

Figure 7.22: Password Prompt for Decryption

After successful decryption the file is displayed in the initial folder or the one selected in the decryption process.
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Figure 7.23: Successful File Decryption

7.5.1.5 Decrypting files in Microsoft Outlook™

After installing Gpg4win a new ribbon GpgOL should be shown in your Outlook™ application. Follow our step by step
guide to decrypt encoded data files sent by your Meteo-40 data logger.

Download and certify the Public key of Meteo-40 as described in Section 7.5.1.1.

Open the email item and go to the Attachments ribbon (Click on one of the attached files). Click on Save and decrypt
in the Attachments ribbon.

Figure 7.24: GgpOL add-in in Microsoft Outlook™

Select the folder, in which the files should be saved and start the decryption process by clicking on Decrypt/Verify in
the Kleopatra software. For decryption, enter the passphrase, which you entered for encryption in the Communication
→ Email menu of the Meteo-40 web interface. See also Section 7.5.1.4.

Both files encoded and decrypted data files should be successfully saved in the selected folder.

Note
In order to verify signed and encrypted test emails sent by Meteo-40, open the email and select Decrypt
in the GpgOL ribbon of Microsoft Outlook™. Enter the password, which has been set for Encryption in the
Meteo-40 web interface.
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7.6 Configuring FTP and SCP Parameters

By using FTP/SCP you can upload CSV files to a server of your choice. To do so, Meteo-40 has to be connected to
the Internet, e.g., via modem.

The CSV file upload can be configured in the Communication → FTP/SCP menu. Meteo-40 offers two methods to
upload data:

If Meteo-40 user Admin set the option Force Encryption, the parameters cannot be changed by user User.

SCP Select this option to upload files via SCP to your server. The connection is encrypted with RSA 2048 bit. Enter
server address, port, username and directory to enable the file upload. Contact your system administrator for
the server details.

All files uploaded via SCP have a checkmark in the SCP column in the Data → Statistics menu. See also
Section 6.3.

FTP Select this option to upload files to your FTP server. Enter server address, username, password and directory
to enable the file upload. Contact your system administrator for the server details.

All files uploaded via FTP have a checkmark in the FTP column in the Data → Statistics menu. See also
Section 6.3.

Note
FTP transfer always uses passive mode, not active mode.

Warning
The file upload via FTP is not encrypted.

File Edit View Go Bookmarks Tabs Help

Back https://d130293.local/communication/copy/

Method:
SCP

Server:
xxx.xxx.xx.xx

Port:
21

Username:
user

Directory:
home/meteo40/d130080

Start date (YYYY-MM-DD):

Reset send status

Save and copy test data

Save

System
Information
Administration
Upgrade
Display
Web Camera
Switches
Logbook

Measurement
Sensors
Channels
Evaluation

Data
Live
Statistics
Source

Communication
Schedule
Online
AmmonitOR
Email
FTP/SCP
SCADA
LAN
WLAN
Modem

Password:
Show password

select upload method

enter directory on server (fi le path)

test fi le upload

Figure 7.25: Configuring the FTP/SCP Parameters

By entering a Start date, you can configure which files should be uploaded. No older files than the indicated Start date
will be uploaded.

Important
Save your configuration. The entered values are reset after moving to another page.
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Each upload includes all collected CSV files, which have been generated since the last file upload. If it is the first
upload, Meteo-40 uploads all CSV files - no matter, how many CSV files have been generated. The sequence of
actions can be configured in the Communication → Schedule menu. For further details refer to Section 7.2

Tip
If you are using Windows™, you might try the FileZilla (http://filezilla-project.org) FTP server.
After downloading and installing the software, you have to add a new user. Enter the appropriate fields and
select the folder, which should be shared. It is also important to configure Windows™ Firewall by adding
an exception for the corresponding port (21 for FTP) and the FileZilla server interface.

Warning
Make sure to download FileZilla only from its official website or other trusted sources. Malicious versions
have been released, that might copy private information to unauthorized parties.

7.7 Configuring LAN Parameters

Important
Restart the data logger or disconnect the Ethernet cable for some seconds to apply new network settings.

Meteo-40 data loggers can be connected to your LAN using a standard Ethernet cable. The network connection will
be automatically recognized. In order to access the Meteo-40 web interface, enter the assigned IP address https:
//nn.nn.nn.nn/ in your web browser. The IP address can be found on the data logger display by selecting the
corresponding device at the Communication → Devices → LAN → Ethernet. Refer to Section 2.3 and Chapter 3 for
more information about the login.

Note
If you are working with Meteo-40 Revision C with RS232 slot, you need an USB Ethernet adapter to connect
the data logger to your LAN. The production of Meteo-40 Revision C stopped in October 2012.

A table in the Communication → LAN menu displays, which devices are connected, e.g., USB and / or Ethernet with
its state, IP address and product (if available).
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Interface
Interface

State
State

IP	Address
IP	Address

Product
Product

usb0 Unavailable 169.254.12.34
eth0 Activated 192.168.12.34

	LAN	online,	whenever	CECS	is	on
IP	address	allocation	method:
DHCP

	Connect	to	internet	via	USB	modem	only	(recommended	e.g.	for	SCADA	and	Ethernet	camera)
LAN	switch	(typically	S1):
S2

IP	address
192.168.40.40
DNS	server
192.168.40.1
Gateway
192.168.40.1
Subnet	mask
192.168.40.1
Additional	subnets

Save

Check	optimal	BGAN	settings

available LAN
connections

select a switch, e.g.
for BGAN modem

select modem for
internet connection

select DHCP, static IP address, or link-local connection

establish internet connection, when CECS is on

Figure 7.26: Configuring LAN parameters

LAN online, whenever CECS is on The checkbox is selected by default. Thus after connecting Meteo-40 to LAN
via Ethernet, the data logger goes online as soon as the CECS subsystem is switched on.

Use DHCP, static IP, or link-local By default, Meteo-40 automatically obtains an IP address from a DHCP server.
DHCP is active in most of the networks. If Use DHCP for wired network is active, the fields below are disabled.
For most SCADA applications, the data logger has to be configured with a fix IP address. Thus the use of DHCP
server has to be deactivated. See Section 7.7.1 for more information.

Note
For upgrading the Meteo-40 firmware via the tethering function of your smartphone, the method has
to be set to DHCP. See also Section 4.3.1.

The link-local method is useful for connecting a PC with Meteo-40 directly using an Ethernet cable. This
connection will not have an influence over the USB modem communication and can be used for testing the
former.

Connect to Internet via USB modem only (recommended e.g. for SCADA) Select this checkbox to set the USB
modem connection as preferred Internet connection. This checkbox is not selected by default.
This function is only recommended, when Ethernet port is used and USB-modem connections are preferred for
the Internet connection, e.g., in SCADA applications or connecting a camera to the Ethernet port.

By choosing a LAN switch you can supply your router or modem, e.g., BGAN satellite modem. For further details
about BGAN modems refer to Section 7.9.7.

7.7.1 Configuring a Static IP address in a LAN

In order to configure a static IP address in a LAN, go to the Communication → LAN menu and select Static IP. Enter
the details for IP address, DNS server, Gateway and Subnet mask.
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If the data logger has to be available from other subnets, e.g., if the SCADA Master is located in another network
segment, it is possible to add additional subnets. The previously configured gateway will also be used for this subnets.
A list of IP numbers and subnet prefixes can be entered in Additional subnets field. Use a semicolon (;) to separate
the IP addresses, e.g., 192.168.13.0/24;192.168.14.0/24

Interface
Interface

State
State

IP	Address
IP	Address

Product
Product

usb0 Unavailable 169.254.12.34
eth0 Activated 192.168.12.34

	LAN	online,	whenever	CECS	is	on
IP	address	allocation	method:
Static	IP

	Connect	to	internet	via	USB	modem	only	(recommended	e.g.	for	SCADA	and	Ethernet	camera)
LAN	switch	(typically	S1):
None

IP	address
192.168.1.170
DNS	server
0.0.0.0
Gateway
0.0.0.0
Subnet	mask
255.255.255.0
Additional	subnets

Save

Check	optimal	BGAN	settings

enter static IP address and further IP settings

select fixed IP for a static IP address

Figure 7.27: Configuring a Static IP Address in a LAN

Note
If you are working with a SIM card with static IP address, it is not necessary to change the LAN settings.
Refer to Section 7.9.3.

7.8 Configuring W-LAN

Meteo-40 supports W-LAN (WiFi) for more flexibility on site. To set up a W-LAN, a W-LAN USB stick has to be
connected to the Meteo-40.

Before using the W-LAN function, Meteo-40 has to be configured. Go to the Communication → WLAN menu and
select the checkbox Activate W-LAN. According to your local network Meteo-40 assigns an IP address and displays
Netmask, Network as well as First address and Last address of your network. Later on you access the Meteo-40 web
interface under the assigned IP address.

Enter a Passphrase consisting of at least eight characters. Click on Save to finish your configuration.

Important
Note down or copy the assigned IP address, as you need this IP address to access the Meteo-40 web
interface via W-LAN!
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Note
Due to security reasons, the passphrase for W-LAN access must have at least eight characters.

File Edit View Go Bookmarks Tabs Help

Back https://d110017.local/communication/wlan/

Help Logout
(Admin on D110017)

 Activate W-LAN

IP address
192.168.40.1

Netmask
255.255.255.0

Network
192.168.40.0

First address
192.168.40.2

Last address
192.168.40.255

Passphrase (at least eight characters)
Show password

Save

Recording: On Switch off

Configuration: Saved Save

Connection: Ethernet,Tunnel

Remaining: ∞

Wireless LAN

System
Information
Administration
Upgrade
Display
Web Camera
Switches
System Log

Measurement
Sensors
Channels
Evaluation

Data
Live
Statistics
Source

Communication
Schedule
E-Mail
Online
FTP/SCP
SCADA
LAN
WLAN
Modem

中文(简) English Español Português Français Deutsch Türkçe © 2011-2012 Ammonit Measurement GmbH
www.ammonit.com

passphrase for Meteo-40  W-LAN

activate W-LAN

IP address for W-LAN access

at least 8 characters

Figure 7.28: Configuring W-LAN Parameters

After having finished the configuration in the Meteo-40 web interface, activate the W-LAN function of your computer.
Search Meteo-40 among the available W-LANs. The established W-LAN is shown with the serial number of the data
logger. Select the W-LAN and enter the Passphrase, which has been entered in the Meteo-40 web interface.

Open your browser and enter the IP address, which has been displayed in the Meteo-40 web interface (see Fig-
ure 7.28).

Note
If you are already connected to a W-LAN, a second W-LAN connection could cause problems.

7.9 Configuring the Modem

Meteo-40 can be connected to the Internet via modem to perform scheduled actions. UMTS/GSM/GPRS modems,
or BGAN satellite modems can be configured. UMTS/GSM/GPRS modems are configured via the Meteo-40 web
interface in the Communication → Modem menu.

Note
Depending on the SIM card used in the modem, a different APN (Access Point Name) has to be entered for
proper communication. If you use a SIM card with dynamic IP address, you can easily configure the modem
via our provider helper, see Section 7.9.1. If you use a SIM card with static IP address, an individual APN
might be necessary. Ask your provider for the correct APN. See also Section 7.9.3.

In order to configure a BGAN satellite modem, refer to Section 7.9.7.

Important
We recommend configuring the modem in the web interface before connecting the modem to the data
logger.
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Tip
If your SIM card gets lock for some reason, e.g., entering a wrong PIN code, remember the PUK code to
create a new SIM card PIN code via the Meteo-40 web interface. See also Section 7.9.5.

On the upper part of the configuration page, the properties of the connected modem are displayed, e.g., signal strength,
operator, IP address and supported bands. If there is no modem connected, the fields are empty.

State
State

Reason
Reason

Signal
Signal

Operator
Operator

IP	Address
IP	Address

Product
Product

RX/TX
RX/TX

Bands
Bands

Activated o2	-	de 10.53.108.67
(USB3)

Cinterion
PHS8-P
REVISION
03.001

5084/5198 GSM/GPRS/EDGE
900	MHz,
GSM/GPRS/EDGE
1800	MHz,
GSM/GPRS/EDGE
1900	MHz,
GSM/GPRS/EDGE
850	MHz,
WCDMA	2100
MHz	(Class	I),
WCDMA	3GPP
UMTS	800	MHz
(Class	VI),
WCDMA	3GPP
UMTS	850	MHz
(Class	V),
WCDMA	3GPP
UMTS	900	MHz
(Class	VIII),
WCDMA	3GPP
UMTS	1900	MHz
(Class	II)

Number:
*99#
APN:
internet
Username:

Password:

	Modem	online,	whenever	CECS	is	on	(recommended)
Modem	switch	(typically	S1):
S1

PIN:

Save

New	PIN:

PUK	(for	changing	the	PIN):

Save	new	PIN

	

Use	provider	helper

SMS

85%

connection
status

reason of
connection
failure

signal
strength

network
operator

IP address
of modem

product
details

set APN and provider details
with the help of  a wizard

received/
transmitted
bytes

modem
supported
bands

establish online connection,
whenever CECS is running

select modem switch

use these fields
to change the SIM PIN

or set a new one

Figure 7.29: Modem Configuration
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In the upper part of the screen, the current modem and connection properties are displayed:

State Connection status

Reason Reason of connection failure

Signal Signal strength

Operator Mobile network operator

IP Address IP address of modem

Product Product details

RX/TX Received/transmitted bytes

Bands Radio bands supported by the modem

Use the Provider Helper (see Section 7.9.1) to complete the required information or enter the details manually:

Number: Depending on your provider, the phone number of the GPRS / UMTS or satellite service has to be entered,
e.g., *99#.

If you are using point-to-point protocol (PPP, TCP/IP connection without GPRS or UMTS), enter the phone
number in the relevant field. In this case, the APN is not important, but username and password probably are,
depending on your provider.

In case of doubt contact your provider.

APN (Access Point Name): Enter the APN of the GPRS/UMTS network, which can be requested from the provider
or can be found in the Internet. CDMA does not require an APN.

Use the Provider helper to set APN and provider details automatically. Check the details with your provider.
See Section 7.9.1.

Important
If you are using a SIM card with static IP address, the APN is different from the one offered in the
Provider helper. Ask your provider for the exact APN. See also Section 7.9.3.

Username: Enter the username for the APN, if applicable.

The username will automatically be set by selecting the APN via the Provider helper.

Password: Enter the password for the chosen APN.

Password is automatically set after selecting the APN via Provider helper.

Modem online, whenever CECS is on The checkbox is selected by default. Thus the modem establishes an online
connection as soon as CECS is switched on (automatically or manually). See also Section 7.9.4.

If the checkbox is deselected, the modem only turns on according to the defined actions in the schedule (see
Section 7.2).

Note
The default setting with activated checkbox Modem online, whenever CECS is on can increase
power consumption - depending on modem type and location of the next transmitting mast.

Tip
By deactivating the checkbox Modem online, whenever CECS is on, connection costs can be saved.
The modem will only be switched on according to the scheduled actions. A running CECS system
for maintenance purposes does not switch the modem.

Modem switch: A switch can be selected for automatic control of modem power supply at the Modem switch combo
box (see Section 4.6). An external relai will be controlled by the switch (see also Figure 13.1 for electrical
connection plans). The modem will be power cycled as needed to prevent possible modem hangups.
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Important
If the modem is connected via relay to the data logger, a switch must be configured. Without selecting
a switch for the modem, it will not be power cycled on data logger restart, e.g. after installing an
upgrade or at the end of an action requiring communication. The assigned switch has to be saved
to the data logger configuration. We highly recommend the usage of a modem switch, the modem
may otherwise misbehave.
In Meteo-40 firmware version higher than 1.0 Rev.13915 switch S1 is set by default for the modem.
If a different switch is used to control the modem relai, it must be accordingly selected. If the switch
is not used for the modem, it can be deselected.

Note
The switch configured for the modem supply is not available for sensor configuration.

Important
If you use a BGAN satellite modem, a switch for the LAN connection has to be assigned in the
Communication → LAN menu (see also Section 7.9.7).

PIN: Enter the PIN code of the used SIM card.

New PIN: This field is used, if you like or have to change the PIN. To use it, you need also to enter the PUK below.

PUK The PUK PIN Unlock Key (or Personal Unblocking Code, PUC) is used to activate the new PIN above.

SMS Click here to configure short message functions. See Section 7.9.2.

After connecting a modem, Meteo-40 shows certain modem properties in its display in the Communication → Devices
→ Modem menu. Use the right keyboard button to navigate to the modem properties. Additionally, you can see the
properties such as state, signal strength and bands in the table (see Figure 7.29) displayed in the web interface in the
Communication → Modem menu.

Apply the configuration by clicking on Save. We recommend testing the modem connection. Therefore, activate the
checkbox Modem online, whenever CECS is on. The state of the modem should change to Active, when the modem
has been configured successfully.

Close the modem connection by deactivating the Modem online, whenever CECS is on mode. If no action is running,
the modem connection is closed after 20 minutes from the last user interaction.

The connection will instantly be closed, when CECS is shut down in the System → Administration menu or when the
modem is manually disconnected from Meteo-40.

Important
If you close the modem connection while accessing the data logger over the modem, you will instantly lose
the communication with the data logger and you will not be able to access it until the next scheduled online
action (Communication → Schedule).

Resetting the SIM PIN over the Meteo-40 web interface is only possible, when the SIM card has been locked after
using a wrong PIN. SIM PUK and new PIN are required to unlock the SIM card.

7.9.1 Using the Provider Helper

In order to support users configuring modem settings, Meteo-40 offers a provider wizard, which can be started by
clicking on Use provider helper. After choosing continent and country, the wizard shows available providers and
APNs. Select the relevant APN and click on Finish to set APN, username and password in the modem configuration.
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Note
The Provider helper is designed for SIM cards with dynamic IP address. For SIM cards with static IP
address, refer to your provider to get the details for the modem configuration. See also Section 7.9.3.

The Provider helper does not fill in the number field. Enter number and PIN code manually to finish the modem
configuration.

Continent
Europe

Country
Germany

Provider
O2

Access	point	name/CDMA	access
internet	(o2	MMS)

Finish

available
Access Point Names

Figure 7.30: Meteo-40 Provider Helper

7.9.2 Short Message Service

In order to configure the Short Message Service (SMS), go to the Communication → Modem menu and select SMS.

Important
The Short Message Service on Meteo-40 data loggers can only be used in connection with a PHS8-P
modem. Other modems offered by Ammonit do not support this feature.

	Enable	short	message	service
Receiver	number
+493060031880
SMSC
+491760000443
SMS	password:
•••••••• Show	password

Save	and	send	test	message

Save

Figure 7.31: Settings for Short Message Service

The parameters are:

Enable short message service Tick the checkbox to enable the SMS function of Meteo-40.
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Receiver number This number is currently only used for sending test messages, i.e. one should enter the telephone
number of a mobile phone. The number is not used for other SMS functions of Meteo-40.

SMSC The SMSC (Short message service center) has to be configured for some mobile telephony providers and
SIMs, for others it is not necessary. In case of doubt, ask your mobile telephony provider.

SMS password Enter a password to use the SMS function. Without password the service is not possible. Use at
least eight characters for the password (numbers and letters are allowed).

7.9.2.1 Sending a Short Message

If the SMS feature is activated and a password has been entered, a message can be sent to the telephone number
linked with the SIM in the modem. The content must be

password
command

where password is the configured SMS password and command is an SMS command. Be careful typing the password
respecting upper and lower cases.

Command Description

info or just i, like information

Meteo-40 replys to the short message with its
serial number, software version, internal voltage,
internal current, and internal temperature in that
moment, and the current recording pointer, as
well as state of switches, modem, and Ethernet.

online or just o, like online Meteo-40 tries to get online immediately and
replys the same details as information.

sN+ or sN-, like switch N on/off (N corresponds
to the switch number)

Meteo-40 turns on or off the specified switch
and replys the same details as information. E.g.:
s1+ to switch on S1
s2- to switch off S2.

Table 7.4: Short Message Commands

Note
If you are unsure about the telephone number of the SIM or whether SMS sending works, try the Save and
send test message function.

7.9.3 Working with Static IP SIM cards

If a SIM card with static IP address is used, refer to the configuration details given by your provider to complete the
fields in the Communication → Modem menu. The APN for SIM cards with static IP address is different than for SIM
cards with dynamic IP address. The Provider helper is designed for SIM cards with dynamic IP address.

7.9.4 Two Ways to Establish an Online Connection via Modem

Note
For testing the USB modem communication you can use a link-local connection over USB or LAN simul-
taeously. This connection will not have an influence over the usb modem communication.
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According to the actions scheduled in the Communication → Schedule menu, Meteo-40 has to establish an online
connection. To do so, CECS of Meteo-40 has to be switched on (see also Section 1.4). Meteo-40 offers two possibilities
to set up or control the online connection via modem using the checkbox Modem online, whenever CECS is on:

Modem is online to perform a scheduled action (checkbox inactive) An online connection is established, when
it is needed for an action, i.e., sending emails, uploading files or remote access according to the schedule (see
also Section 7.2).

Modem is online, when CECS is running - independent of scheduled actions (checkbox is active; default) An
online connection via modem is established as soon as CECS (see also Section 1.4) of Meteo-40 is activated,
either manually or according to the schedule in the Communication → Schedule menu. The connection is
closed, when CECS is switched off.
By default the Modem online, whenever CECS is on checkbox is activated and the modem always goes online,
when CECS is running.

Important
The default setting with activated checkbox can increase power consumption - depending on modem
type and location of next transmitting mast.

We recommended deactivating this option, if the CECS always active mode (see Section 4.2) is selected. With
activated CECS always active mode, the modem will stay permanently online, despite the scheduled online
actions.
The mode is independent from the LAN online mode.

7.9.5 Reset PIN Code of Locked SIM Card

If a wrong PIN code has been entered and the SIM card has been locked, use its PUK code to create a new PIN code.
On the bottom of the modem configuration page you can find the appropriate fields (see Figure 7.29). Click on Save
to apply the new PIN code, which will automatically be copied in the PIN code field for the modem configuration.

7.9.6 Connecting a GSM/GPRS Modem to Meteo-40

We recommend testing the modem connection before final installation in the field.

Important
In order to avoid PIN conflicts, we recommend configuring the modem before the modem is connected to
Meteo-40.

Before connecting the modem to Meteo-40 insert the SIM card into the modem. Afterwards the modem can be provided
with power and connected to the data logger. If the modem has been successfully recognized, Meteo-40 shows the
connection in its display Communication → Devices → Modem.

7.9.6.1 Information on Modem Sierra Wireless Airline Fastback Extend EDGE FXT009

If you are using the modem Sierra Wireless AirLine Fastback Extend EDGE FXT009, slide the SIM card into the
modem as shown in Figure 7.32.

Important
It is very important to lock the SIM card slot after inserting the SIM card into the modem. If the SIM card is
not properly placed, connection problems may occur.
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Figure 7.32: Inserting SIM Card into modem Fastback Extend EDGE FXT009

To customize the frequency bands of the modem, connect the modem directly to your computer via USB. If you are
using a Windows™PC and the modem is not displayed in the Device Manager under Modem, you require a driver file,
which can be downloaded from the Sierra Wireless (http://www.sierrawireless.com/) website. On Linux™
PCs, in general no driver file needs to be installed.

After connecting the modem to your PC, go to the Device Manager (see Figure 7.33) and open the properties of the
modem by double-clicking on the modem.

connected modem

Figure 7.33: Device Manager

Go to the Modem tab (see Figure 7.34) to get the name of the COM Port, to which the modem is connected, e.g.,
COM5. Change the Maximum Port Speed to 57600 baud rate. Save the changes.
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COM port

change baudrate

Figure 7.34: Modem Properties

To switch from one supported band to another, you can configure your modem with the help of AT commands.

AT+WMBS=5 (to switch to 850/1900 MHz)
AT+WMBS=4 (to switch to 900/1800 MHz)
AT+WMBS=7 (to switch to 850/900/1800/1900 MHz)

In order to customize the frequency bands, a standard terminal program like PuTTY (http://www.putty.org/)
can be used. Open the program and enter the port number as Serial line and 57600 for the Speed as shown in
Figure 7.35. Open the command window (see Figure 7.36) of the terminal program. In order to test the connection,
enter ”at” and press Enter. If OK is shown, the connection is fine and you can change the frequency bands with the
above mentioned AT commands.

Warning
Make sure to download PuTTY only from its official website or other trusted sources. Malicious versions
have been released, that might copy private information to unauthorized parties.

enter COM port and speed

Figure 7.35: PuTTY Configuration
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Figure 7.36: PuTTY Command Window

Important
Restart the modem after modification.

7.9.7 Connecting a BGAN Satellite Modem to Meteo-40

7.9.7.1 Pointing the terminal to the satelite

It is recommended to test the conectivity outdoors because pointing through a window introduces a slight drop in signal
strength. Most units have audible and visual pointing indicators. The terminal first needs to acquire GPS, which may
take a long time. Some units will then diplay pointing information to help with the orientation of the antena. Line-of-sight
to the satellite is required for connectivity.

7.9.7.2 Configuring Meteo-40 with BGAN Satellite Modem

Important
BGAN modems are not configured using the modem page, but in the LAN page, as shown in Figure 7.26.

BGAN satellite modems are connected via Ethernet to Meteo-40. If you are working with Meteo-40 Revision C with
RS232 slot, you have to use an USB Ethernet adapter to connect the satellite modem to your data logger.

Configure DHCP to automatically assign an IP address to data logger Ethernet port and modem. Both Meteo-40 and
modem must be configured to use DHCP.

Use the software provided by its manufacturer to configure the BGAN satellite modem.

In order to supply the modem, select a LAN switch from the dropdown list in the Communication → LAN menu. Hence
prior to the scheduled actions, the modem can be supplied via the Meteo-40 switch (see Section 7.7). For testing, the
checkbox LAN online, whenever CECS is on may be switched on. So the modem goes online as soon as CECS has
been switched on. After testing, this setting should be switched off to prevent excessive traffic.

For testing the satellite modem, go to the Communication → Schedule menu and press Run now for the online action.
Go to the Communication → Online menu and copy the Ammonit tunnel address of the data logger, e.g., https://
dnnnnnn.tunnel.ammonit.com. Disconnect the data logger from your PC and / or LAN. After entering the copied
address in your browser, you should be able to log into the Meteo-40 web interface.
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7.9.7.3 Recommended Settings for Satellite Connections

Help Logout
Admin	on	D171234

URL:	https://D151234.local/communication/lan/

Interface
Interface

State
State

IP	Address
IP	Address

Product
Product

usb0 Unavailable 169.254.12.34
eth0 Activated 192.168.12.34

	LAN	online,	whenever	CECS	is	on
IP	address	allocation	method:
DHCP

	Connect	to	internet	via	USB	modem	only	(recommended	e.g.	for	SCADA	and	Ethernet	camera)
LAN	switch	(typically	S1):
S2

IP	address
192.168.40.40
DNS	server
192.168.40.1
Gateway
192.168.40.1
Subnet	mask
192.168.40.1
Additional	subnets

Save

Check	optimal	BGAN	settings

Recording: Off Switch	on

Configuration: Saved Save
Connection: ETHERNET,	Tunnel
Remaining: ∞
Date/time: 2017-05-11	14:54:40	UTC

LAN
Please	turn	off	'CECS	is	always	active'

Please	activate	AmmonitOR	with	a	valid	project	key

Please	use	AmmonitOR	for	data	transfer

Please	configure	a	tunnel	access	code

Please	prevent	implicit	tunnel	activation

Please	use	mode	for	reduced	user	interface	interactions

Please	configure	not	more	than	three	online	times	of	max.	one	hour	combined

Please	turn	off	'LAN	online,	whenever	CECS	is	on'

Please	do	not	use	EMail	for	data	transfer

Please	use	daily	CSV	files	with	10	minute	statistics	interval

Figure 7.37: Check BGAN optimal settings

Use the Check optimal BGAN settings button to verify if all recommended settings are propperly configured.

1. We strongly recommend sending data only to AmmonitOR, but not by email. The data transfer to AmmonitOR
consumes less bandwidth than email (see Section 7.2 and Section 7.4).

2. Use only few tunnel connections, e.g. twice or thrice a week for twenty minutes (see Section 7.2).

3. Use a tunnel access code to prevent unauthorized access to the data loggers login page (see Figure 7.3) which
can generate data traffic.

4. To reduce data traffic when using the web user interface, you may want to reduce user interface interactions
(see Figure 7.3).

5. Prevent implicit tunnel activation, only recommended for satellite communication (see Figure 7.3).

6. Do not set the check on LAN online, whenever CECS is on (see Section 7.7).
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7. Be sure to generate not too huge or too many CSV files by keeping the default of one file per day with 10 minutes
statistics interval (see Section 6.3). Avoid gust data files, which may get large, depending on configuration and
wind conditions.

7.10 Troubleshooting

Some mobile service providers and also firewalls in corporate networks restrict the communication of mobile devices
to certain ports. The communication of the Meteo-40 data logger might also be affected. There are different incidents,
e.g., the tunnel connection does not work, but Rx/Tx traffic is possible or the tunnel is accessible, but sending emails
does not work. Reasons for this are often blocked ports by the communication service provider or the firewall or broken
DNS.

7.10.1 How to perform the test for tunnel and AmmonitOR

In the web user interface, just save the online/tunnel parameters or AmmonitOR settings. In this moment the data
logger checks the connection and presents the result.

Alternatively, you can do the check from the LC display. Go to Communication (Figure 7.38). Then select Communi
cation Check (Figure 7.39). This will take some time. After some seconds, you can see the results (Figure 7.40).

System
Status
Channels

> Communication

Figure 7.38: Select ”Communication”

Devices
Activation

> Check Connection
Schedule

Figure 7.39: Select ”Check Connection”

Tunnel accessible
Port 4040 open
AmmonitOR accessible
Port 4041 open

Figure 7.40: View results of check

If one of the servers is not accessible or a port is blocked, please contact your network administrator or mobile service
provider.
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Chapter 8

SCADA

8.1 Configuring Meteo-40 for SCADA

Meteo-40 SCADA Server can be used to monitor performance and production of wind farms by providing reliable
meteorological data. Meteo-40 data loggers support the standard protocols Modbus TCP/IP over Ethernet as well
as Modbus RTU over RS485 (Slave).

SCADA parameters can be configured in the Communication → SCADA menu. In order to activate SCADA for Meteo-
40, select the checkbox Activate SCADA server.

	Activate	SCADA	server
SCADA	protocol
Modbus	TCP

TCP	port
502

Allowed	client	IP	address

Modbus	unit	id
1

RS-485	slave	speed
19200	bps

RS-485	slave	data	format
8N1

Save

Edit	Modbus	register	map

Edit	METEO-32	stream	map

Figure 8.1: Configuring SCADA Parameters

Depending on the SCADA system in which Meteo-40 is integrated, a protocol for data retrieval has to be chosen:

Modbus TCP over Ethernet If you use Modbus TCP, a TCP port has to be entered. The default value is 502. By
entering an IP address in field Allowed client IP address, the access to the data can be restricted to a single IP.
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Only the client with the specified IP address can request data from Meteo-40. If the field is left empty or filled
with value 0.0.0.0, any client is allowed to access the data.

Note
In most SCADA systems, the Ethernet interface should be configured properly with a static IP ad-
dress. Refer to Section 7.7 for further details.

In order to connect Meteo-40 to a fiber optic, an industrial media converter 10/100BaseT to 100BaseFX (-40 ...
75°C) can be used.

Make sure that your Modbus TCP client is addressing the Meteo-40 SCADA server with the proper Modbus unit
ID configured here. The default value is 1.

Modbus TCP uses the unit identificator for routing purposes in case of addressing a device on a MODBUS
or MODBUS+ serial line subnetwork. The Modbus TCP server is still sensitive for this parameter. For further
details see MODBUS Messaging on TCP/IP Implementation Guide V1.0b recommendations at The Modbus
Organization (http://www.modbus.org/).

Modbus RTU over RS485 S (slave) If you are using the Modbus RTU protocol, Modbus Unit ID and RS485 serial
settings (speed and data format) have to be selected.

Note
Some SCADA clients require a half-duplex (2-wire) RS485 interface. In order to convert the 4-wire
RS485 signal delivered by Meteo-40 Revision C data loggers into a 2-wire (half duplex) signal, an
accessory module has to be implemented. Refer to the separate data sheet provided by Ammonit.
For further details contact Ammonit.
The production of Meteo-40 Revision C stopped in October 2012.
The accessory module is not necessary for Meteo-40 Revision D data loggers (with Ethernet port).

If you are using more than one Meteo-40 data logger in your SCADA system, each data logger requires a unique
Modbus Unit ID and all data loggers have to use the same RS485 serial settings (speed and data format).

Meteo-32 Stream Used for streaming Meteo-32 data. A Meteo-32 stream map has to be configured. Refer to Sec-
tion 8.4 for further details.

Save your settings. Otherwise, the configuration is reset to the previous values after moving to another page.

8.1.1 CECS power mode

Important
To use Meteo-40 SCADA server, the CECS must remain permanently on (CECS always active mode)
Figure 8.2 (System → Administration. This mode is automatically set when the SCADA server is activated
in the Communication → SCADA. You can only switch it off again after deactivating the SCADA server.

The CECS always active mode can be configured manually via the web interface (see Section 4.2) or over the display
(Status → CECS, see Section 9.5) of the data logger.

If CECS always active mode is selected, it will be displayed in the status box of the web interface with the infinity
symbol (∞) as well as on the Meteo-40 display with the word Always.
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CECS	Power	Mode
Restart	CECS

Shutdown	CECS

	CECS	is	always	active	(only	recommended	for	SCADA	and	laboratory	use)
Automatic	CECS	reboot
Weekly

Save	CECS	power	mode

Power	CECS	on	digital	status	signal
None

Save	channel

select digital channel for manual
CECS start with voltage peak

choose automatic reboot interval

switch on CECS permanently

Figure 8.2: Configuring CECS always active mode for SCADA

If power supply is disconnected and the data logger shuts down while CECS was running in the CECS always active
mode, it will restart automatically as soon as power is available again.

Note
When CECS is configured to be permanently active, you cannot manually shut down the system by pressing
the middle button on the data logger.

Important
CECS is a fully embedded Linux™ computer (see also Section 1.4). Be aware that the power consumption
of Meteo-40 is higher, when CECS is switched on.

8.1.2 Statistics selection

It is possible to request both live data and statistics over SCADA (see available statistics). For the statistics to be
calculated, a time interval must be selected in Data → Statistics menu.

Important
The time interval over which the SCADA statistics will be calcuated can be modified (see also Section 6.3.1).
This interval is used as well for the Switch manager and the data snaphots

Summary statistic is normally used to calculate the summary over a complete day. It is available for precipitation,
precipitation intensity, status and sun status evaluations. The SCADA summary interval can also be changed in Data
→ Statistics menu.

The Modbus register map in the Meteo-40 web interface only shows the selected statistics from the Data → Statistics
menu. Go to the Data → Statistics menu and select the required data. See also Section 6.3.1.
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8.2 Meteo-40 and Modbus

The configurable Modbus Register Map allows Meteo-40 to operate in most existing SCADA systems. The user must
determine which measurement values should be available for the SCADA Master and configure a unique register
number for each measurement (PDU addressing, first reference is 0). Two separate data bocks are available for input
and holding registers. For more information about the supported function codes see the public function code definition
from the Modbus application protocol specification The Modbus Organization (http://www.modbus.org/).

All registers in range 0 to 65535 not selected to hold a measurement will contain the hexadecimal value FFFFh. If the
register is selected but no valid measurement is present, the invalid value corresponding to the configured data type
is written (see Table 8.1).

Data Type Invalid Value
short (16-bit integer) 7FFFh
ushort (16-bit unsigned integer) FFFFh
long (32-bit integer) 7FFFFFFFh
ulong (32-bit unsigned integer) FFFFFFFFh
IEEE 754 (32-bit single precision binary floating
point)

7FC00000h

Unix Time 00000000h

Table 8.1: Modbus Invalid values
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Input	Registers

Measurements
Measurements

Live
Live

Avg
Avg

Max
Max

Min
Min

SDv
SDv

Sum
Sum

Med
Med

Val
Val

Summary
Summary

Type
Type

Factor
Factor

Anemometer,
Wind	Speed
(m/s)

float	(IEEE754	32-bit) 1

Wind	Vane,
Wind	Direction
(°)

float	(IEEE754	32-bit) 1

Hygro/Thermo,
Humidity	(%) float	(IEEE754	32-bit) 1

Hygro/Thermo,
Temperature
(°C)

float	(IEEE754	32-bit) 1

A1	(V) float	(IEEE754	32-bit) 1

A2	(V) float	(IEEE754	32-bit) 1

A3	(V) float	(IEEE754	32-bit) 1

A4	(V) float	(IEEE754	32-bit) 1

C1	(I) float	(IEEE754	32-bit) 1

Int.	Voltage	(V) float	(IEEE754	32-bit) 1

Int.	Current
(mA) float	(IEEE754	32-bit) 1

Int.
Temperature
(°C)

float	(IEEE754	32-bit) 1

	 Year Month Day Hour Minute Second 	 	 	 	 	
Date/Time	Live 	 	 	 ushort	(16-bit) 	
Date/Time
Statistics

	 	 	 ushort	(16-bit) 	

Date/Time
Summary

	 	 	 ushort	(16-bit) 	

Switches	Live 	 	 	 	 	 	 	 	 ushort	(16-bit) 	
	 Live Start End 	 	 	 	 	 	 	 	
Unix	Time 	 	 	 	 	 	 ulong	(32-bit) 	
Unix	Time
Summary

	 	 	 	 	 	 	 ulong	(32-bit) 	

Holding	Registers

	Write	measurements	to	holding	registers
Set	date/time

Set	switches	state

Stored	Data	Request
Retrieved	unix	time

First	input	register	for	retrieved	data

Modbus	Endianness

Byte	endianness
Big	(most	significant	first)

Word	endianness
Big	(most	significant	first)

Reset	Modbus	Register	Map

Save

Back	to	SCADA

live data

evaluated data
 

aggregated data

measurement
channels

 

internals
 

Figure 8.3: SCADA Modbus Register Table

Column Measurements Name of the evaluation, channel, or measurand. For every measurand either two or four
registers are used, depending on the configurable data type (see Table 8.2).
Name of date, time, and switches fields. Every single value needs one register, with the exception of the UNIX
time (seconds since 1970-01-01 00:00:00 GMT), which needs two registers.

Columns statistics (Live, Avg, ... Med) Here are the fields for the actual registers.

Type For each evaluation or channel, a data type can be selected, e.g., float, (see Table 8.2).
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Factor For each evaluation or channel, a scale factor can be selected, e.g., float, (see Table 8.2).

Live data Describes instantly measured data of the active channels (An, ACn, Cn, Dn, Mn, Pn) and switches (Sn)
as well as instantly evaluated data (Top Anemometer Wind Speed (m/s), Precipitation (mm), etc.). All live data
values, including Live Date/Time and Live Unix Time, are written in the Modbus store with an atomic operation.
This guarantees that the time-stamps, in case configured, match the measurement values.

Aggregated / statistical data The evaluation interval for statistics calculation and generation of newly aggregated
data has to be defined via the Meteo-40 web interface in the Communication → SCADA menu. The following
statistics are available: average, maximum, minimum, standard deviation, sum (for status signals) and median.
Statistics can be applied to channels and to evaluated data. All statisticsl data values, including Statistics
Date/Time and Start-End Unix Time, are written in the Modbus store with an atomic operation. This guarantees
that the time-stamps, in case configured, match the measurement values.

In order to configure the Modbus slave address of the data logger for serial subnetworks, go to the Communication
→ SCADA menu. For further details about Modbus see: www.modbus.org (http://www.modbus.org).

Option Description

Measurements
Data Type and
Scale Factor

Date/time values, i.e., year, month, day, hour, minute, and second, as well as
state of the switches are represented as unsigned short values, stored in one
16-bit Modbus register each. Data type and scale factor do not apply to these
values.
For the measurement value representation, data type and scale factor have
to be selected. Data types short, ushort, long and ulong represent a
measurement value as an integer and store it in one or respectively two
subsequent 16-bit registers. To achieve higher resolution on the
representation or a wider range of values represented with a lower resolution,
the original measured value can be divided by a scale factor before storing it
into the registers as an integer. The default data type is IEEE 754 standard in
binary32 format (32-bit single precision binary floating point), being values
stored in two subsequent 16-bit Modbus registers. In this last case, scale
factor 1 is recommended. See also Equation 8.1.

Modbus
Endianness for
SCADA Server

According to the Modbus Application Protocol Specification V1.1.b, Modbus
is a ’big-Endian’ protocol: ”Modbus uses a ’big-Endian’ representation for
addresses and data items. If a numerical quantity larger than a single byte is
transmitted, the most significant byte will be sent first.” Meteo-40 endianness
can be configured by the user via web interface and is set by default to
’big-endian’ byte order and ’big-endian’ registers order representation (high
byte first, high word first). For example for value -4.395978e-11, the
representation would be: Table 8.3

Modbus register
address
interpretation

For historical reasons, some devices use a starting offset to refer to Modbus
register addresses, depending on the function code used to read the data.
That means, a Modbus client may represent for example Modbus input
register 100 with address 30101 and Modbus holding register 100 with
address 40101.
Meteo-40 does not use this representation. The same measurement values
are available as input and as holding register. Only the register address,
unique for each measurement that will be retrieved and in range 0 to 65535,
must be introduced at the Modbus register table. For the previous example,
only 100 should be introduced at the corresponding text box of the register
table. The Modbus Master can read the data as holding or as input register.

Modbus Device
Identification

Some additional information relative to the physical and functional descripton
of the device is available with function code 43 (see Table 8.4).

Table 8.2: Optional Available Information and configuration
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ValueSCADA =
ValueOriginal

Scalefactor

Equation 8.1: Scale Factor

Representation Byte Endianness Word Endianness
AE41 5650 Big (high byte first) Big (high word first)
5650 AE41 Big (high byte first) Little (low word first)
41AE 5056 Little (low byte first) Big (high word first)
5056 41AE Little (low byte first) Little (low word first)

Table 8.3: Modbus Endianness for SCADA Server

Object Id Description Type

0x00
VendorName: ’Ammonit
Measurement GmbH’

ASCII String

0x01
ProductCode: Data logger
serial number (e.g. ’D151234’)

ASCII String

0x03
VendorURL:
’http://ammonit.com/’

ASCII String

0x04
ProductName: Data logger
name (see Section 4.2)

ASCII String

0x05
ModelName: Data logger type
(e.g. ’Meteo-40L’)

ASCII String

Table 8.4: Modbus Device Identification

8.2.1 Input Registers

Input registers contain the measurement values configured by the user. Meteo-40 SCADA server instantly writes
measured values in the Live registers and the calculated statistics after each interval in the aggregated data registers.
These data can be read with modbus function code 04. Register addresses must be between 0 and 65535. The
following values can be accessed in modbus registers, if so configured in the table:

Live and statistical data of all active channels
Data logger internal values (Int.Voltage (V), Int.Current (mA) and Int.Temperature (°C))
Switches state
Unix Time (for live data and start/end of current statistics interval)
Live data time stamp (Live Date/Time)
Last time of the evaluation interval for statistical data (Statistics Date/Time)

Important
Only measurements selected in menu Data → Statistics (see also Section 6.3.1) are available here for
retrieval.

8.2.2 Holding Registers

Holding registers can be both read or written. If Write measurements to holding registers is selected, the
measurement values from the Input registers table will be also written in the same register numbers from the Holding
registers table. They can be read with function code 03.
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Note
To prevent holding registers from being overwritten by the measurements, the holding and input registers
ranges cannot overlap if Write measurements to holding registers is selected. This means,
you cannot configure a holding register between two input registers. It is recommended to use a complete
different range e.g. 0 to 999 for the input registers and 1000 to 2000 for the holding registers.

Holding registers can be written by the SCADA client in order to achieve any of the following implemented functional-
ities.

Date/Time synchronization To synchronise data logger date and time over Modbus, configure the start holding reg-
ister number for the date/time value (Set Date/Time). By means of a single modbus frame and function code 16
(write multiple registers), year, month, day, hour, minute and second must be written in six subsequent registers,
starting at the previously configured register (16-bit unsigned short values).
A successful syncronization will be logged in the logbook

Important
It is necessary to allow date and time synchronization over SCADA in Section 4.2.

Set switches state If a register number is configured in Set switches state, it is possible to set the current state of
the switches. You can use modbus function code 6 (write single register) to control the state of all 8 switches
with one telegram or function code 5 (write single coil) to set the state of only one switch.
In the first case, you must write write into the configured register the integer representing the state of all switches.
Each bit determines the state of one switch:”0” for open, ”1” for closed switch.
In the second case the configured register is the first address and corresponds to S1. To change the state of
switch ’n’ (Sn) you must write the coil address

Switch
number S8 S7 S6 S5 S4 S3 S2 S1

Bit
Position

7 6 5 4 3 2 1 0

Table 8.5: Set switches state

Stored Data Request To request stored data using Modbus, the holding register for the retrieved unix time and the
first input register for the retrieved data must be configured. Scale factor and data type configuration from the
input registers table will be applied.
Retrieved Unix Time contains the register number where the timestamp of the required period must be written.
With a single Modbus telegram and function code 16 (write multiple registers), the timestamp must be written
as a 32-bit unsigned long in two subsequent holding registers. The statistic values of the first interval starting
after the required timestamp is returned.
First input register for retrieved data contains the number of the first register where the requested stored data
will be available. This offset will be added to the number in the input registers table and the corresponding
measurement value will be available there.
All values from the Stored Data Retrieval range are written in the Modbus store with an atomic operation. This
guarantees that the time-stamps, in case configured, match the measurement values read from the store.
E.g. Retrieved Unix Time = 3000, First input register for retrieved data = 4000, Unix Time Start = 100, Anemome-
ter Wind Speed Avg = 102. To retrieve the data from 2016-1-27 15:00:00 the corresponding Unix Timestamp
(1453903200) should be written in holding registers 3000 and 3001. After writing the timestamp, the Unix Time
at the beginning of the requested interval will be available at register 4000 + 100 = 4100 and the average wind
speed for the requested interval will be available at register 4000 + 102 = 4102.

Note
In case that no valid measurement values were available for the requested period, the first available
period will be returned. It is highly recommended to verify the unix timestamp of the returned data.
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8.3 Cascading two Meteo-40 Data Loggers using RS485

An easy way to cascade two or more Meteo-40 data loggers to get more measurement channels, is to use one Meteo-
40 as RS485 SCADA master, and up to four Meteo-40 as RS485 slaves. All data loggers have to be connected as an
RS485 bus.

Please be aware of the following characteristics of the RS485 cascading:

• Due to the additional communication involved, there is a delay on the cascaded channels, between 1 and 2 seconds.
For most applications, where only 10 minute average data is relevant, this should not be a problem.

• The CECS of the slave or slaves must be always active, leading to a higher energy consumption.
• The slave or slaves have not necessarily a connection to the Internet. If there is no additional modem or a router,

the data loggers cannot be accessed from remote nor can receive software updates easily.
• The master can only read up to 20 Modbus registers per slave at a time. Instead of using four Meteo-40 slaves, one

can also configure the same Meteo-40 up to four times to read different register sets. This allows reading up to 80
Modbus of one slave.

• Care has to be taken, that master and slave configuration fit exactly.

8.3.1 Configuration of the slave or slaves

The Meteo-40 slave or slaves need to be configured as a SCADA device with Modbus RTU protocol and a unique
Modbus unit identifier. Note, that no more 20 registers should be configured. The CECS must be always active.

8.3.2 Configuration of the master

At the master side, every slave has to be added as a RS485 sensor (Other Sensor/Modbus RTU), introducing slave’s
unit identifier as RS-485 address. For all up to 20 registers one should configure a custom evaluation using a linear
equation (see Evaluation Helper).

8.4 Replacing Meteo-32 Data Loggers used for SCADA

To ensure compatibility with Ammonit Meteo-32 data loggers, Meteo-40 offers serial streaming via RS485 S (slave)
port. So Meteo-40 can easily replace operating Meteo-32 data loggers in SCADA systems.

After activating Meteo-40 for SCADA in menu Communication → SCADA, select Meteo-32 Stream as SCADA protocol
and the required RS485 serial settings (baud rate and data format). Save the settings.
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	Activate	SCADA	server
SCADA	protocol
METEO-32	Stream

TCP	port
502

Allowed	client	IP	address

Modbus	unit	id
1

RS-485	slave	speed
9600	bps

RS-485	slave	data	format
8N1

Save

Edit	Modbus	register	map

Edit	METEO-32	stream	map

select METEO-32 stream protocol

select RS485 baudrate

configure METEO-32 stream map

select statistics interval

Figure 8.4: Configuring Meteo-40 for Meteo-32 streaming

In order to set up Meteo-40 for Meteo-32 streaming, configure the Stream Map. Open it via Edit Meteo-32 stream
map. The stream map displays all active channels and evaluated data. For data retrieval, special codes have to be
entered (unlike Modbus register map!). Refer to Table 8.6 and Table 8.7 as well as the example in Figure 8.5.
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Sensor Code Unit Example

Anemometer s 0.1 m/s
Anemometer 1 = s1
Anemometer 2 = s2

Wind Vane d degree
Wind Vane 1 = d1
Wind Vane 2 = d2

Ultrasonic (horizontal wind
speed)

u1 0.01 m/s

Ultrasonic (wind direction) u2 degree
Ultrasonic (vertical wind
speed)

u3 0.01 m/s

Humidity h % Frel
Humidity 1 = h1
Humidity 2 = h2

Temperature t 0.1 K
Temperature 1 = t1
Temperature 2 = t2

Air Pressure b hPa

Barometric Pressure
Sensor 1 = b1
Barometric Pressure
Sensor 2 = b2

Pyranometer r W/m²
Pyranometer 1 = r1
Pyranometer 2 = r2

Precipitation p 0.1 mm/min

Analog Voltage v 0.1 mV
Analog Voltage 1 = v1
Analog Voltage 2 = v2

Counter Input c 0.1 Hz
Counter Input 1 = c1
Counter Input 2 = c2

Status Input i % on
Status Input 1 = i1
Status Input 2 = i2

Int. Temperature ti °C + 40 ti
Int. Voltage vx V vx
Int. Current ic mA ic

Table 8.6: Channel Codes for Meteo-32 Stream Map

Value Code
Average a
Standard Deviation s
Minimum i
Maximum x

Table 8.7: Statistic Codes for Meteo-32 Stream Map
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Live
Live

Avg
Avg

Max
Max

Min
Min

SDv
SDv

Backup	Anemometer,	Wind	Speed
Low	Anemometer,	Wind	Speed
Middle	Anemometer,	Wind	Speed
Top	Anemometer,	Wind	Speed
Backup	Wind	Vane,	Wind	Direction
Low	Wind	Vane,	Wind	Direction
Top	Wind	Vane,	Wind	Direction
Hygro/Thermo,	Humidity
Hygro/Thermo,	Temperature
Int.	Voltage	(V)
Int.	Current	(mA)
Int.	Temperature	(°C)

Reset	Table

Save

Back	to	SCADA

Figure 8.5: SCADA Meteo-32 Stream Map

Click on Save to finish the configuration.
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Chapter 9

Using the Display

The LC display of Meteo-40 with background light is able to show 4 lines, each with 20 characters. In order to navigate
through the menu or to perform an action, use the buttons next to the display.

 
Data Logger Meteo-40

 
 

① switch
on/off

② submenu/
action

③ scroll
down

⑤ scroll
up

④ return

Figure 9.1: Use of the Meteo-40 buttons

1. Press this button for a few seconds to switch Meteo-40 (CECS) on or off.

2. Navigate into a submenu or perform an action.

3. Scroll down in the menu list.

4. Leave the submenu, return to the previous menu.

5. Scroll up in the menu list.

Note
After connecting Meteo-40 to the power supply, the two lower LED lights (red and yellow) turn on for a few
seconds. When the LED lights turn off, Meteo-40 is ready and can be switched on.

9.1 Assigning Permissions to Display Users

In order to avoid that settings are accidentally modified by a display user, e.g., when measurement data is downloaded
on a USB flash drive, you can assign permissions to display users. The configuration can be changed in the System
→ Display menu (see also Section 4.4.1).
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9.2 LED Lights

Meteo-40 has four LED lights next to its display. The two upper LED lights have not yet been assigned a function. The
two lower LED lights (red and yellow) turn on, when Meteo-40 is connected to a power supply and turn off as soon as
Meteo-40 is ready to be switched on. However, the lower LED lights show:

Red (third from the top) Indicates errors in measuring operation. For details see the error list in the display System
→ Errors → Error List.

Yellow (lower LED light) Indicates that RS485 sensors are connected. According to the Modbus protocol the LED
light blinks, when a measurement is made.

9.3 Navigating through the Display Menu

The display menu of Meteo-40 includes four main menu items and several submenu items. The main menu items are
System, Status, Channel and Communication.

In order to jump into a submenu or to perform an action, press the right button. To return to the previous menu, use
the left button. By pressing the upper or the lower button, you can navigate up and down the menu list. For further
details see Figure 9.1.

9.4 Menu: System

Submenu Submenu Item Description

Information
Data Logger

• Type
• Serial Number (Dnnnnnn)
• Channels

Version
• Software version
• Bootloader version

Memory

• RAM including % of memory
used

• Source Memory including %
of memory used. Note, that
the value can go beyond
100%, because the memory
is organized as ring buffer.

Time and Date
Clock

Displays date and time, incl.
time zone

Set Clock

Sets date and time on
Meteo-40 according to NTP
server time and Time Zone
defined in the web interface in
menu System
→ Administration

Errors
Error List Displays the error list
Clear List Clears the error list

Table 9.1: Menu: System
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9.5 Menu: Status

The Status menu includes the information shown in the status box of the Meteo-40 web interface (see Section 3.2
also). In order to switch recording on / off or to save the configuration, press the right navigation button next to the
display.

Submenu Item Description

Rem. Time

• Infty = Infinity (if CECS always active is
selected)

• Remaining time in mm:ss

Recording

• On
• Off (no recording, e.g., after changing the

configuration)

Configuration
• Saved
• Unsaved (changes have been made)

CECS

• When needed
• Always (if CECS always active is

selected)

Ethernet
• Online
• Offline

Modem
• Online
• Offline

Tunnel
• Active
• Inactive

Jobs Number of currently running actions

Table 9.2: Menu: Status

9.6 Menu: Channels

The menu channels contains seven submenus: Evaluations, Analog Voltage, Analog Current, Counter,
Digital Lines, Switches and Internal. In order to set or display the values, press the right button until the
required value appears in the display.

Submenu Property

Evaluations

Displays current values of the evaluation, e.g.,
wind speed, wind direction, temperature etc.
The order of evaluations is explained in
Section 5.1.3.

Table 9.3: Menu: Channels/Evaluations
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Submenu Submenu Item Property Range of Values

Analog A1 (Depending
on the data logger
type, Meteo-40 offers
4, 8 or 12 analog
voltage channels)

Measurement
State On or Off

Value
Displays the current
value

Settings
Range

0.1V, 0.1-0.3V, 1V,
10V

Rate

• 1/8s ... 30s
• 1min ... 30min
• 1h

Switch
State On or Off

ID

Select the appropriate
switch. Depending on
the data logger type,
Meteo-40 offers 2, 4 or
8 switches.

Time

• 1/8s ... 30s
• 1min ... 30min
• 1h

Table 9.4: Menu: Channels/Analog Voltage

Submenu Submenu Item Property Range of Values

Analog AC1
(Depending on the
data logger type,
Meteo-40 offers none,
1 or 2 analog current
input channels.)

Measurement
State On or Off

Value
Displays the current
value

Settings
Range 1mA, 10mA, 100mA

Rate

• 1/8s ... 30s
• 1min ... 30min
• 1h

Switch
State On or Off

ID

Select the appropriate
switch. Depending on
the data logger type,
Meteo-40 offers 2, 4 or
8 switches.

Time

• 1/8s ... 30s
• 1min ... 30min
• 1h

Table 9.5: Menu: Channels/Analog Current
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Submenu Submenu Item Property Range of Values

Counter C1
(Depending on the
data logger type,
Meteo-40 offers 4,8 or
12 counters.)

Measurement
State On or Off

Value
Displays the current
value.

Settings Rate

• 1s ... 30s
• 1min ... 30min
• 1h

Switch
State On or Off

ID

Select the appropriate
switch. Depending on
the data logger type,
Meteo-40 offers 2, 4 or
8 switches.

Time

• 1/8s ... 30s
• 1min ... 30 min
• 1h

Table 9.6: Menu: Channels/Counter

Submenu Submenu Item Property Range of Values

Digital D1 (Depending
on the data logger
type, Meteo-40 offers
2,4 or 8 digital
channels.)

Measurement
State On or Off

Value
Displays the current
value

Settings
Rate

• 1/8s ... 30s
• 1min ... 30min
• 1h

Type

• None
• Thies10bit
• Thies8bit
• Status

Switch
State On or Off

ID

Select the appropriate
switch. Depending on
the data logger type,
Meteo-40 offers 2, 4 or
8 switches.

Time

• 1/8s ... 30s
• 1min ... 30min
• 1h

ClockPin
CLK 5V

Press the right button
to force the clock pin
to 5V for 10 seconds.

CLK 0V
Press the right button
to force the clock pin
to 0V for 10 seconds.

Table 9.7: Menu: Channels/Digital Lines

© 2011 — 2017 Ammonit Measurement GmbH 137



Submenu Range of Values
S1 (Displays a list of switches. Depending on
the data logger type, Meteo-40 offers 2, 4 or 8
switches.

On or Off

Table 9.8: Menu: Channels/Switches

Submenu Property
Voltage Displays the current value
Current Displays the current value
Temperature Displays the current value

Table 9.9: Menu: Channels/Internal

9.7 Menu: Communication

Submenu Submenu Item Property Description

Devices

Modem
Product Name (only
when a modem is
connected)

Quality: displays signal
strength
Status:

• Offline
• Active

Type: indicates
connection mode, i.e.,
GSM
RX Bytes: displays sum
of bytes received
TX Bytes: displays sum
of bytes transferred

LAN

USB

State / Interface

• State: Active
• or Unavailable
• Interface: usb

IP / Netmask: displays IP
address and subnet
mask
Routes: displays router
or gateway address
MAC / Speed: displays
MAC address of the data
logger and the
transmission rate

Ethernet (network
connection)

State / Interface

• State: Active
• Interface: eth

IP / Netmask: displays IP
address and subnet
mask
DNS Servers: displays
DNS server addresses
Routes: displays router
or gateway address
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Submenu Submenu Item Property Description
MAC / Speed: displays
MAC address of the data
logger and transmission
rate
Method: DHCP / Fixed
IP / Link-local (can
be selected using the
keyboard)

WLAN
• Restart
• Active / Inactive
• IP Address

The WLAN connection
can be restarted using
the display.

Activation

Modem: When needed
or Permanent (can be
selected using the
keyboard)
LAN: When needed or
Permanent (can be
selected using the
keyboard)
WLAN: Active or Not
active

Check Connection

Checks the connection
to Tunnel and
AmmonitOR servers, see
Section 7.10.1.

Schedule

Online • Online Perform the respective
actions immediately, by
pressing the right button.
The configuration for the
actions has to be done
beforehand. The dash (-
) is visible, if the action is
not active at the moment,
otherwise it show runs
or done.

AmmonitOR • AmmonitOR
• AmmonitOR Test

Email • Email
• Email Test

Copy • Copy
• Copy Test

Generate CSV • Gen.CSV

SMS • SMS Test
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Chapter 10

Sensors

Meteo-40 data loggers are designed for installation in wind and solar measurement campaigns. Thus the data logger
is compatible with all relevant sensor types. Depending in the data logger type a different number of sensors can be
connected to analog voltage, pulse/counter, digital/serial/status as well as analog current, current source and RS485
channels. See also Chapter 11 and Section 1.3.

Depending on the measurement campaign different sensors are required. Find below a list of measurement instru-
ments for wind measurement and solar measurement purposes as well as a list of other meteorological sensors and
different measurement devices.

Note
If the sensor, you want to connect, is not listed in this manual, refer for technical details and connection
plans to the data sheets on the Ammonit website (http://www.ammonit.com) or contact our sales team
(+49-30-6003188-0 or info@ammonit.com).

10.1 Sensors for Wind Resource Assessment and Wind Farm Mon-
itoring

In order to evaluate the wind conditions at a specific location, various measurements for wind resource assessment
are required. According to IEC 61400-12-1 horizontal wind speed, wind direction as well as air density have to be
measured. Wind energy is calculated as follows:

P = 1/2ρ · A · v³

Equation 10.1: Calculation of Wind Energy [P]

(where A is the area; ρ is the air density, ρ = p / (R • T), being p the air pressure, T the air temperature and R the gas
constant; v is the wind speed)

Therefore, wind speed (v) is the most important parameter, as wind energy (P) is proportional to the cube of wind
speed. Δ1% wind speed ≈ Δ3% wind energy

The following sensors are crucial for wind site assessment:
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Sensor Description Link

Anemometer (wind
speed)

• Most important parameter for wind
measurement

• Wind energy is proportional to the cube of
wind speed

• Install calibrated cup anemometers or
calibrated ultrasonic anemometers

• Heated sensors are recommended for
measurements in cold climates

Note
Vertical wind speed measurement
for turbulence and wind turbine load
analysis with 3D ultrasonic or pro-
peller anemometer.

Section 10.5
(Anemometers)
Section 10.7
(Ultrasonics)
Section 10.5.1
(Propeller
Anemometer)

Wind vane (wind
direction)

• Important parameter for wind farm
micrositing

• Ultrasonic anemometers also determine the
wind direction

Section 10.6 (Wind
vanes)
Section 10.7
(Ultrasonics)

Temperature / Humidity
sensor

• Important parameters for air density
calculation

• Wind energy is linear proportional to the
inverse of air temperature in K

• Measurement of relative humidity
recommended at high temperatures acc. to
IEC

• Combined air temperature and relative
humidity sensors available

Section 10.8

Barometric pressure
sensor

• Important parameter for air density
calculation

• Wind energy is linear proportional to air
pressure

Section 10.9

Ultrasonic anemometer

• Evaluate horizontal wind speed and
direction; 3D ultrasonics measure vertical
wind speed for turbulence analysis

• Recommended for measurements in cold
climates, as ultrasonic anemometers do not
have moving parts and can be fully heated

Section 10.7

Table 10.1: Sensors for Wind Measurement

10.2 Sensors for Solar Resource Assessment

Certain solar measurements are necessary to design profitable solar power plants. Refer to the Ammonit website
(http://www.ammonit.com) to learn more about solar measurement systems. Depending on application (e.g., PV,
CSP, CPV) and size of the solar power plant different measurements are crucial.
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Insolation combines Direct Normal Irradiation (DNI) and Diffuse Horizontal Irradiance (DHI). Both are linked according
to the formula for Global Horizontal Irradiation (GHI):

GHI[W/m²] = DHI[W/m²] + DNI[W/m²] · cos(θ)

Equation 10.2: Calculation of Global Horizontal Irradiation

(where θ is the solar zenith angle)

On a sunny day the insolation is 100% GHI, 20% DNI and 80% DNI·cos(θ).

Sensor Description Link

Pyranometer

• Measures GHI (Global Horizontal
Irradiation), if installed horizontally

• Measures GTI (Global Tilted Irradiation), if
installed tilted as PV panel

• Measures DHI (Diffuse Horizontal
Irradiation), if shaded by a shadow ball or
shadow ring (installation on sun tracker)

Section 10.10

Pyrheliometer

• Measures DNI (Direct Normal Irradiation)
and has to be installed on a sun tracker to
follow the position of the sun on the sky

Section 10.11

Sunshine Duration
sensor

• Indicates the sunshine status as defined by
WMO (sunshine = direct irradiation exceeds
the level of 120 W/m²)

Section 10.12

Solar Tracker

• Capable to orient a payload towards the sun.
Can be combined with different solar
sensors to measure solar radiation global,
direct and diffuse components.

Section 10.13

Soiling Measurement

• Soiling and Irradiance Measurement
Systems collect critical data for evaluating
PV array performance.

Section 10.14

Table 10.2: Sensors for Solar Measurement

Besides measuring the solar conditions at the site of the planned solar power plant, some additional measurements
might be necessary to design the solar power plant, i.e., wind speed, wind direction, air temperature, relative humidity
as well as air pressure (see Table 10.1). In some cases soiling detectors and precipitation sensors are required.

10.3 Other Sensors for Meteorological Purposes

There are several sensors, which are not mandatory for wind and solar resource assessment, but provide important
parameters for ground construction and other influential conditions, e.g., precipitation sensors.
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Sensor Description Link

Precipitation Rain
Gauge

• Measures the amount of precipitation (rain
gauge) Section 10.16

Laser Precipitation
Monitor

• Calculates SYNOP code (Surface Synoptic
Observations)

• Measures intensity of total precipitation
• Measures intensity of liquid precipitation
• Measures intensity of solid precipitation
• Calculates the amount of precipitation

Section 10.17

Table 10.3: Sensors for Meteorological Purposes

10.4 Devices for Electrical Measurements

Meteo-40 can be used to connect power meters, multifunction transducers or other electrical measurement devices,
e.g., for power curve measurement.

Device Description Link

Multifunction
Transducer

• Also power meters or measuring transducers
• Measure average phase voltage, current,

real and reactive power
Section 10.19

Table 10.4: Electrical Measurement Devices

10.5 Anemometers

Anemometers measure the horizontal wind speed (velocity). This parameter is crucial for any wind site assessment.
Cup anemometers are the general standard type of anemometers. They are robust and resistant to turbulence and
skew winds caused by masts and traverses. Each anemometer should be individually calibrated and equipped with a
certified calibration report according to international standards (e.g., MEASNET). At least two anemometers have to
be installed on a met mast. Most anemometers can be equipped with electronically regulated heating.

Refer to the Ammonit website (http://www.ammonit.com/) to learn more about anemometer behavior and accu-
racy.

The wind speed (v) is determined by the linear function of the frequency (impulse) output (I):

v[m/s] =

{
slope[m] · I[1/s] + offset[m/s] : I > 0

0 : I = 0

Equation 10.3: Calculation of Wind Speed (v)

A counter value of 0 will always result in 0, i.e., the offset is ignored in this case.

For wind assessment campaigns it is required to perform an individual MEASNET calibration of each anemometer
in a wind tunnel to achieve optimal accuracy. After calibration, use the values for slope and offset according to the
calibration protocol.

Anemometers are connected to counter channels (Cx). Refer to Figure 13.11 for the connection diagram. Further
details about counter channels can be found in Section 11.2 and Section 12.2.
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Anemometers can easily be configured in the Meteo-40 web interface via the Sensor Helper (see Section 5.1.4).

Sensor Order-No
Thies First Class Advanced S11100 / S11100H
Vector L100 First Class S14100 / S14100H
Thies Compact S12100 / S12100H
Windsensor (Risø) P2546A-OPR S16100C
Vaisala Anemometer WAA252 S15100H

Table 10.5: Overview Anemometers

Important
If you plan to install anemometer NRG #40H (Hall Effect), anemometer Risø P2546A (Reed switch),
anemometer Thies (if open drain is used), an accessory module is needed! Refer to the data sheet and
contact Ammonit for further details.

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

Meteo-40 saves all electrically measured values to the source data (Section 6.7). The calculated wind speed in m/s
is saved to the CSV file (see Section 6.6.1).

Note
The CSV file contains for all active channels the electrical values according to the chosen statistical inter-
val.

10.5.1 Propeller Anemometer Young

The Propeller Anemometer measures horizontal and vertical wind speed. However, it is not classified according to
MEASNET and IEC. The anemometer is widely used to measure vertical wind speed to analyse turbulences and the
wind load of a turbine.

The anemometer uses a transducer, which converts propeller rotation to a DC voltage that is linearly proportional to
air velocity. Connect the sensor to the analog voltage channels (Ax) of your Meteo-40 data logger.

The anemometer can easily be configured in the Meteo-40 web interface via the Sensor Helper (see Section 5.1.4).

Sensor Order-No
Propeller Anemometer Young 27106T S17100

Table 10.6: Overview Propeller Anemometer

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).
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Meteo-40 saves all electrically measured values to the source data (Section 6.7). The calculated wind speed in m/s
is saved to the CSV file (see Section 6.6.1).

Note
The CSV file contains for all active channels the electrical values according to the chosen statistical inter-
val.

10.6 Wind Vanes

Wind vanes indicate the horizontal wind direction. The evaluation of the wind direction enables the best possible
positioning of wind turbines. It is essential that a wind vane covers an entire 360° degree radius - without north gap.

There are different wind vane types available. Ammonit recommends installing digital wind vanes due to their accuracy
and easy connection to the Meteo-40 data logger. Additionally, wind vanes with potentiometer, which are connected
to analog voltage channels, and wind vanes, which are connected to a RS485 bus are compatible with Meteo-40 data
loggers.

10.6.1 Digital Wind Vanes TMR

Ammonit recommends installing digital wind vanes TMR to determine the wind direction. Wind vanes TMR deliver
more precise measurement values than wind vanes POT and are less susceptible to failure because of their solid
state design. Ammonit offers wind vane Thies First Class TMR 10-bit serial-synchron and wind vane Thies Compact
TMR 10-bit serial-synchron.

Wind Vane Accuracy
Thies Compact TMR ± 1°
Thies Compact POT ± 2°
Thies First Class TMR ± 0.5°
Thies First Class POT ± 1°

Table 10.7: Comparison of Wind Vane Accuracy

Each wind vane TMR requires one digital channel, whereas potentiometer wind vanes require two analog voltage
channels each. By installing wind vanes TMR instead of wind vanes POT, analog voltage channels are available for
other analog sensors, e.g., barometric pressure sensor, temperature or humidity sensors.

Tip
Considering a measurement system with wind vanes TMR a smaller Meteo-40 model with less channels
can be sufficient - for example Meteo-40S with 10 channels (4 analog voltage, 4 counter and 2 digital
channels).

Wind vanes TMR are connected to digital channels (Dx). Refer to Figure 13.13 for the connection diagram. Further
details about digital channels can be found in Section 11.3 and Section 12.2.

Wind vanes can easily be configured in the Meteo-40 web interface via the Sensor Helper (see Section 5.1.4).

Sensor Order-No
Thies First Class S21100H
Thies Compact S22100 / S22100H

Table 10.8: Overview Wind vanes TMR
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Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

10.6.2 Wind Vanes with Potentiometer

In order to determine the wind direction with a potentiometer wind vane, e.g., Thies First Class and Thies Compact,
it has to be connected to two analog voltage channels (Ax,Ay e.g. A1,A2). Ax indicates the total voltage (UAx); Ay

indicates the partial voltage (UAy). The following equation shows the calculation of the wind direction (D).

D[°] =
UAx[V]

UAy[V]
· 360° + offset[°]

Equation 10.4: Calculation of the Wind Direction (D)

The Offset [°] must be filled when the wind vane has not been precisely aligned to the north, e.g., when the wind
vane has been aligned to the mast. The offset specifies the angle between the North and the point the wind vane has
been aligned to.

The Offset for each wind vane is configured in the Sensor Helper (see Section 5.1.4) of the Meteo-40 web interface.

Refer to Figure 13.7 for the connection diagram. Further details about analog voltage channels can be found in
Section 11.1 and Section 12.2

Sensor Order-No Offset
Thies First Class S21200H 0° (if aligned to the North)
Thies Compact S22200 / S22200H 0° (if aligned to the North)

Table 10.9: Parameters for the configuration of potentiometric wind vanes

Important
If potentiometric wind vanes, e.g., Thies First Class, Thies Compact, Vector W200P, Vector W200P/L, NRG
#200P, are installed, protection resistors are needed. Contact Ammonit regarding further details about the
accessory module!

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

Meteo-40 saves all electrically measured values to the source data (Section 6.7). The calculated wind direction in °
(degree) is saved to the CSV file (see Section 6.6.1).

Note
The CSV file contains for all active channels the electrical values according to the chosen statistical inter-
val.
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10.6.3 Wind Vanes connected to RS485 bus

There are certain wind vanes, which can be connected to the RS485 bus of the Meteo-40 data logger. Up to 8 smart
sensors can be connected to the RS485 bus of Meteo-40.

Wind vanes can easily be configured in the Meteo-40 web interface via the Sensor Helper (see Section 5.1.4). See
Table 10.10 for the configuration of RS485 wind vanes.

Model Protocol Description Channels / Evaluated
Data Required Configuration

Thies First
Class

Thies
Mx_1: Wind speed,
Mx_2: Wind direction

Serial settings, Address,
Half duplex mode

Thies Wind
Vane 8-bit
parallel via
ICP DAS
I7051

DCON

RS485
module to
connect two
Thies 8-bit
parallel wind
vanes

Mx_1: Wind direction
vane DI: 0..7,
Mx_2: Wind direction
vane DI: 8..15

Same configuration as
for Meteo-32 (Serial
settings: 38400 8N1,
Address: 6, Checksum:
disabled)

Table 10.10: Configuration of RS485 Wind Vanes

Meteo-40 saves all measured values to the source data (Section 6.7). The wind direction in ° (degree) is saved to the
CSV file (see Section 6.6.1).

10.7 Ultrasonic Anemometers

Ultrasonic anemometers are devices, which measure horizontal wind speed, wind direction as well as acoustic virtual
temperature. 3D sensors also measure the vertical wind velocity, which is important for turbulence and wind load
calculations.

Important
If more than one ultrasonic anemometer should be connected via RS485, all connected sensors have to
use the same protocol. Additionally, each ultrasonic sensor has to use a unique ID (RS485 address), which
has to be configured for the sensor. The transmission mode for all rs485-connected sensors has to be
configured to half duplex.

Ultrasonic anemometers are connected to the RS485 bus of Meteo-40. The following ultrasonic anemometers are
compatible with Meteo-40 data loggers:

Model Protocol Description Channels / Evaluated
Data Required Configuration

Thies 2D
Anemometer

Thies Telegram 3

Mx_1: Wind speed,
Mx_2: Wind direction,
Mx_3: Acoustic virtual
temperature

serial settings, address, half
duplex mode, scalar
averaging over 1 s

Thies 3D
Anemometer

Thies Telegram 3

Mx_1: Wind speed azimuth,
Mx_2: Wind direction
azimuth,
Mx_3: Wind speed
elevation,
Mx_4: Acoustic virtual
temperature

serial settings, address, half
duplex mode, scalar
averaging over 1 s
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Model Protocol Description Channels / Evaluated
Data Required Configuration

Thies Clima
Sensor US

Thies Telegram 6

Mx_1: Wind speed,
Mx_2: Wind direction,
Mx_3: Temperature,
Mx_4: Humidity
Mx_5: Air pressure,
Mx_6: Brightness max.
value,
Mx_7: Direction of
brightness,
Mx_8: Precipitation status,
Mx_9: Precipitation
intensity,
Mx_10: Precipitation sum,
Mx_11: SYNOP

serial settings, address, half
duplex mode, no date and
timestamp

NMEA - Thies
Compact
Anemometer

NMEA

Sensors
supporting
NMEA V2.0
standard. I.e.
Thies,
Telegram 3

Mx_1: Wind direction,
Mx_2: Wind speed

serial settings, address,
NMEA protocol, half duplex
mode, scalar averaging
over 1 s

Lufft 2D
VENTUS-
V200A-UMB

Modbus
registers 14
and 25

Mx_1: Wind direction,
Mx_2: Wind speed

serial settings, address,
Modbus protocol, parity
none, scalar averaging over
1 s

Lufft Weather
station
WSx-UMB

Modbus
registers 10,
14, 22, 31
and 47

Mx_1: Relative humidity
(act.),
Mx_2: Rel. air pressure
(act.),
Mx_3: Wind direction fast,
Mx_4: Air temperature °C
(act.),
Mx_5: Wind speed fast m/s

serial settings (38400 bps),
address, Modbus protocol,
parity none, scalar
averaging over 1 s

Gill
Windmaster
Pro 3D
Anemometer

Gill Mode 4

Mx_1: Wind direction
azimuth,
Mx_2: Wind speed azimuth,
Mx_3: Wind speed
elevation,
Mx_4: Sonic temperature (if
activated)

serial settings (B5: 38400
bps, 8N1), address (default
Q), averaging inactive (G0),
sampling rate 20 Hz (P8),
polar polled (M4), output
format CSV (O1), Sonic
temperature activated (A3)

Gill Wind
Observer 2D
Anemometer

Gill Mode 4

Mx_1: Wind direction
azimuth,
Mx_2: Wind speed azimuth,
Mx_3: Sonic temperature (if
activated)

serial settings (B5: 38400
bps, F1: default 8N1),
address (default A),
averaging inactive (G0),
sampling rate 20 Hz (P8),
polar polled (M4), output
format CSV (O1), Sonic
temperature activated (A2)

10.7.1 NMEA V 2.0

Supported NMEA telegram: $WIMWV,<dir>,<ref>,<spd>,<uni>,<sta>*<chk><CR><LF>

• <dir>: Wind direction xxx.x
• <ref>: Reference R = relative
• <spd>: wind speed xxx.x
• <uni>: Wind speed unit is Kilometers per hour
• <sta>: Status A = valid
• <chk>: Checksum (8-bit XOR, excluding $ and *)
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• <CR>: Carriage return code, ASCII 0DH
• <LF>: Line feed code, ASCII 0AH

Telegram must have 29 bytes.

10.7.2 Thies Ultrasonic Configuration Options

Before connecting any Thies sensor to Meteo-40, the sensor has to be configured. Three ultrasonic types are available:
2D compact, 2D and 3D.

Ammonit recommends configuring Thies ultrasonic sensors as follows:

Required settings

• Half duplex for transmission mode
• Unique ID for each sensor connected to the bus
• Heating ON/OFF

Further Thies-specific settings

• Voltage threshold for heating suppression: 17 V (HC=17)
• Serial settings: 38400 bps, 8N1 (data format)
• Average mode: scalar-averaged velocity and vectorial-averaged angle (AM=2)

Important
If more than one ultrasonic anemometer should be connected via RS485, all connected sensors have to
use the same protocol. Additionally, each ultrasonic sensor has to use a unique ID (RS485 address), which
has to be configured for the sensor. The transmission mode for all RS485-connected sensors has to be
configured to half duplex.

Tip
For more information about Thies acoustic virtual temperature, see sensor’s manual.

10.7.3 Lufft UMB Configuration Tool

Before connecting any Lufft sensor to Meteo-40, it has to be configured. Download and install the software UMB-
Config-Tool (http://www.lufft.com/en/support/downloads/software/?subcategory1=61) and follow
the next steps:

1. Power on the sensor.

2. Connect sensor’s A-, B+ to your computer using RS485 to USB or RS232 adapter.

3. Start Config-Software-UMB and setup the connection in the Edit → Connection settings menu.

4. In order to configure the sensor, switch all sensors temporarily to UMB protocol in the Options menu (follow
instructions).

5. Add the new sensor in the Edit → Sensor menu. Select the appropriate type from the list and ID (default 1). Do
not exit this menu, press Configure to access the sensor configuration.

6. Load the profile from the sensor (press the button again, if it does not respond). Select the tab with sensor type
name and configure as described in the table above (see Section 10.7).

7. Store profile on sensor to apply the configuration changes to the sensor. Save the profile also to your disk to
keep a copy of the sensor configuration.

8. Close the configuration program, disconnect and power off the sensor. Connect the sensor to the data logger
and power on the sensor.
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9. Add the sensor to the sensor list of the data logger in the Measurement → Sensors menu, applying the same
configuration.

Important
If more than one ultrasonic anemometer should be connected via RS485, all connected sensors have to
use the same protocol. Additionally, each ultrasonic sensor has to use a unique ID (RS485 address), which
has to be configured for the sensor. The transmission mode for all RS485-connected sensors has to be
configured to half duplex.

10.7.4 Gill Wind Configuration Tool

Before connecting any Gill sensor to Meteo-40, configure the settings. Download and install Gill Wind Com (http:
//www.gill.co.uk/main/software.html) and follow the next steps:

Use the Wizard tool to change from the default configuration all parameters specified in the upper table (see Sec-
tion 10.7).

1. Do not forget to save the configuration report in the Tools menu.

2. Close the configuration program, disconnect and power off the sensor. Connect the sensor to the data logger
and power on the sensor.

3. Add the sensor to the Meteo-40 sensors list in the Measurement → Sensors menu, applying the same config-
uration.

Note
Any wind magnitude lower than defined by sensor’s parameter K (default 0.050 m/s) will omit the wind
direction.

Important
Gill Windmaster sensors are not designed to connect more than one unit to a bus.

10.8 Temperature Humidity Sensors

Temperature sensors measure the air temperature, while humidity sensors measure the air humidity. Both sensors
are often applied in combination to reduce cost.

Temperature humidity sensors, e.g., Galltec Active KP, Galltec Active TP, have to be connected to analog voltage
channels (Ax). Refer to Figure 13.4 for the connection diagram.

The output signal (U) from the temperature sensor is proportional to the temperature (T) in °C.

T[°C] = slope[°C/V] · U[V] + offset[°C]

Equation 10.5: Calculation of Temperature (T)

The output signal (U) from the humidity sensor is proportional to the humidity (RH) in %.
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RH[%] = slope[%/V] · U[V]

Equation 10.6: Calculation of Humidity (RH)

Slope and Offset are internal parameters of the sensor, which are important to calculate temperature (T) in °C and
humidity (RH) in %. Both values are pre-configured in the Sensor Helper (see Section 5.1.4).

Note
For more flexibility, when connecting the combined Galltec temperature and humidity sensor to Meteo-40,
two different Galltec Active KP sensors are listed in the Sensor Helper (see Section 5.1.4). Two analog
channels are needed and thus the order of the signals to be connected is selectable. ”Galltec Thermo-
Hygro Active KP” assigns the first analog channel to temperature and the second to humidity. As opposite,
”Galltec Hygro-Thermo Active KP” assigns the first channel to humidity and the second to temperature.

Sensor Order-No Slope Offset
Galltec Active KP
(Temperature + Humidity)

S52100
100%/V (Humidity)
100°C/V (Temperature)

0% (Humidity)
-30°C(Temperature)

Galltec Active TP
(Temperature)

S42100 100°C/V -30°C

Table 10.11: Parameters for the configuration of temperature humidity sensors

Important
If you install calibrated sensors, enter the values given in the calibration protocol.

Meteo-40 saves all electrically measured values in V to the source data (Section 6.7). The calculated values for
temperature (°C) and humidity (%) are saved to the CSV file (see Section 6.6.1).

Note
The CSV file also contains for all active channels the electrical values according to the chosen statistical
interval.

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

10.8.1 Resistance Temperature Detectors (RTD) / Pt100 / Pt1000

RTDs measure the temperature by correlating the resistance of the RTD element with temperature. Those sensors
provide high accuracy and repeatability; the sensors are suitable for precision applications. RTDs use electrical resis-
tance and require a power source to operate.

Platinum Resistance Thermometers (Pt100 / Pt1000) are classified according to DIN EN 60751 - see tolerance classes
below.
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Tolerance Class Tolerance in K
Class B1/3 DIN ±(0.10K+0.0017x[t])
Class A ±(0.15K+0.002x[t])
Class B ±(0.30K+0.005x[t])
Class 0.5 ±(0.50K+0.006x[t])

Table 10.12: Tolerance Classes - Platinum Resistance Thermometers (Pt100)

Pt100 / Pt1000 sensors have to be connected to the analog voltage channel and the current source of Meteo-40
data loggers. The sensors can easily be configured via the Sensor Helper (see Section 5.1.4) in the Meteo-40 web
interface.

Meteo-40 saves all electrically measured values in V to the source data (Section 6.7). The calculated value for tem-
perature (°C) is saved to the CSV file (see Section 6.6.1).

Note
The CSV file also contains for all active channels the electrical values according to the chosen statistical
interval.

10.8.2 Temperature Humidity Sensors connected to RS485 bus

There are certain temperature humidity sensors available, which have to be connected to the RS485 bus of the Meteo-
40 data logger. The sensors can easily be configured in the Meteo-40 web interface via the Sensor Helper (see
Section 5.1.4).

Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion
Galltec
Thermo/Hygro
KPC.MS

Modbus
registers 0, 1,
3, 4

Mx_1: Temperature
Mx_2: Humidity

Fixed serial
settings
(19200 8N1)

Table 10.13: Data request for RS485 Temperature Humidity Sensors

Meteo-40 saves all measured values to the source data (Section 6.7). The values for temperature (°C) and humidity
(%) are saved to the CSV file (see Section 6.6.1).

10.9 Barometric Pressure Sensors

Barometric pressure sensors measure the air pressure. Air pressure and air temperature should be evaluated for an
accurate wind site assessment. It is recommended including an air pressure sensor as part of a measuring system.

Barometric pressure sensors, e.g., AB60, AB100 and Vaisala PTB110, have to be connected to analog voltage chan-
nels (Ax). Refer to Figure 13.3 for the connection diagram.

The output signal (U) from the barometric pressure sensor is proportional to the air pressure (P).

P[mbar] = slope[mbar/V] · U[V] + offset[mbar]

Equation 10.7: Calculation of Air Pressure (P)
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Slope and Offset are internal parameters of the sensor, which are important to calculate the air pressure in hPa.
Both values are pre-configured for sensors listed in the library of the Sensor Helper (see Section 5.1.4).

Sensor Order-No Slope Offset
Ammonit AB60 S31100 60 mbar/V 800 mbar
Ammonit AB100 S31200 100 mbar/V 600 mbar

Vaisala PTB110
S32100 for PTB 110.3
S32200 for PTB 110.2
S32300 for PTB 110.1

60 mbar/V 800 mbar

Table 10.14: Parameters for the configuration of barometric pressure sensors

Important
If you install calibrated sensors, enter the values given in the calibration protocol.

Meteo-40 saves all electrically measured values in V to the source data (Section 6.7). The calculated air pressure
value in mbar is saved to the CSV file (see Section 6.6.1).

Note
The CSV file contains for all active channels the electrical values according to the chosen statistical inter-
val.

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

10.9.1 Barometric Pressure Sensors connected to RS485 bus

Certain barometric pressure sensors have to be connected to the RS485 bus of the Meteo-40 data logger. The sensors
can easily be configured in the Meteo-40 web interface via the Sensor Helper (see Section 5.1.4).

Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion
Thies Baro
Transmitter

Thies Telegramm 1
Mx_1: Air pressure,
Mx_2: Temperature

serial settings,
address

Table 10.15: Data request for RS485 Barometric Pressure Sensors

Meteo-40 saves all measured values to the source data (Section 6.7). The air pressure value in hPa is saved to the
CSV file (see Section 6.6.1).

10.10 Pyranometers

Pyranometers measure the global horizontal radiation. They are also used as reference instruments thanks to their
measurement precision. The use of this sensor is crucial for measurements with solar-powered applications.
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Meteo-40 indicates for pyranometers the global horizontal irradiation (GHI).

Pyranometers, e.g., MS series of EKO Instruments or CMP series of Kipp & Zonen, have to be connected to analog
voltage channels (Ax). Refer to Figure 13.2 for the connection diagram.

The output signal (U) from the pyranometer is proportional to the solar irradiance (E) in W/m².

E[W/m²] =
U[μV]

Sensitivity[μV/[W/m²]]

Equation 10.8: Calculation of Solar Irradiance (E)

Sensitivity is an internal parameter of the sensor, which is important to calculate the radiation in W/m². The value
is given in the calibration certificate of the sensor.

Sensor Order-No
EKO MS-802 S64120
EKO MS-410 S64130
EKO MS-602 S64110
Kipp & Zonen CMP11 S61120
Kipp & Zonen CMP6 S61110
Kipp & Zonen CMP3 S61100
Hukseflux Pyranometer LP 02 S63100
Hukseflux Pyranometer SR 1 S63120

Table 10.16: Pyranometers

Meteo-40 saves all electrically measured values in V to the source data (Section 6.7). The calculated values for solar
radiation are saved in W/m² to the CSV file (see Section 6.6.1).

Note
The CSV file also contains for all active channels the electrical values according to the chosen statistical
interval.

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

10.10.1 Pyranometer: Delta-T Sunshine SPN 1

The pyranometer Delta-T Sunshine SPN 1 measures global horizontal and diffuse irradiation in W/m². It provides 2
analogue voltage outputs (Ax) for global and diffuse irradiation, and 1 digital output (Dx) for sunshine duration.

Additionally, Meteo-40 estimates the direct normal irradiation based on the values of global horizontal and diffuse
irradiation according to the general formula: Global Horizontal Irradiation = Diffuse Horizontal Irradiation + Direct
Normal Irradiation � cos(θ), where θ is the solar zenith angle

The order number for Delta-T Sunshine SPN 1 is S65100.

Important
In order to estimate direct normal irradiation (DNI) and sun status, latitude and longitude of the measurement
station have to be entered in the System → Administration menu (see also Section 4.2).
If any estimated values should be included in the CSV statistics file, the values have to be selected in the
Data → Statistics menu under Select statistics (see also Section 6.3.1).
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Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

10.11 Pyrheliometers

Pyrheliometers are used to measure the direct irradiance emitted by the sun in a 5 degree angle. The sensors have
to be connected to the analog voltage channels (Ax) of Meteo-40.

The output signal (U) from the pyrheliometer is proportional to the solar irradiance (E) in W/m².

E[W/m²] =
U[μV]

Sensitivity[μV/[W/m²]]

Equation 10.9: Calculation of Direct Solar Irradiation (E)

Sensitivity is an internal parameter of the sensor, which is important to calculate the irradiation in W/m². The value
is given in the calibration certificate of the sensor.

Meteo-40 indicates for pyrheliometers direct normal irradiation. Additionally, the data logger estimates DNI � cos(θ)
and sun status based on the recorded values for direct normal irradiation. In order to estimate sun status and DNI �
cos(θ), latitude and longitude of the measurement station have to be entered in the System → Administration menu
(see also Section 4.2)

The sensor often comes with built-in Pt100 sensor and thermistor. The Pt100 sensor can be connected to the current
source (see Section 11.5) of Meteo-40.

If the built-in Pt100 sensor should be connected to Meteo-40, pyrheliometer and Pt100 sensor have to be config-
ured separately in the Sensor Helper: Pyrheliometer via sensor type Solar Sensors and Pt100 via sensor type Hy-
gro/Thermo.

Important
Do not connect the thermistor to Meteo-40!

Sensor Order-No
EKO MS-56 S64210
Kipp & Zonen CPH1 S62210

Table 10.17: Pyrheliometers

Important
In order to estimate sun status and direct normal irradiation [DNI � cos(θ)], latitude and longitude of the
measurement station have to be entered in the System → Administration menu (see also Section 4.2).
If any estimated values should be included in the CSV statistics file, the values have to be selected in the
Data → Statistics menu under Select statistics (see also Section 6.3.1).

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).
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10.12 Sunshine Duration Sensors

Sunshine duration sensors indicate the sunshine status as defined by the WMO (sunshine = irradiation exceeds the
level of 120 W/m²). The sensor measures the irradiation and switches the output voltage high or low to indicate sunny
or not sunny conditions.

Sunshine duration sensors, e.g., Kipp & Zonen CSD 3, have to be connected to analog voltage channels (Ax). If direct
irradiation should be measured, connect this output also to another analog voltage channel (Ax). Refer to Figure 13.2
for the connection diagram.

The output signal (V) indicates sunshine or no sunshine. Additionally, the calculated direct irradiation can be measured.
The output signal (mV) for direct irradiation is proportional to the direct irradiation (W/m²).

E[W/m²] =
U[μV]

Sensitivity[μV/[W/m²]]

Equation 10.10: Calculation of Solar Irradiation (E)

Sensitivity is an internal parameter of the sensor, which is important to calculate the radiation in W/m². The value
is given in the calibration certificate of the sensor.

Meteo-40 saves all electrically measured values in V to the source data (Section 6.7). The calculated values for direct
irradiation are saved in W/m² to the CSV file (see Section 6.6.1).

Sensor Order-No
Kipp & Zonen CSD 3 S61910

Table 10.18: Sunshine Duration Sensors

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

Meteo-40 saves all electrically measured values to the source data (Section 6.7). The calculated direct irradiation in
W/m² and the current sun status are saved to the CSV file (see Section 6.6.1).

Note
The CSV file contains for all active channels the electrical values according to the chosen statistical inter-
val.

10.13 Solar Trackers

EKO Instruments high precision STR Sun Tracker provide high tracking reliability, enhanced functionality with fully
automated set up procedure through a built in GPS receiver. The compact sun trackers are suited to support all kinds
of measurement sensors to measure Global, Diffuse and Direct Radiation.

EKO Sun Trackers must be connected to RS485-M port by means of an RS232 to RS485 adapter.

Date, time and location are acquired from the sensor by means of commands TM and LO. If the data logger values
are significantly different, Meteo-40 will get automatically synchronized and the changes will be logged in the logbook.
This syncronization happens in two cases: when configuring the sensor and on every CECS reboot. If you want to
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trigger the syncronisation routine, you can access the configured EKO Sun Tracker for editing and save it again without
changeing the configuration.

According to the configured polling rate, which is 1 s per default, the calculated angle according to the GPS information
and the current angle are requested and recorded.

Important
Make sure that no other method to synchronize date and time is active (Section 4.2).

Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion

EKO Sun
Tracker

EKO
Commands
MR and CR

M1_1: Azimuth calculated
(CR),
M1_2: Altitude calculated
(CR),
M2_1: Azimuth (MR),
M2_2: Altitude (MR)

serial settings

Table 10.19: Data request for RS485 Sun Tracker

10.14 Soiling Measurement

Soiling and Irradiance Measurement Systems with the Atonometrics RDE300 Series measurement and control unit
collect critical data for evaluating PV array performance. The systems can be used at operating PV power plants and
pre-construction site survey locations.

Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion

Atonometrics
RDE300

Modbus RTU

M1_1: Global Irradiance
PV1,
M1_2: Analog Current PV1,
M1_3: Temperature PV1,
M1_4: Active Power PV1,
M2_1: Global Irradiance
PV2,
M2_2: Analog Current PV2,
M2_3: Temperature PV2,
M2_4: Active Power PV2,
M2_5: Soiling Ratio,
M2_6: Soiling Ratio Isc,
M2_7: Soiling Ratio Pmax,
M3_1: Event Code,
M4_1: Status Fluid,
M5_1: Status Pump

Serial
settings,
address

Table 10.20: Data request for RS485 Soiling Measurment
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10.15 Rotating Shadowband Irradiometer

Measure Global, Diffuse and Direct Radiation from two LiCor sensors as well as the temperature. The average values
from both sensors are also calculated.

Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion

CSPS RSI CSPS

M1_1: Global Horizontal
Irradiance (GHI),
M1_2: Difuse Horizontal
Irradiance (DHI),
M1_3: Direct Normal
Irradiance (DNI),
M1_4: Temperature,
M1_5: GHI LiCor 1,
M1_6: DHI LiCor 1,
M1_7: DNI LiCor 1,
M1_8: GHI LiCor 2,
M1_9: DHI LiCor 2,
M1_10: DNI LiCor 2

Serial settings

Table 10.21: Configuration of RS485 CSPS RSI

10.16 Precipitation Sensors (Rain Gauge)

Precipitation sensors are designed to measure the quantity and intensity of precipitation striking the earth’s surface.
Precipitation is best measured with a tipping bucket device. Precipitation, collected over a surface of 200 cm², is con-
ducted through an inflow sieve into a tipping bucket. When the bucket has collected 2 cm³ = 0.1 mm of precipitation, it
tips over. This measurement principle is based on the “Guide to Meteorological Instruments No 8, WMO”. Precipitation
sensors are typically applied for meteorological assessments.

Precipitation sensors, e.g., Young precipitation sensor, have to connected to counter channels (Cx). Refer to Fig-
ure 13.12 for the connection diagram.

The output signal (I) from the sensor is proportional to the precipitation quantity (N).

Nμm = slope[μm/pulse] · I[pulse]

Equation 10.11: Calculation of Precipitation Quantity (N)

Slope is an internal parameter of the sensor, which is important to calculate the precipitation quantity according to the
measurement rate set in the sensor configuration. The value is pre-configured in theSensor Helper (see Section 5.1.4).

Sensor Order-No Slope Offset
Thies Precipitation Sensor S71100H 0.1 mm/I 0 mm
Young Precipitation Sensor S73100 / S73100H 0.1 mm/I 0 mm

Table 10.22: Parameters for the configuration of precipitation sensors

Important
If you install calibrated sensors, enter the values given in the calibration protocol.
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Meteo-40 saves all electrically measured values in Pulse [I] to the source data (Section 6.7). The calculated values
are saved to the CSV file (see Section 6.6.1).

Note
The CSV file also contains for all active channels the electrical values according to the chosen statistical
interval.

Important
If you plan to install precipitation sensor Thies or Young, you have to implement an accessory module!
Refer to the data sheet and contact Ammonit for further details.

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

10.17 Laser Precipitation Monitors

Laser precipitation monitors measure various precipitation details, i.e., intensity of total, liquid and solid precipitation
as well as the precipitation amount and the SYNOP parameter.

Thies Laser Precipitation Monitor (LPM) sensor performs a new calculation every minute, after the first 5 minutes of
operation. Meteo-40 requests data with a 1s-rate in order to guarantee a valid measurement per minute with a working
sensor.

Thies LPM has to be connected to RS485-M port.

Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion

Thies Laser
Precipitation
Monitor

Thies Telegram 8

Mx_1: SYNOP,
Mx_2: Intensity total
precipitation,
Mx_3: Intensity liquid
precipitation,
Mx_4: Intensity solid
precipitation,
Mx_5: Precipitation amount

Serial
settings,
address, half
duplex mode,
no automatic
telegram
sending

Table 10.23: Configuration of RS485 Laser Precipitation Monitor Sensors

Note
SYNOP (surface synoptic observations) is a numerical code used for reporting weather observations, also
called FM-12 by the World Meteorological Organization. Refer to Thies LPM sensor’s manual for more
information.
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10.18 Other Sensors / Devices compatible withMeteo-40 RS485 bus

In addition to meteorological sensors, further RS485-compatible sensors or devices can be connected to the Meteo-40
RS485 bus. The following list includes some sensors and their configuration.

Sensor
type Model Protocol Description Channels / Evaluated

Data

Required
Configura-

tion

Multi
Channel
Voltage
Module

Gantner
e.bloxx A1

Modbus
registers 17
to 32

Mx_1: Analog Voltage
AI1,
Mx_2: Analog Voltage
AI2,
Mx_3: Analog Voltage
AI3,
Mx_4: Analog Voltage
AI4,
Mx_5: Analog Voltage
AI5,
Mx_6: Analog Voltage
AI6,
Mx_7: Analog Voltage
AI7,
Mx_8: Analog Voltage
AI8

Serial
settings,
address,
protocol,
channels
definition

Multi
Channel
Voltage
Module

Gantner
e.bloxx
A3-1

Modbus
registers 17
to 26

Mx_1: Analog Voltage
1,
Mx_2: Analog Voltage
2,
Mx_3: Analog Voltage
3,
Mx_4: Analog Voltage
4,
Mx_5: Digital status

Serial
settings,
address,
protocol,
channels
definition

Multi
Channel
Digital
Module

Gantner
e.bloxx
D1-1

Modbus
registers 0
to 7

Mx_1: Digital status 1,
Mx_2: Digital status 2,
Mx_3: Digital status 3,
Mx_4: Digital status 4,
Mx_5: Digital status 5,
Mx_6: Digital status 6,
Mx_7: Digital status 7,
Mx_8: Digital status 8

Serial
settings,
address,
protocol,
channels
definition

Table 10.24: Configuration details for other RS485 Sensors / Devices

10.18.1 Configuring generic Modbus RTU sensors

It is possible to connect up to 8 Modbus RTU sensors to RS485-M port. They can be combined with other Modbus
RTU sensors implemented in Meteo-40 like Lufft sensors, but not with other protocols like Thies or Gill.
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Sensor	type:
Other	Sensor

Sensor:
Modbus	RTU

Installation	height	(m):
0.0

Label:

Serial	number:

Evaluation	type:
Other	Evaluation

Unit

RS-485	Channel:
M1

RS-485	address	(0..247)
1

Data	Type:
ushort	(16-bit)

Word	Endianness:
Big	(most	significant	first)

Modbus	start	register	(0..65535)
0

Modbus	register	quantity	(1..20)
1

Modbus	function	code	(3..4)
4

RS-485	master	general	configuration
RS-485	speed:
19200	bps

RS-485	data	format:
8N1

Measurement	rate:
1	s

Add	more

Finish

Figure 10.1: Generic Modbus RTU sensor configuration
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The maximum quantity of consecutive registers that can be read from each sensor is 20. It is necessary to specify
the first register (PDU addressing, first reference is 0) and the amount of registers. The function code is selectable
between ’03’ (read holding registers) and ’04’ (read input registers).

Read registers will be evaluated according to the selected data type. If a 32-bit data type is selected, each two
registers will be merged. For each registers pair (if 32-bit data type selected) or each individual register (if 16-bit
data type selected), an evaluation is generated. E.g. reading 10 registers on RS485 channel M1 will generate 10
evaluations if a 16-bit data type is selected (M1_1 to M1_10) and 5 evaluations if a 32-bit data type is selected (M1_1
to M1_5).

The resulting evaluations have no unit or evaluation type. You can create a new evaluation on top of each original
evaluation by means of the linear equation from the Evaluation Helper (see Section 5.3.1). Finally, it is necessary to
properly select the evaluations to be included in the CSV statistics files in the Data → Statistics (see Figure 6.4).

10.19 Multifunction Transducer, Power Meters and other Electrical
Measurement Devices

Meteo-40 can be used to connect power meters, multifunction transducers or other electrical measurement devices,
e.g., for power curve measurement. The devices are connected to the RS485 bus of Meteo-40.

Sensor type Model Protocol Description Channels and Evaluated
data

Sensor’s
previous
configura-

tion
needed

Power Meter
Sineax CAM
(see Sec-
tion 10.19.1)

Modbus

Actual values
(registers
40100,
40118 to
40122,
40134 to
40142)

Mx_1: Average phase
Voltage U,
Mx_2: Current I1,
Mx_3: Current I2,
Mx_4: Current I3,
Mx_5: Real Power P1,
Mx_6: Real Power P2,
Mx_7: Real Power P3,
Mx_8: Total Real Power P,
Mx_9: Total Reactive
Power Q

Serial
settings,
address

Power Meter

Iskra MT540
(see Iskra
manuals
download
(http:
//www.
iskrasistemi.
si/
download/
manuals/))

Modbus

Normalized
actual values
(registers
804, 809 to
811, 816 to
819, 823)

Mx_1: Average phase
Voltage U,
Mx_2: Current I1,
Mx_3: Current I2,
Mx_4: Current I3,
Mx_5: Real Power P1,
Mx_6: Real Power P2,
Mx_7: Real Power P3,
Mx_8: Total Real Power P,
Mx_9: Total Reactive
Power Q

Serial
settings,
address

Power Meter

GD2000
Multi-function
Power
Analyzer

Modbus
registers 56
to 63

Mx_1: Active power,
Mx_2: Power factor,
Mx_3: Reactive power,
Mx_4: Apparent power

Serial
settings
(19200 bps),
address

10.19.1 Sineax CAM Measuring Unit

Sineax CAM is a universal measuring unit for heavy current variables. Actual measurements for average phase volt-
age, current, real and reactive power are requested from this sensor. For more information refer to Gossen Metrawatt
Sineax CAM documentation (http://www.gossenmetrawatt.com/english/produkte/sineaxcam.htm#).
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10.20 Remote Sensing

10.20.1 ZephIR 300 Lidar

Meteo-40 can acquire ZephIR 300 averaged wind data registers and include them in the measurement CSV files or
share them over SCADA. You can select ZephIR 300 from the sensors list under ’Other Sensor’.

Before adding it to the list, the ZephIR 300 must be powered and connected to Meteo-40’s RS485-M port. The
configured heights will be automatically requested and for each height, a RS485 channel (M1 to M8) will be configured.

Note
For more information about how to electrically connect ZephIR 300 and Meteo-40 please contact us.

Important
Measurement polling interval is 1 minute per default. It must always be lower than the statistics time interval
(see Section 6.3) in order to ensure a valid measurement per interval.

Model Protocol Description Channels / Evaluated Data
Required
Configura-

tion

ZephIR 300 Modbus
Averaged
wind data per
height

Mx_1: Reference,
Mx_2: Wind Speed,
Mx_3: Vertical Wind Speed,
Mx_4: Wind Direction,
Mx_5: Temperature,
Mx_6: Air Pressure,
Mx_7: Humidity,
Mx_8: Wind Speed Max,
Mx_9: TI

Serial
settings,
address

Table 10.25: Requested values
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Chapter 11

Channels

In the previous chapter, various sensors have been described, which can be connected to Meteo-40. The sensors
have to be connected to the corresponding channel. Depending on the data logger type, Meteo-40 offers up to 35
channels. Meteo-40 provides connectors for the following measurands and signals:

• Analog Voltage (DC)
• Analog Current (DC)
• Pulse / Counter (Period)
• Digital / Serial / Status
• RS485 (master) to connect various types of sensors.

Furthermore, the data logger Meteo-40 provides up to two high precision Current Sources to supply passive sensors.

See also Section 1.3.

11.1 Connecting Sensors to Analog Voltage Channels

Meteo-40 is equipped with up to 12 differential voltage inputs, depending on the logger’s type. Generally, there are
two benefits from differential inputs:

1. Reduced impact of perturbances and interferences on the signal lines,

2. Helps to avoid ground loops.

You can find the analog voltage channels (Ax, Bx) on the lower left side of the measuring unit (see Section 1.2).
For example, analog wind vanes, barometric pressure sensors or pyranometers with analog voltage output can be
connected to analog voltage channels of Meteo-40.

The analog voltage ranges comprise the following voltage ranges:

• ±0.1V,
• ±1V,
• ±10V,
• 0.1V to 0.3V.

Note: The voltage range 0.1V to 0.3V is a high resolution range, especially designed tor use with passive Pt1000
temperature sensors in conjunction with the current sources of Meteo-40.

For further electrical details refer to Section 12.2.

Channel Meteo-40S Meteo-40M Meteo-40L
Analog Voltage Channels 4 8 12

Table 11.1: Analog Channels of Meteo-40
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11.2 Connecting Sensors to Counter Channels

The counter channels (C) are on the right side of the analog voltage channels (see Section 1.2). For example,
anemometers and precipitation sensors can be connected to counter channels. For electrical details refer to Sec-
tion 12.2.

With data loggers produced since 2017-06, one can use the counter channels C5, C6, C11, and C12 as period
measurement channels. This is useful for low frequency signals. The channel names are P1 to P4, respectively.

Channel Meteo-40S Meteo-40M Meteo-40L
Counter Channels 4 8 12
Period measurements 0 2 4

Table 11.2: Counter Channels of Meteo-40

11.3 Connecting Sensors to Digital Channels

To use digital serial wind vanes Meteo-40 comprises up to eight Digital Channels (D). These Digital Channels are
located in the middle of the connection panel of the data logger. For further electrical details refer to Section 12.2.

Channel Meteo-40S Meteo-40M Meteo-40L
Digital Channels 2 4 8

Table 11.3: Digital Channels of Meteo-40

11.3.1 Functionality Check of Clock Output

To set up a proper digital connection between the sensor and Meteo-40 it is sometimes necessary to verify the func-
tionality of the Digital Clock Output. The Digital Clock Output sends a short data sequence to the sensor, the sensor
should respond with a data sequence on the IN line of the serial interface.

To request data from the sensor the Digital Clock Output must provide voltage levels that can be detected (understood)
by the sensor. To simply test the functionality of the Digital Clock Output with a Multimeter Meteo-40 has implemented
a software driven test procedure. To perform the CLK-Line Output Test do the following:

• Disconnect the sensor from the data logger.
• Connect the data logger to the PC to configure it via web interface.
• Login into the data logger and follow the links Measurement→ Channels
• Press the button ”Digital test below the sensor list. ”
• A tabular showing the Digital Channels available on this logger occurs. The right columns of the table contains two

buttons: ”5V” and ”0V” corresponding to the each channel.
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(Digital Channels 1 ... 4)
voltage of CLK line
Toggle DC output

Header

Figure 11.1: Configuration Menue for CLK-Line Test in Meteo-40.

• Connect the multi meter between CLK output and GND of the Digital Channel you intend to check.
• First step: Press the button ”5V” to switch on the DC voltage of the Clock Output. There must be a voltage between

4V and 5.6V present at the Clock Output.
• Second Step: Add a resistor of 1kΩ ... 1.2kΩ in parallel to the multi meter (see figureFigure 11.2). Press the button

”5V” to switch on the DC voltage of the Clock Output. The voltage at the Clock Output must not drop below 3 volts.

Notes:

• The DC voltage output can be toggled between High- and Low-level via the two buttons ”5V” and ”0V”
• The test has limited timespan: After pressing the button ”Digital test” and choosing the the DC voltage level

the voltage level disappears after 10 seconds. To redo the test the button ”5V” has to be pressed again.

Test Result: If the voltage level drops below 3 volts the CLK output of the data logger seems to be defective.
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1kΩ ... 1.2kΩ

CLK

Data
-In

GND

PAS / E
art

h

Measure Voltage
Between CLK and GND

to sensor

Figure 11.2: Setup for CLK-Line test of Serial Interface.

11.4 Connecting Sensors to Analog Current Channles

Meteo-40 data loggers offer analog current measurement channels: Meteo-40L provides two channels; Meteo-40M
and Meteo-40S one each.

Barometric pressure sensors with current output can be connected to these channels. The current measurement
channels offer current ranges of 1mA, 10mA and 100mA which can be configured via web interface.
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Channel Meteo-40S Meteo-40M Meteo-40L
Analog Current Channels 1 1 2

Table 11.4: Analog Current Channels of Meteo-40

11.5 Connecting Sensors to Current Source

The current source (CS) is located on the left of the communication unit next to the analog current channels (see
Section 1.2). Meteo-40 data loggers are equipped with one or two current sources, depending on the logger’s type.
The goal of these current sources is to supply passive temperature sensors (PT100 or PT1000).

Single Pt100 and Pt1000 sensors as well as Pt100 sensors, which are for example implemented inside pyrheliometers
can be connected to the current source of Meteo-40. For electrical details refer to Section 12.2.

Channel Meteo-40S Meteo-40M Meteo-40L
Current Source Channels 1 1 2

Table 11.5: Current Source Channels of Meteo-40

Note
For technical details and electrical characteristics of sensors, refer to the data sheets, which can be down-
loaded from the Ammonit website (http://www.ammonit.com/).

11.6 Connecting Sensors to RS485 M

All data logger types of Meteo-40 offer an RS485M (master) slot for bus connection of up to eight sensors with RS485
interface. For further electrical details refer to Section 12.2.

When adding an RS485 sensor in the Measurement → Sensors menu, a (selectable) channel name between M1 and
M8 is assigned to the sensor. Subindexes, e.g., M1_1, M1_2, are created for measured data and evaluations. In
the Measurement → Evaluation menu the evaluations are displayed. Both measured values and evaluated data are
included in the CSV files and can be seen in the Data → Live menu.

Most RS485 sensors have to be configured before use. The same configuration must be applied, when adding the
sensors to Meteo-40 in the Measurement → Sensors menu.

Important
Only sensors using the same protocol and serial settings can share the RS485 bus. It is important to
configure each sensor with a unique RS485 address in the bus.

Important
If 4 or less RS485 sensors are connected, the RS485 M receiver remains enabled for 165 ms. With more
than 4 sensors, the receiver enabled time decreases to 40 ms. The sensor response delay and the response
transmission itself should happen within this period.

© 2011 — 2017 Ammonit Measurement GmbH 169

http://www.ammonit.com/


170 © 2011 — 2017 Ammonit Measurement GmbH



Data Logger Meteo-40 User’s Manual 171 / 234

Chapter 12

Technical Data

12.1 Specification

Property Specification
Housing Dimensions 260x194x50mm
Weight 950g
Protection IP65

Temperature -40 ... +65°C (operation)
-20 ... +65°C (display readable)

Memory
Meteo-40S: 1GB
Meteo-40M: 2GB
Meteo-40L: 2GB

Date Format YYYY-MM-DD
Time Format hh:mm:ss

Clock

Buffered real time clock
Accuracy: -40 ... +85°C (±3.5ppm);
0 ... +40°C (±2ppm)
3V Lithium Button Cell CR2032;
approx. 180 mAh; operating time >3 years

Power Supply No internal supply! (see Section 12.2.12)

Important
Meteo-40 has no internal supply battery! External power supply is essential for proper operation. Sec-
tion 12.2.12 contains the characteristics of the voltage supply and the current consumption of the data
logger.
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71
51

225±0.4

12
5±0

.4

4x threaded inserts for mounting
metric screw thread: M5
screw-in-depth: 10 mm

Figure 12.1: Mounting threads dimensions.

12.2 Electrical Characteristics

The values given in the following tables Table 12.1 to Table 12.12 contain the specifications of the digital and analog
inputs and outputs. The given values are specified for a temperature range of -40 ... +65°C.

Note
All inputs and outputs are protected against overvoltage and electrostatic discharge. All voltage outputs of
the data logger are fused by an self-resetting electronic fuse. Additionally, the power supply comprises an
inverse-polarity protection.
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12.2.1 Electrical Specifications of Analog Voltage Channels / Differential Inputs

Property Specification

Number of Channels per Data Logger Type
12 @ Meteo-40L (A1 ... A12)
8 @ Meteo-40M (A1 ... A8)
4 @ Meteo-40S (A1 ... A4)

Available Voltage Ranges (DC)

±0.1V
±1V
±10V
0.1V ... 0.3V

Internal Resolution (Bit)

15 bit (Range: ±0.1V)
16 bit (Range: ±1V)
16 bit (Range: ±10V)
16 bit (Range: 0.1V ... 0.3V)

Internal Resolution (Voltage)

6.1 µV (Range: ±0.1V)
30 µV (Range: ±1V)
300 µV (Range: ±10V)
3.1 µV (Range: 0.1V ... 0.3V)

Measurement Accuracy (Voltage)

≤ 50µV (Range: ±0.1V)
≤ 150µV (Range: ±1V)
≤ 1mV (Range: ±10V)
≤ 50µV (Range: 0.1V ... 0.3V)

Input Impedance 1 MΩ

Input Voltage
min. -12V
max. +12V

Maximum Measurement Frequency 8 Hz

Table 12.1: Electrical Specifications of Analog Voltage Channels / Differential Inputs

12.2.2 Electrical Specifications of Analog Current Channels / Differential Inputs

Property Specification

Number of Channels per Data Logger Type
2 @ Meteo-40L (AC1 ... AC2)
1 @ Meteo-40M (AC1)
1 @ Meteo-40S (AC1)

Available Current Ranges (DC)
±1mA
±10mA
±100mA

Measurement Accuracy (DC)
≤ 5µA (Range: ±1mA)
≤ 30µA (Range: ±10mA)
≤ 300µA (Range: ±100mA)

Resolution (Bits)
13 bit (Range: ±1mA)
15 bits (Range: ±10mA
15 bits (Range: ±10mA

Input Impedance (Shunt) 4.7 Ω
Maximum Input Current 150 mA
Maximum Input Voltage 0.75V
Maximum Measurement Frequency 8Hz

Table 12.2: Electrical Specifications of Analog Current Channels / Differential Inputs
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12.2.3 Electrical Specifications of Counter Channels / Non-Differential Inputs

Property Specification

Number of Channels per Data Logger Type
12 @ Meteo-40L (C1 ... C12)
8 @ Meteo-40M (C1 ... C8)
4 @ Meteo-40S (C1 ... C4)

Frequency Range (TTL-Level) 1Hz ... 25kHz
Frequency Resolution 1 0.1 Hz
Voltage Threshold (f > 1 Hz) 0.22V

Input Voltage
min. -12V
max. +12V

Period Measurement (Non-Differential Inputs) Channels P1 (C5), P2 (C6), P3 (C11), P4 (C12)

Table 12.3: Electrical Specifications of Counter Channels / Non-Differential Inputs

12.2.4 Electrical Specifications of Digital Channels (Serial Input / Output)

Property Specification

Number of Channels per Data Logger Type
8 @ Meteo-40L (D1 ... D8)
4 @ Meteo-40M (D1 ... D4)
2 @ Meteo-40S (D1 ... D2)

Input Voltage Range (High State) 2V ... 25V
Input Voltage Range (Low State) -0.5V ... 0.6V
Input Resistance ≥ 10 kΩ

Table 12.4: Electrical Specifications of Digital Channels (Serial Input / Output)

12.2.5 Electrical Specifications for Digital Clock Output

Property Specification

Number of Channels per Data Logger Type
8 @ Meteo-40L (D1 ... D8)
4 @ Meteo-40M (D1 ... D4)
2 @ Meteo-40S (D1 ... D2)

High State 5V
Low State 0V
Output Resistance 100 Ω
Minimal Load Resistance 500 Ω

Table 12.5: Electrical Specifications for Digital Clock Output

1 The frequency resolution depends on the period time setting. Longer period time setting results in higher resolution.
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12.2.6 Electrical Specifications for Analog Current Source

Property Specification

Number of Channels per Data Logger Type
2 @ Meteo-40L (CS1 ... CS8)
1 @ Meteo-40M (CS1)
1 @ Meteo-40S (CS1)

Nominal Current 200 µA
Tolerances < 0.5 %

Table 12.6: Electrical Specifications for Anlog Current Source

12.2.7 Electrical Specifications for Switches

Property Specification

Number of Channels per Data Logger Type
8 @ Meteo-40L (S1 ... S8)
4 @ Meteo-40M (S1 ... S4)
2 @ Meteo-40S (S1 ... S2)

Switch Voltage Range 5V ... 28V
Max. Current Continuous Switch 120 mA
Peak Switch Current (2 s) 400 mA
Switch On Resistance < 350 mΩ
Switch Off Resistance > 10 MΩ

Table 12.7: Electrical Specifications for Switches

Important
The switches section of the Meteo-40 comprises 5V outputs to supply periferical devices inside the steel
cabinet of the measurement setup. The 5V supply is not intended to supply sensors connected with long
cables due to the risk of damage caused by lightning strike.
The 5V outputs provide an electronic current limiter and an overvoltage protection.

12.2.8 Electrical Specifications of the 5V Output

Property Specification
Max. output voltage 5.5 V
Min. output voltage 4.7 V
Max. output current per output terminal 15 mA

Table 12.8: Electrical Specification of the 5V Output

12.2.9 Electrical Specifications of the RS485 Interface

Property Specification
Supply Voltage RS485 A, B 5V
Termination Resistor (Bus Termination) 120 Ω
Maximal Transmission Rate 1 MB/s

Table 12.9: Electrical Specification of the RS485 Interface
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Note
Biasing of RS485 interface via external module M83550.

12.2.10 Electrical Specification of the Ethernet Interface

Important
The Ethernet interface is only available on Meteo-40 Revision D.

Property Specification
Ethernet port (Meteo-40 Revision D) 100Mbit/s (100BASE-TX)

Table 12.10: Electrical Specification of the Ethernet Interface

12.2.11 Electrical Specification of the RS232 Interface

Important
The RS232 interface is only available on Meteo-40 Revision C. The production of Meteo-40 Revision C
stopped in October 2012.

Property Specification

Serial interface port (Meteo-40 Revision C)
Male 9-pin RS232 connector for connection to
serial modem

Maximal Baudrate 115200 Baud

Table 12.11: Electrical Specification of the RS232 Interface

12.2.12 Electrical Specification of the Power Supply

Important
Meteo-40 has no internal supply battery! External power supply is essential for proper operation.
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Power Supply Property Specification
Supply Voltage Input (with
Reverse Voltage Protection)

Supply Voltage Range 9V (DC) ... 36V (DC)
Peak Supply Voltage (10 s) 55V (DC)

Current Consumption

Average Current Consumption
@ 12V (DC) during
measurement

≤ 30 mA (P < 360 mW)

Average Current Consumption
@ 12V (DC) during
communication

≤ 70 mA (P ≤ 840 mW)
for Meteo-40 Revision D
≤ 60 mA (P < 720 mW)
for Meteo-40 Revision C

Average Current Consumption
@ 12V (DC) with display
illumination

175 mA (P ≤ 2.1 W)
for Meteo-40 Revision D
< 500 mA (P < 6 W)
for Meteo-40 Revision C

Table 12.12: Electrical Specification of the Power Supply
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Chapter 13

Electrical Connection Plans

The following connection plans explain how Meteo-40 is connected with power supply, sensors and other periphery.

Note
Since Meteo-40 is designed to be very flexible, various sensors can be connected to the data logger. If the
sensor, you want to connect, is not listed in this manual, refer for technical details and connection plans
shown on the data sheets on our website (www.ammonit.com (http://www.ammonit.com)) or contact
our sales team (+49-30-6003188-0 or sales@ammonit.com).

Figure 13.1: Meteo-40 Supply incl. Modem
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Figure 13.2: Electrical Connection Plan: Analog Voltage (Pyranometer)

Floating voltage source (pyranometer) is connected via terminal or OVP to the differential analog voltage channels.
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Figure 13.3: Electrical Connection Plan: Analog Voltage (Temperature / Barometric Pressure Sensor)

The temperature and/or barometric pressure sensor is connected via terminal or OVP to the differential analog voltage
channels. To avoid ground loops, it is not recommended connecting the B terminal of the analog voltage input directly
to common ground.
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Figure 13.4: Electrical Connection Plan: Analog Voltage (Temperature + Humidity Sensor)

Voltage sources (temperature and humidity sensor) are connected via terminal or OVP to the differential analog voltage
channels. To avoid ground loops, it is not recommended connecting the B terminal of the analog voltage input directly
to common ground.
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Figure 13.5: Electrical Connection Plan: Analog Voltage / Current Source (4-wire-connection; Pt1000)

Analog Current Source (CS) of Meteo-40 is applied to feed a Pt100/Pt1000 temperature sensor. The sensor is con-
nected via terminal or OVP to the differential analog voltage channel. 4-wire measurement is recommended to avoid
voltage errors due to the resistance of feed line.
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Figure 13.6: Electrical Connection Plan: Analog Voltage / Current Source (4-wire-connection; Pt1000 +
Humidity)

Analog Current Source (CS) of Meteo-40 supplies the Pt100/Pt1000 temperature sensor. The active humidity sensor
may be fed by the same supply as the data logger. Both sensor outputs are connected via terminal or OVP to individual
differential analog voltage channels.
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Figure 13.7: Electrical Connection Plan: Analog Voltage (Potentiometric Wind Vane)

The figure above shows the 5-wire connection of a potentiometric wind vane. The intention of this configuration is to
avoid voltage drops on the measurement lines caused by wire resistance. The first analog voltage channel measures
the voltage across the whole potentiometer while the second channel measures the voltage between wiper and ground.
The configuration is supplied via current limiting resistor by a 5V supply. All lines to the wind vane are connected via
terminal or OVP.
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Figure 13.8: Electrical Connection Plan: Analog Voltage with Voltage Divider (2xR)

The Meteo-40 data logger is designed to measure analog DC voltages from -10V ... 10V. This is sufficient for most
meteorological sensors. If voltages higher than +10V occur, the voltage at the analog voltage inputs must be shared
by a voltage divider. Note that R2 is in parallel to the input impedance of the analog voltage channel (1MΩ).
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Figure 13.9: Electrical Connection Plan: Analog Current (2-wire-connection), active

Meteo-40 comprises analog current measurement inputs (AC) to measure DC currents up to 100mA. Many meteoro-
logical sensors provide analog current outputs with 0...20mA or 4...20mA. The positive signal line has to be connected
to the A input. The negative line (or signal ground) has to be connected to the B input of the analog current input. The
figure above depicts the recommended setup using connections via terminal or OVP to the data logger.
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Figure 13.10: Electrical Connection Plan: Analog Voltage with Shunt

Max. voltage between sensor and data logger 70 V DC!!!

The Meteo-40 data logger can measure DC currents up to 100mA on its analog current inputs. This is sufficient for
most meteorological sensors. If currents higher than 100mA are to be measured, a shunt can be used in conjunction
with the analog voltage inputs.
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Figure 13.11: Electrical Connection Plan: Pulse Counter (Anemometer)

Meteo-40 comprises several impulse counter inputs (CNT). In most cases they are used for anemometer setup. The
signal output of the sensor has to be connected to the CNT input of the data logger. In most cases the common
ground is used for the negative line of counter connection. The figure above depicts the recommended setup using
connections via terminal or OVP to the data logger.
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Figure 13.12: Electrical Connection Plan: Pulse Counter with Pull-up Module for Precipitation Measure-
ment

The counter inputs of the Meteo-40 data logger can be used for precipitation sensors. Most precipitation sensors
comprise open collector outputs or use a switching reed contact. In both cases an additional pull-up resistor has to
be applied. This pull-up resistor is tied to a 5V supply to feed the sensor’s output. The module M83510 by Ammonit
comprises a pull-up resistor and a 5V supply and can easily be integrated in the setup of a steel cabinet. The figure
above shows the recommended setup using connections via terminal or OVP to the data logger.
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Figure 13.13: Electrical Connection Plan: Digital Serial for Serial Wind Vane (Thies TMR)

The Digital Serial inputs of Meteo-40 data loggers are designed to connect sensors using serial communication. The
data logger sends a clock burst to the sensor via the CLK line. The response of the sensor is sent back to the data
input line (IN) of the Digital Serial panel. It is essential that sensor and data logger use the same common ground.
The figure above shows the recommended setup using connections via terminal or OVP to the data logger.
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Figure 13.14: Electrical Connection Plan: Status with Pull-down Module

In some cases an additional pull-down resistor may be required to equalise the electrical potential on the status signal
lines. This may be necessary to reduce perturbance caused by floating lines. The potential equalization can be
realized by an external resistor to GND or an external module provided by Ammonit. This external module comprises
several pull down resistors for several signal lines.
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Figure 13.15: Electrical Connection Plan: Status for Obstacle Light

Many obstacle lights provide a diagnosis port to indicate malfunction. This diagnosis port can be connected to the IN
port of the Serial Digital panel. For a detailed description of the electrical characteristics of the interfaces see table in
Section 12.2.4. The figure above shows the recommended setup using connections via terminal or OVP to the data
logger.
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Figure 13.16: Electrical Connection Plan: RS485 with RS485 Module

If RS485 communication is used an additional biasing may be required. This is done with the configuration shown
above. Ammonit provides a special RS485 module for biasing purposes. The RS485 module contains an internal
voltage supply providing 5V for biasing the RS485 bus lines.
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Figure 13.17: Electrical Connection Plan: Switch external Sensor Heating via Meteo-40 Switch Manager

The configuration above displays the connection of an external sensor heating switched by the Meteo-40 heating
control.
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Chapter 14

Cryptographic Software

Ammonit implemented certain standard cryptographic software to protect sensitive measurement data. None of the
algorithms are developed by Ammonit. All cryptographic software used on Meteo-40 is free software. Its source code
is available for everybody to study and check for security problems.

Currently the following is encrypted:

• Access to Meteo-40 via web interface over HTTPS with high-grade encryption (AES-256, 256 bit keys)
• All data sent and received via the Meteo-40 web interface, e.g., data download
• Data upload via SCP (RSA 2048 bit) to AmmonitOR or your own server
• Emails and attached CSV files sent by Meteo-40 (optional)

Note
There is no encryption, when data is uploaded via FTP to a server. Moreover, the data stored on Meteo-40
is not encrypted. But only computer specialists with inside knowledge could be able to access the data.

Software or Protocol Description Supported Algorithms

HTTPS

All access to the user interface
of the data logger is done via
HTTPS, a combination of
HTTP with SSL/TLS, as
implemented in OpenSSL.

AES, Blowfish, Camellia,
SEED, CAST-128, DES, IDEA,
RC2, RC4, RC5, Triple DES,
GOST 28147-89, MD5, MD2,
SHA-1, SHA-2, RIPEMD-160,
MDC-2, GOST R 34.11-94,
RSA, DSA, Diffie–Hellman key
exchange, Elliptic curve,
GOST R 34.10-2001

SSH

The connection to the Ammonit
tunnel server (or any tunnel
server of your choice) is
performed with an SSH
reverse tunnel.

3DES, Blowfish, CAST128,
Arcfour, AES, RSA

GnuPG
GnuPG is used to digitally sign
and encrypt measurement
data.

CAST5, Camellia, Triple DES,
AES, Blowfish, Twofish,
ElGamal, RSA RIPEMD-160,
MD5, SHA-1, SHA-2, Tiger,
DSA, RSA

Table 14.1: Cryptographic Software
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Chapter 15

Maintenance and Care

In order to ensure that Meteo-40 data loggers work properly, it is important that you maintain and handle the device
with care.

Important
If an error occurs and the Ammonit support team needs to be contacted, download the configuration file (con
fig-Dnnnnnn.txt in menu System → Information) and send it with the error description to the Ammonit
Support support@ammonit.com.

15.1 Operation and Storage

The data logger can be affected by extreme temperature and humidity conditions. Meteo-40 is designed to operate
properly at temperatures between -40 ... +65°C in non-condensing environments. The display is readable between
-20 ... +70°C.

On site the data logger has to be installed in a robust and weatherproof cabinet (see also at www.ammonit.com
(http://www.ammonit.com/)). The cabinet protects the data logger against weather and condenzation damage,
theft and vandalism. If humidity tolerance is exceeded and moisture penetrates, the electronics of Meteo-40 can be
damaged. Users are responsible for effective humidity control.

Handle Meteo-40 with care, do not drop it, and avoid mechanical shocks and vibrations to prevent the electronics from
being damaged. Do not open or break the Meteo-40 housing or any of the slots. Avoid permanent pressure on the
data logger.

To ensure that Meteo-40 operates properly, install only equipment, e.g., sensors, adapters and cables, which is un-
damaged and approved by Ammonit. Contact Ammonit, if any questions occur.

15.2 Overvoltage / Lightning Protection

Ammonit offers lightning and overvoltage protection devices for DC and AC low-voltage supplies of components and
measuring systems, ensuring protection of data and signal lines and power cables. The surge protection cable clamp
is installed in the steel cabinet instead of a regular unprotected cable clamp. We offer several types of surge protection
devices, differing in number of pins and voltage levels. Although the installation of overvoltage protection devices is not
mandatory, we highly recommend installing them, as unprotected lightning can lead to a total breakdown of the entire
measuring system. Overvoltage protection is strongly advised at freestanding measuring stations or when aircraft
obstacle lights are applied.
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Chapter 16

Frequently Asked Questions

Find in this chapter a summary of frequently asked questions.

If you do not find the answer to your specific question in this chapter, contact the Ammonit support team.

16.1 Local Communication

Question Answer

The Meteo-40 display does not
show anything.

The display is switched off. Press the middle button of your data logger
and hold it until the display turns on. The display of Meteo-40 is only
illuminated, when CECS is running. During MARS operation, the
display is switched of. Refer to Chapter 9.
The ambient temperature is below -20°C. The crystals of the LCD got
stuck.

I cannot configure Meteo-40 using
the buttons.

You do not have permission to configure the data logger with the
buttons on the Meteo-40 housing. See Section 9.1.

The red LED light is turned on.
What does it indicate?

It indicates that an error in the measuring operation occured. For
details see System → Logbook in the web interface or System
→ Errors → Error List in the display menu.

The yellow LED light blinks. What
does it indicate?

It indicates that at least one RS485 sensor is connected. According to
the Modbus protocol, the yellow LED light blinks, when a measurement
is taken.

I do not have an USB Ethernet
adapter available. How can I
connect Meteo-40 Revision C to
the LAN?

As Meteo-40 Revision C has no Ethernet port, an USB Ethernet adapter
is required. Use the USB Ethernet adapter included in the delivery.
Meteo-40 Revision D data loggers are equipped with Ethernet port and
can be connected directly to the LAN - without any accessories.

Meteo-40 is connected to the LAN.
After entering the IP address of
Meteo-40 in my browser, I receive
an error message.

Check the three following possibilities:

• Meteo-40 is switched off. The web interface can only be accessed,
when Meteo-40 is switched on, rep. the CECS has to be on. See
Section 1.4.

• Make sure, Meteo-40 and your PC are within the same LAN.
• A static IP address is configured, which does not exist in your current

LAN. If you have the permission, you can activate DHCP in the
display of Meteo-40. Go to the Communication → Devices → LAN
→ eth menu and set Use DHCP toYes (see Section 9.1. Or connect
the data logger via USB and change the LAN settings. See
Section 7.7.

Meteo-40 is connected via USB to a
Windows PC and is not recognized.

Download and install the required driver file. See Section 2.5.

Which cable I have to use to
connect Meteo-40 to my PC?

Use a standards USB-A+B cable, the same cable used to connect
printers or other devices.
Note that you might require a driver file for Meteo-40 (see above).
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16.2 Remote Communication

16.2.1 Modem

Question Answer

After configuring and connecting
the Sierra Wireless FXT009
modem, the connection cannot be
established.

• Make sure the SIM card is not broken. The SIM card should be
inserted properly and the SIM card slot of the modem has to be
locked (see Section 7.9.6.1).

• Check the power supply of the modem. A small red light indicates
that the modem is running.

• Make sure that you configured the SIM card’s provider details in the
provider settings. Use the Provider helper (see Section 7.9.1), if you
are unsure. If your provider is not given in the list, ask your provider
for the details, i.e., APN, username and password.
We recommend doublechecking the provider details.

• Make sure that the used SIM card has not been locked by entering a
wrong PIN code. You can create a new PIN code via the Meteo-40
web interface; the PUK code is required.

• Make sure that you use a SIM card / rate, which supports mobile
Internet.

An Internet connection is always
established, when I switch on the
CECS of Meteo-40. The modem
should only be online, when data
has to be sent.

Deselect the checkbox Modem online, when CECS is on in the
Communication → Modem menu. Thus the modem only establishes an
online connection, when an action (e.g., upload data, email data or
online availability) is scheduled.

I cannot connect to the data logger
via modem?

• Make sure the modem is switched on and running to perform the
scheduled actions. Did you configure a switch to toggle the modem?
If the modem is connected via relay to the data logger, a switch has
to be configured in the Communication → Modem menu of the data
logger. In Meteo-40 firmware version 1.0 Rev. 13915 and higher S1
is set by default in the modem configuration.
It is not sufficient to toggle the switch manually, as it is not saved to
the data logger configuration. After rebooting the data logger or after
power supply interruptions, the modem will not start again. It remains
switched off. See also Section 7.9.

• If the modem is configured properly and you do not receive any
measurement data, it could be a problem with the modem. Are the
frequency bands configured correctly? Refer to Section 7.9.6.1.
We also recommend upgrading the data logger firmware regularly as
we contineously improve the software.

• If you receive measurement data, the signal might be too weak to set
up the Internet connection to access the data logger. In this case
refer to Section 16.2.2.

Tip
We recommend testing the modem functions before installa-
tion in the field, i.e., sending emails, uploading files and ac-
cessing the web interface via modem connection.
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Question Answer

How do I connect a BGAN satellite
modem?

BGAN satellite modems are connected via Ethernet cable to Meteo-40.
If you are working with Meteo-40 Revision C with RS232 slot, you need
an USB Ethernet adapter to connect the modem.
In order to supply the satellite modem, a LAN switch has to be assigned
in the Communication → LAN menu. Make sure that the checkbox LAN
online, whenever CECS is on is not selected. Hence, the modem goes
online only when needed. The modem itself has to be configured using
the software provided by its manufacturer. For further details refer to
Section 7.9.7 and especially to Section 7.9.7.3.

16.2.2 Ammonit Tunnel

Question Answer

After entering the URL of the tunnel
connection, a message is displayed
which indicates that the tunnel is
not responding.

• Your data logger is (currently) not connected to the Internet. The data
logger has not been configured to be online for this time. Meteo-40
establishes an Internet connection for the periods configured in the
schedule (see Section 7.2).

Tip
If you use AmmonitOR to monitor your data logger, you can
check, when the data logger is scheduled to be online.

• The data logger is busy, e.g., performing an upgrade, uploading files.
Try to access the tunnel connection a few minutes later.

• Another user is logged in and is downloading data files. Try to access
the tunnel connection a few minutes later.

The entered URL seems to be
wrong.

Make sure that the URL has the form https://Dnnnnnn.tunnel.
ammonit.com/, where Dnnnnnn must be replaced with the serial
number of the data logger without spaces or hyphens.
If a tunnel affix has been entered in the Meteo-40 web interface
(Meteo-40 firmware version older than 1.0 Rev. 13645), enter the URL
of the data logger without tunnel affix:
https://Dnnnn.tunnel.ammonit.com (Dnnnnnn represents the serial
number of the data logger). The tunnel affix has to be entered for the
tunnel access code. If you lost your tunnel affix or tunnel access code,
call the Ammonit support team.
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Question Answer

The data logger is sending /
uploading data, but I cannot
connect to the data logger via
tunnel.

The tunnel connection seems to be not stable enough. The issue can
be solved as follows:

• The GPRS connection might be very weak. Switch to GSM. Ask your
provider for the dial-in number (P-to-P). The dial-in Number has to be
configured in the Meteo-40 web interface in the Communication
→ Modem menu. An APN does not have to be entered. See also
Section 7.9.

• The signal might be very weak. Replace the installed antenna with a
Yagi directional antenna. The Yagi antenna can be aligned to a near
transmitting station to receive a better signal. For further details see
Wikipedia
(http://en.wikipedia.org/wiki/Yagi-Uda_antenna).

• Instead of using a standard SIM card with dynamic IP address, insert
a SIM card with public IP address into the modem. The data logger
can be accessed via its public IP address and/or via the domain
provided by the tunnel server, if configured. See also Section 7.3.
If your data logger is registered in AmmonitOR, you can find its public
IP address in the Data Loggers → Connections menu. Go with the
mouse pointer on a displayed connection in the graphic view or look
up the IP address in the text view.

16.3 Firmware Upgrade

Question Answer

Do I have to be on site to perform
an upgrade?

No, you can start the upgrade via remote access (tunnel connection),
e.g., when the data logger is scheduled to be online.
Nevertheless we recommend upgrading the data logger in the office to
avoid any unexpected difficulties.

My data logger is not connected to
the Internet; how can I perform an
upgrade?

In order to perform an upgrade, the data logger has to be connected to
the Internet.
By connecting your smartphone to the data logger, you can set up an
Internet connection via the tethering function of the smartphone.
Connect your smartphone to your Meteo-40 data logger via USB
(USB-A slot of the data logger and micro USB slot of the smartphone).
Open the settings for Tethering and portable hotspot of the smartphone
operating system (see Figure 4.14). Activate USB tethering.
Browse for the IP address of your Meteo-40 data logger using the keys
(Communication → Devices → LAN → USB (Activated) → IP settings).
Enter the data logger’s IP address in your smartphone browser, login
and perform the upgrade.

Do I have to install all upgrades?

We recommend installing all available upgrades to benefit from new
features and to fix recent problems.
Ammonit regularly informs Meteo-40 users about available upgrades by
email.

During the download process the
connection was interrupted? Do I
have to restart the download
process?

The downloaded software packages are stored on the data logger.
Start the upgrade process again to continue the download and
installation process. Once downloaded packages do not have to be
downloaded again.

How does the installation process
affect the recording of the MARS?

If the MARS is not affected by the upgrade, the recording continues
without any interruption.
If the MARS will be upgraded, the recording stops for approx. 30s and
continues afterwards.

16.4 Data: Transfer and Download
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Question Answer

Which methods are available to
transfer data files?

• Upload data files via SCP/FTP connection to a server of your choice
or the AmmonitOR installation on your server (see Section 7.6).

• Upload data files to your AmmonitOR account on the Ammonit server
(AmmonitOR project key is required, see Section 7.6).

• Sent data files to an email account (see Section 7.5).
• Manual download of CSV files via the Meteo-40 web interface.
• Manual download of CSV files on pre-configured USB flash drive on

site (see Section 4.4.3).

If no Internet connection is available
on site, can I download data files?

Yes, you can download the statistics and/or the source data using a
pre-configured USB flash drive. Switch on the data logger (CECS) and
plug in the prepared USB flash drive. All generated CSV files will
automatically be saved on the USB flash drive. See also Section 4.2.
You can also connect to the data logger via USB or W-LAN on site and
download the CSV files on your PC.

What happens to data files, which
could not be sent / uploaded
according to the schedule time,
e.g., because of connection
problems?

Files, which have not been sent according to the scheduled time, will be
sent or uploaded at the next scheduled action.

I receive data files with the file type
csv.gz? How do I handle these
files?

The file is compressed using GNU gzip (See Section 6.6) and has to be
decompressed before you can use it. If you work with Microsoft
Excel™, open the file as decribed in Section 6.6.3. If you work with
LibreOffice or OpenOffice, use the settings decribed in Section 6.6.2.

How can I open CSV files
generated by Meteo-40 with
Microsoft Excel?

In order to open CSV files with Microsoft Excel, the settings have to be
adapted. Launch Microsoft Excel and open the Options in menu File.
Under Advanced the decimal and thousands separators are defined.
Adapt the settings for Meteo-40 CSV files as follows, if necessary.
Decimal separator has to be a dot (.); thousands separator has to be a
comma (,). If necessary, deselect the function Use system separators.
CSV files generated by Meteo-40 data loggers use the comma (,) as
field separator, double quote (”) for embedding commas in textual
strings and UTF-8 as character set. These details have to be
considered, when data files are imported. In order to import CSV files,
click on From Text on the Data tab and browse for the CSV file. Follow
the instructions of the import wizard.
For further details refer to Section 6.6.3.

I have an AmmonitOR installation
on my own server. How can I
upload the data files to it?

Select in the Communication → AmmonitOR menu of your Meteo-40
data logger for AmmonitOR server the value Custom AmmonitOR and
below under server the name or IP address of your server.

16.5 Sensor: Configuration and Connection

16.5.1 Sensor Configuration
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Question Answer

The sensor, which I have to install,
is not given in the sensor list. How
do I configure the sensor?

If the sensor is not given in the list, you can select Other Sensor in the
Sensor Helper and configure channels, slope and offset values,
measurement rate etc. manually.
If the anemometer you want to install is not listed in the Sensor Helper,
select Anemometer for the sensor type and Generic Anemometer for
the sensor. The other values have to be configured manually.
If the analog wind vane you want to install is not listed in the Sensor
Helper, select Wind Vane for the sensor type and Generic Analog Wind
Vane for the sensor. The other values have to be configured manually.

Important
Only for the sensors listed in the Sensor Helper, Ammonit as-
sures the correct calculation of the statistics!

If you are unsure how to configure an unlisted sensor, contact the
Ammonit support team.

I have a calibrated sensor. Where
do I enter the calibration values?

For each configured sensor you can modify the slope and offset values
in the Sensor Helper.

My configured pyranometer SPN1
does not display any estimated
value?

In order to estimate DNI and sun status, you have to enter the
geographic coordinates of the measurement station, i.e., latitude and
longitude. Both coordinates are important to get the zenith angle of the
sun at the site. Enter latitude and longitude in the System
→ Administration menu of your Meteo-40 data logger.

16.5.2 Sensor Connection

Question Answer

Where can I find a plan to connect
a sensor?

• If you ordered the measurement system including steel cabinet and
cables from Ammonit, connection plans can be found in the steel
cabinet. Additionally, the sensor connection with Ammonit cables is
described in the data sheet, which you received for each sensor
bought from Ammonit.

• If you ordered only the sensors without cables from Ammonit, refer to
the data sheet by the sensor’s manufacturer. In Chapter 13 you can
find the electrical connection plans for Meteo-40.

I have to install two potentiometric
wind vanes, a barometric pressure
sensor and a temperature humidity
sensor - all connected to analog
voltage channels. Which data
logger model is suitable?

The Meteo-40M model offers 8 analog voltage channels to connect two
potentiometric wind vanes, a barometric pressure sensor and a
temperature humidity sensor.
If digital wind vanes TMR would be installed, which require only one
digital channel each, the Meteo-40S model would be suitable, as well.

Note
Digital wind vanes TMR are more precise than potentiometric
wind vanes. Additionally, digital wind vanes TMR are sub-
ject to less mechanical wear than potentiometer wind vanes
thanks to their solid state design. Wind vanes TMR do not
have moving parts, except the bearings. Thus digital wind
vanes TMR are more reliable and less susceptible to failure.

16.6 Measurement
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Question Answer

Sensors are configured and
connected, but the measurement is
not recorded?

Check the following options:

• It seems that the power supply during measurement was not
sufficient or has stopped. Thus MARS is turned off. Connect
Meteo-40 to a reliable power supply to operate MARS on.

• In the status box Recording is swiched off. Click Switch on in the
Meteo-40 web interface.

• The configuration has not been saved after the last modification.
Save the configuration and click Switch on for recording.

Where can I find the meteorological
data in m/s or °C?

The current value of each evaluation is displayed in the Measurement
→ Evaluation menu in the Meteo-40 web interface. Additionally, you
can display live data in the Data → Live menu of the data logger.
In the CSV files you can find the evaluated meteorological data
according the the settings you made in the Data → Statistics menu.
Furthermore, if you work with AmmonitOR, you can monitor the
meteorological data in your AmmonitOR project, e.g., in various plots
for selectable periods.

Where can I find the original
electrical measurement data?

The current electrical value of each channel is displayed in the
Measurement → Channels menu of the Meteo-40 web interface.
Additionally, you can see the electrical values of all channels in the
Data → Source menu.
In the source file, which can be downloaded in the Data → Statistics
menu of the data logger, you can see all electrical values of all channels
for a selected period.

16.7 Errors and Messages

Question Answer

After saving a configuration or
starting an action, an Internal error
occured and is displayed in the web
interface?

Internal errors could have various reasons. Not always a serious error
occured, e.g., due to a short connection time out, an operation could
have been interrupted. Try the following actions to solve the problem:

• Go to another page and perform the action again.
• Restart the data logger and perform the action again.

The red LED light is turned on.
What does it indicate?

It indicates that an error in the measuring operation occured. For
details see System → Logbook in the web interface or System
→ Errors → Error List in the display menu.

Important
If you should notice any error on your data logger or in the web interface, we kindly ask you to inform us as
soon as possible. The Meteo-40 data logger is a very complex system, so unfortunately it can happen that
errors occur. In order to avoid any disruption of the data logger operation, we need on your assistance.
In case of an error, please note down what have been done on the data logger before the error occured,
which system components are used, e.g., GSM modem or satellite modem, and which system configuration
is active.
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Release Notes

1.7.6 (2017-07-25)

• New Reflectometer CS650 over SDI-12
• New Wind Direction Potentiometric formula in Evaluation Helper
• Fix delete evaluations from evaluation helper
• Fix compressed files download as Viewer
• Selection of individual files for redundant send/copy possible with ’Mark as not sent’
• Fix invalidate CSV files
• Replace ”formula_params” with ”params” key in CSV files footer
• Fix data logger name encoding error in SCP
• Allow fine-grained sending of CSV files

Warning
If you already have secondary and/or tertiary CSV files configured, you must explicitely switch on sending
to AmmonitOR, by email, or to a file server now!

• Additional RS485 master speed: 1200 bps
• Sign all data by default
• Support signing and encryption of log and config files for server copy and USB flash drive copy
• The comma (”,”) is not allowed in the data logger name anymore
• Fix ZephIR evaluations for more than one height
• Effectively turn USB modem switch off, even if no USB modem is connected
• Set switch state over display is per default available
• Manufacturer administration can be manually started over UI
• Newly produced data loggers have individual UI certificates

1.7.4, 1.7.5 (2017-06-12)

• Fix possible LCD freeze after reboot

1.7.3 (2017-06-09)

• Fix LCD backlight switching

1.7.2 (2017-06-07)

• Fix data logger name encoding error in snapshots and test email
• New ZephIR Live data
• New Gill Wind Master M3
• Fix evaluation type for Gantner modules
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1.7.1 (2017-05-15)

• Fix active channels when adding evaluation with evaluation helper

1.7 (2017-05-12)

• Support secondary and tertiary CSV statistics files
• New data types with 8-bit exponent selectable for modbus sensors
• New Atonometrics RDE300
• Evaluation type and unit can be configured for all sensors of type ’Other Sensor’
• Enhanced performance for SCADA stored data request
• Fix evaluations using GPS location
• Provide default WLAN passphrase for newly produced data loggers
• Fix wrong time-stamp in CSV files if summary statistic configured
• New formulas in Evaluation Helper
• Fix live data evaluation for Thies Clima sensor
• New Gill Wind Master 3D Ultrasonic XYZ coordinates
• Support period measurement on counter channels C5, C6, C11, and C12 for newly produced Meteo-40, available

as P1, P2, P3, and P4
• Fix switches state shown in display

1.6.3 (2017-02-28)

• Fix ultrasonic sensors wind speed linear formula

Warning
In case you are using ultrasonic sensors and version 1.6.2, you must delete and regenerate all files
generated with this version!

• Fix SCADA stored data request

1.6.2 (2017-02-14)

• Allow deletion of multiple selected statistics files
• Fix a problem with source data memory overuse if a switch is associated to a sensor
• Fix missing latitude and longitude in CSV and admin page when using GPS
• Add date and time of last GPS fix in CSV statistics file as gps_fix
• Use function code 4 for Iskra MT540 input registers
• Fix SCADA Modbus write to holding registers selection
• Switch manager supports inverted logic
• Increased robustness for RS485 Thies communication
• RS485 serial console representation enhancements
• New Thies 3D Ultrasonic XYZ coordinates

1.6.1 (2016-12-20)

• New RS485 Master serial console
• New RS485 sensor SMP10 pyranometer
• Record status byte for Thies Ultrasonic 2D and 3D

210 © 2011 — 2017 Ammonit Measurement GmbH



Data Logger Meteo-40 User’s Manual 211 / 234

• Fixed send statistics CSV per email if Gust data active
• Include SCADA status in Information site
• New set one switch over SCADA using Modbus write single coil
• Fixed set switches OFF over SCADA
• Fixed request stored data over SCADA
• Fixed sending of snapshot data to AmmonitOR, broken in 1.6
• Fixed unexpected tunnel connection if SMS active
• Fix tunnel connection fails on action execution if another action running
• New solar zenith angle in evaluation helper
• Allow Mosbus RTU broadcast address ’0’ for sensors
• Slope for ultrasonic sensors wind direction available
• Fix SiS-13TC-T sensor irradiance not available
• Default connection (Ethernet/Modem) is shown in capital letters (uppercase)
• Add support for Met One 014mini anemometer

1.6 (2016-11-14)

• Optionally create gust data files
• Include internal voltage and temperature in Switch Manager lists
• Add data snapshot to email and server copy
• Add slope and offset for 3D ultrasonic sensors vertical wind speed
• Update provider helper with current mobile providers and APNs
• Fix custom evaluations: allow any input evaluation and not only evaluations of type ”other”
• Data logger is prepared for later upgrades via USB flash memory
• Fix easy cleanup for SCADA registers tables
• Increase backlight time for Meteo-40 Revision D from 5 s to 15 s, and allow Admin to deactivate display backlight
• Custom evaluations are ordered in CSV between regular evaluations and channels
• Optionally copy camera image to a USB flash drive when sending
• Allow Admin and User to view and download data logger files on USB flash drive
• Use hPa instead of mbar for newly configured pressure sensors
• Fix SCADA stored data request timestamp: use unix time and not logger local time
• New summary statistics available over SCADA
• New set switches state over SCADA
• Allow users starting actions via display (requires setting the permission first)
• New covariance evaluation
• New generic thermo-hygro 5V -20..80°C / 10V
• Maximum and minimum statistics available for internal temperature
• Statistics for internal channels can be selected
• New sensor MESA WSWD Sonic
• Add source data download of complete week
• Add function to invalidate all statistics CSV files, that have been sent before
• Write in SCADA server holding registers optimized
• When setting time, check whether files from later dates exist
• Fix close tunnel connection if CECS always on

1.5.10 (2016-08-01)

• Fix a harmless, but annoying error message when saving the configuration
• User interface: fix related to config file download
• User interface: minor performance improvement
• Force Encryption now also blocks changes on Email and SCADA, and limits live data to about 2 minutes
• New evaluations: Sensible Heat Flux, Turbulence Intensity, Obukkhov stability parameter and Inflow angle
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1.5.9 (2016-07-06)

• Add function to easily regenerate possibly inconsistent CSV files
• Make action handling more reliable.
• Solve problem with switch ”Prevent implicit tunnel activation (only recommended for satellite communication)”. The

tunnel connection was not disabled after ”Action online”
• Fix wrong date/time stamps in CSV, in cases when first channel had invalid data
• Add option to reduce online traffic when logged in, e.g. for satellite connections
• SCADA server write in Modbus store is now an atomic operation
• New generic Hygro/Thermo sensor -20..80°C
• New Silicon Irradiance Sensor SiS-13TC-T
• Fix SCADA modbus acknowledge writing holding registers
• Fix SCADA interval for stored data request
• Pyranometer Li-Cor LI-200SZ must be connected to analogue channel
• Fix a problem with signatures for newly produced Meteo-40
• Enhanced EKO Sun Tracker date, time and location synchronization
• Logbook more verbose, i.e. messages about CECS status and actions
• Minor UI improvements, e.g. faster web service and data logger icon
• Fix a problem with CECS mode not possible to change from LC display
• Fix a problem with time setting occasionally not working
• Fix CMP10 solar sensor

1.5.8 (2016-04-14)

• UI: sow CECS and MARS uptime
• Fix false handling of missing digital (TMR) wind vane data

Warning
In case you have wrong CSV files, generated from version 1.5 to 1.5.7, you have to remove them and
regenerate!

• Rename Heating Manager to Switch Manager
• Add switch management by means of wind speed for solar power plants
• Fix precipitation scale factor for Meteo-32 Streaming livedata
• Fix change switch state with switch manager
• Add easy cleanup for SCADA registers tables
• Fix Obukov-length CSV header for AmmonitOR
• Fix source data download
• Fix Silicon irradiance sensor default slope

1.5.7 (2016-03-07)

• Fix automatic CECS reboot method

1.5.6 (2016-02-24)

• Add evaluated data to source data view in web interface and to USB flash copy
• Add evaluation type and unit to linear equation
• Fix ZephIR 300 endianness and statistics
• Provide access to stored data over SCADA
• Fix ultrasonic wind speed scale factor for Meteo-32 Streaming livedata
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Warning
In case you are using Meteo-32 Streaming to read wind speed values from ultrasonic sensors, you might
need to correct the scale factor at the SCADA master!

• Fix generation of partial CSV files
• Minor bug fixes in CSV files generation
• Fix action ’Only generate CSV’
• Use ’---’ for invalid value in CSV

1.5.5 (2016-01-14)

• Fix statistics when using different measurement rates for counters and digitals
• Fix generic windvane evaluation

1.5.4 (2016-01-13)

• Fix statistics when using different measurement rates are used

Warning
In case you have wrong CSV files, generated from version 1.5 to 1.5.3, you have to remove them and
re-generate!

• Fix data snapshots to AmmonitOR
• Add hint for BGAN users on LAN page
• Add PT100 variant of Galltec Thermo-Hygro Passive CP
• More flexible ways of copying files to USB flash drive by date
• New ZephIR certified averaged data
• Fix CSV File generation with Thies Clima Sensor US

1.5.3 (2015-12-07)

• Fix problem with action colliding with midnight reboot
• Remove standard cabinets from user interface

1.5.2 (2015-12-03)

• New Apogee pyranometer PYR-PA, PYR-SA
• Fix RS485 polling rate for Thies Laser Precipitation Monitor
• Add self test for digital clock output
• More flexible automatic CECS reboot function

Note
If you use SCADA or are using Meteo-40 in 24/7 mode, check the setting Automatic CECS reboot option
on the administration page after upgrade!
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1.5.1 (2015-11-26)

• Fix a precision error in release 1.5 for digital wind vanes

1.5 (2015-11-25)

• Add support for sensors:
EKO Sun Tracker
CMP 10 Pyranometer
Inclinometer 2-axis SCA121 Level Developments
Vento anemometer
Galltec Thermo-Hygro with two 4..20 mA
ISET Solar Radiation Sensor
Generic Thermo/Hygro sensors with voltage outputs
Pyranometer Li-Cor LI-200SZ

• New status evaluation in Evaluations Helper
• New direction at maximum speed evaluation in Evaluations Helper
• Fix active power and obukhov length in evaluation in Evaluations Helper
• Fix application of positive and negative slope and offset to Young Propeller Anemometer

Note
If you have different slope values for upwind and downwind, it is necessary to regenerate the CSV files!
The slope for downwind will be automatically set to a negative value by the data logger.

• Support for SMTPS in addition to STARTTLS for more Email security options
• Device Identification available over SCADA
• Set date and time over SCADA Modbus communication
• CSV stability improvements
• Support tilt angle and cardinal direction for SPN-1
• Improve evaluation view and start messages in LC display
• Fix a communication issue, when no AmmonitOR project key is set
• Improve GPS reliability
• Future upgrades will use HTTPS instead of HTTP, enhancing security
• Fix configuring digital channel to power on CECS

1.4.3 (2015-08-18)

• Fixed a CSV generation error

1.4.2 (2015-08-04)

• Digital signatures refer to uncompressed CSV as canonical, not the compressed files - this might influence your
work flow

• Fixed a problem with delayed GPS time
• GPS location no longer changes configuration
• Support for Temperature Sensors 4..20mA, -30..70°C and -40..60°C

1.4.1 (2015-07-23)

• Fix for download of encrypted data in web interface
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1.4 (2015-07-16)

• Data encryption supported for USB flash drive copy and download
• Support for CSPS RSI sensor
• New linear equation, active power and wind direction formulas in Evaluation Helper
• Heating manager control by means of voltage measurement allowed
• Configurable word endianness for RS485 Modbus Sensors
• Include solar radiation summary in CSV files
• User interface change: New device page with display and USB flash drive settings
• User interface change: Encryption and signature now under Administration
• Add a Force Encryption option
• Connection check in web interface and via LC display
• Fix CSV generation with numerous RS485 errors
• Fix Young Wind Monitor missing wind direction evaluation

1.3.4 (2015-05-11)

• New HMP155 active and passive sensors
• Fix tunnel connectivity, when reconfiguring
• Reduce SCADA Modbus server response time to 40 ms
• Old CSV files get removed on CECS reboot when not enough memory left

1.3.3 (2015-03-31)

• Allow custom clipping for humidity sensors
• Fixed a problem with encryption when private key is not available
• Fixed a problem with sending pictures via FTP
• Enhanced RS485 sensors support
• Fixed a problem with preventing sending of CSV files to AmmonitOR or file server
• Removed unused tilt angle from sensor helper
• Fixed UI air density configuration
• Fixed a SCADA performance issue

1.3.2 (2015-02-16)

• Fixed a problem with deleting source data memory

1.3.1 (2015-02-06)

• Fixed a problem with display showing ”Please wait” for a long time
• Fixed a problem with Thies Precipitation Monitor

1.3 (2015-02-04)

• Fixed a CSV generation error in cases where measurement has been stopped for a day by the user
• Data snapshot and camera image can be sent to AmmonitOR now, data snapshot is still experimental
• UI: show modem quality bar in LC display and web UI
• UI: warn about missing WLAN passphrase
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• UI: don’t show Gantner modules as unknown in LC display
• Add Thies Precipitation Monitor
• Obukhov length possible with 3D ultrasonics
• Enhance memory security esp. for SCADA
• Thies Clima Sensor uses wind direction offset for brightness direction
• Fixed a problem with SCP sending when data logger name contained non-ASCII characters

1.2.4 (2014-11-12)

• Added support for Thies Clima Sensor US
• Fix wind speed evaluation for Lufft WS

1.2.3 (2014-11-05)

• Enhance memory security

1.2.2 (2014-10-20)

• Fixed a problem with the SCADA function: In some cases the values were not readable
• Fixed a problem with the camera function for data logger with non-ASCII characters in their name
• Fixed a problem with the display of values for some RS485 modules

1.2.1 (2014-09-22)

• Counter measurement fix: When the clock is set, e.g. by NTP or GPS, under some conditions, the counter value
can be wrong. This affected mainly the maximal values

• Minor UI fixes

1.2 (2014-09-08)

• Modem PHS8 is supported
• Experimental support for SMS
• Complete configuration can be sent to AmmonitOR or via email or FTP/SCP

Note
If you don’t want to have the configuration file sent to AmmonitOR or via email or FTP/SCP, you have to
switch this off in the respective menu.

• New scale factor and data type selection for SCADA measurement values
• New Unix Time available over SCADA
• Easier connection between PC and data logger using link-local connection
• Fixed a problem with CSV generation
• Fixed providing sum statistic over SCADA
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1.1 (2014-08-14)

• Digital signature available for newly produced data loggers. Contact Ammonit, if this feature is required on a previ-
ously purchased device

• The heating manager can make use of an optional voltage as additional heating condition, while the humidity has
been made optional

• The USB flash drive function is activated with a default password for newly produced data loggers
• Factory reset and source data deletion is logged in the logbook
• Setting of date/time by GPS, NTP, or manually is logged into logbook
• Setting the date via GPS is supported, updating the altitude by GPS is not done anymore
• An error in the counters calculation for periods ≠ 1 s has been fixed
• Minor user interface changes
• Fixed a problem sending images via e-mail
• Use new algorithm for wind direction maximum and minimum
• Show DHCP state also for Tethering connection
• New Thies Laser Precipitation Sensor
• Memory sizes are indicated in MiB
• Error condition recognition for Gill Wind Master

1.0.1 (2014-06-10)

• Enhanced Modbus RTU SCADA server performance
• New page for AmmonitOR related configuration
• Allow sending data to both AmmonitOR and an FTP/SCP server
• New densitiy of moist air evaluation
• Fix CSV generation with temperature differential evaluations
• Correction for Galltec Thermo-Hygro Passive CP
• Allow date limit for file transfer (start date) and reset of send status
• Improved check when sending test email
• Add experimental support for email encryption
• Fix NMEA RS485 telegram parser
• Enhance modem communication in respect to disconnection
• Enhance clock accuracy
• Enhance memory protection
• Fix Young Monitor and Tech Sun channel order
• Fix erroneous recursive CSV file generation

1.0 Rev. 14683 (2013-12-19)

• Support for temperature difference evaluation
• More WLAN chips are supported: Atheros AR9271, Ralink rt2800, Ralink rt73
• Enhanced UI for accessing source data
• Minor error corrections, e.g.

in respect to USB flash drive,
solar evaluations in the LC display,
use of non-ASCII characters in email password and data logger name
correction of WAV252 and MT32
optimization of SCADA streaming mode
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1.0 Rev. 14324 (2013-11-08)

Note
There are some minor, but incompatible changes in this software version. Please check carefully, if one of
the changes might affect you.

• New sensors: FarData wind vane, Teknam Thermo-Hygro, Teknam barometric pressure sensor
• Enhanced special mode for Meteo-32 wind vane compatibility: No dedicated configuration of Meteo-32 sensors

necessary; standard configuration and connection according to manual
• Milliseconds in date/time field of statistics file (.csv) removed; importing software might be configured, if necessary
• Switching of CECS status via status input signal, see Administration.
• Format of the keyfile.txt changed to INI file format; copying of source data to logbook possible
• Minor user interface changes
• Speed up and improved robustness of source data download
• Speed up some solar evaluations
• Enhanced RS485-Sensors error recognition and response
• Configurable slope and offset for RS485 ultrasonics horizontal wind speed
• Fix RS485-Sensors count statistic when more than one sensor connected

1.0 Rev. 13947 (2013-09-23)

• New sensors: Tech-Sen thermo-hygro, Tech-Sen barometric pressure sensor
• Correction for status evaluation
• Minor user interface changes

1.0 Rev. 13863 (2013-09-12)

• New sensors: Setra barometric pressure sensor Model 276 and 278; compatibility for first and second Meteo-32
wind vane

• Optimized tunnel traffic
• USB connection displayed in status box; data logger name shown in upper right corner

1.0 Rev. 13749 (2013-09-04)

• New sensors: Pyranometer SP Lite 2, Gantner e.bloxx A1
• Re-enabled reboot at midnight, with exception for SCADA-enabled data loggers
• Enhanced flash memory detection

1.0 Rev. 13645 (2013-08-23)

• New sensors: Hygro-thermo Galltec KPC MS, passive hygro-thermo Galltec CP, Gantner e.bloxx A3-1 and d.bloxx
D1-1, wind vane Vaisala WAV252, Thies precipitation intensity

• Support of virtual temperature for Gill wind observer 2D
• Better presentation of switches states in live data
• Better estimation of sun status for SPN1
• User interface enhancements for SCADA
• Logbook for registering events
• POP-before-SMTP/SMTP-after-POP supported by email function
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• Better support for USB flash drives
• Replacement of tunnel affix by tunnel access code
• Download multiple CSV file as ZIP archive
• Solved wrong statistics selection (scalar/vector)

1.0 Rev. 13187 (2013-07-01)

• Communication enhancements, esp. for satellite modems
• Increased memory protection
• Support for Sineax Cam Power Meter, e.g. for PCM
• Heating manager problem on configuring boundaries corrected
• Enhancements in web interface: Statistics calendar
• Optional time synchronization via GPS

1.0 Rev. 12696 (2013-05-16)

• Heating manager: Temperature and humidity configurable
• Support for ISKRA Power Meter, e.g. for PCM
• Wind direction offset for ultrasonic sensors added
• Timing enhancement for RS485 sensors
• Additional route for LAN possible, e.g. for SCADA
• Solved sporadic connection failure with modem
• Possible wrong timezone corrected, when setting the time manually
• Enhancements in web interface for smart phones and small devices

1.0 Rev. 12454 (2013-04-24)

• Timeout problem for serial (RS485) SCADA connections corrected

1.0 Rev. 11982 (2013-01-22)

• Set default display contrast
• Error for Lufft RS485 sensor corrected
• Automatic reboot at midnight removed
• RS485 serial settings allowed
• Further performance enhancements for SCADA

1.0 Rev. 11900 (2012-12-19)

• Possible source data corruption problem after second overrun (e.g. after two years) corrected; upgrade must happen
before second overrun

• Implementation of new ”generic” ModBus RTU sensor
• Supported temperature measurement using Pt1000 or Pt100 for data loggers with built-in Ethernet interface
• Evaluating of virtual temperature for Gill Windmaster Pro 3D, if configured like Thies ultrasonics 2D/3D
• Minor user interface corrections
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1.0 Rev. 11669 (2012-11-19)

• Documenation of heating manager
• Performance enhancements for SCADA
• Support of data logger with built-in Ethernet interface

1.0 Rev. 11587 (2012-11-05)

• New feature: Simple heating manager
• Corrected data actualization problem in SCADA
• Internet Explorer 8™ and Chrome™ supported

1.0 Rev. 11317 (2012-10-08)

• Parallel working of SCADA and modem possible
• UI with virtual display keys
• Enhanced factory reset

1.0 Rev. 11236 (2012-09-21)

• Email sending problem corrected
• GPS enhancements
• Changes in network shown live in display

1.0 Rev. 11181 (2012-09-11)

• CSV files with round time slices
• Serial modems work, even if not permanently on
• Measurement frequency ⅛s removed
• Problem with displaying negative power for pyranometers corrected
• Emergency password reset method available by means of Ammonit support for new data loggers
• Configuration of longitude, latitude, and altitude, support of KML (e.g. Google Earth™)
• USB GPS devices supported
• Enhanced user manual

1.0 Rev. 11031 (2012-08-27)

• Min and max for wind direction available
• Eror when saving sensors corrected
• Measurement interruption when upgrading corrected
• Measurement range for NRG hygro/thermo sensor corrected
• Order of hygro/thermo for Galltec sensor corrected
• Corrected error for ICP-CON wind vane module
• Enhanced user manual
• Detection of under-voltage situation (brown-out) implemented
• Configuration of CSD3 optionally with only one voltage channel
• Thies wind vane classic with one analog channel supported
• SCADA endianess configurable
• Overall stability enhancements
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1.0 Rev. 10769 (2012-07-25)

• More robust CSV creation
• Gill Windmaster supported
• Power meter GD2000 supported
• Virtual temperature Thies ultrasonics 2D/3D evaluated
• Turkish language in user interface supported
• User interface problem with Internet Explorer™ corrected

1.0 Rev. 10627 (2012-07-12)

• Average values for SCADA supported
• Gill Wind Obversver is supported
• PINs and passwords not visible in the downloaded configuration anymore
• Problems with uploading older configuration files solved
• CECS mode is saved in the configuration file
• New functions to remove all statistics files, all sensors, and for factory reset
• Switches in the display shown
• Minor changes for upgrade function

1.0 Rev. 10474 (2012-06-29)

• Fixing of an potential data corruption error introduced with the last version

1.0 Rev. 10244 (2012-06-15)

• Problem with switching of the CECS corrected
• Enhanced solar sensors
• AmmonitOR connection log supplied with data logger time and time zone
• Documentation corrections
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GNU General Public License

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the
GNU General Public License is intended to guarantee your freedom to share and change free software - to make sure
the software is free for all its users. This General Public License applies to most of the Free Software Foundation’s
software and to any other program whose authors commit to using it. (Some other Free Software Foundation software
is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed
to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish),
that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new
free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender
the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if
you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all
the rights that you have. You must make sure that they, too, receive or can get the source code. And you must show
them these terms so they know their rights.

We protect your rights with two steps:

1. copyright the software, and

2. offer you this license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author’s protection and ours, we want to make certain that everyone understands that there is no
warranty for this free software. If the software is modified by someone else and passed on, we want its recipients to
know that what they have is not the original, so that any problems introduced by others will not reflect on the original
authors’ reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors
of a free program will individually obtain patent licenses, in effect making the program proprietary. To prevent this, we
have made it clear that any patent must be licensed for everyone’s free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

TERMSANDCONDITIONSFORCOPYING, DISTRIBUTIONANDMOD-
IFICATION

Section 0

This License applies to any program or other work which contains a notice placed by the copyright holder saying it
may be distributed under the terms of this General Public License. The “Program”, below, refers to any such program
or work, and a “work based on the Program” means either the Program or any derivative work under copyright law:
that is to say, a work containing the Program or a portion of it, either verbatim or with modifications and/or translated
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into another language. (Hereinafter, translation is included without limitation in the term “modification”.) Each licensee
is addressed as “you”.

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope.
The act of running the Program is not restricted, and the output from the Program is covered only if its contents
constitute a work based on the Program (independent of having been made by running the Program). Whether that is
true depends on what the Program does.

Section 1

You may copy and distribute verbatim copies of the Program’s source code as you receive it, in any medium, provided
that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of
warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other
recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection
in exchange for a fee.

Section 2

You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program,
and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet
all of these conditions:

a. You must cause the modified files to carry prominent notices stating that you changed the files and the date of
any change.

b. You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the
Program or any part thereof, to be licensed as a whole at no charge to all third parties under the terms of this
License.

c. If the modified program normally reads commands interactively when run, you must cause it, when started
running for such interactive use in the most ordinary way, to print or display an announcement including an
appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a warranty)
and that users may redistribute the program under these conditions, and telling the user how to view a copy of
this License. (Exception: If the Program itself is interactive but does not normally print such an announcement,
your work based on the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from
the Program, and can be reasonably considered independent and separate works in themselves, then this License,
and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the
same sections as part of a whole which is a work based on the Program, the distribution of the whole must be on the
terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every
part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the
intent is to exercise the right to control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on
the Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this
License.

Section 3

You may copy and distribute the Program (or a work based on it, under Section 2 in object code or executable form
under the terms of Sections 1 and 2 above provided that you also do one of the following:

a. Accompany it with the complete corresponding machine-readable source code, which must be distributed under
the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,
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b. Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than
your cost of physically performing source distribution, a complete machine-readable copy of the corresponding
source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily used for
software interchange; or,

c. Accompany it with the information you received as to the offer to distribute corresponding source code. (This
alternative is allowed only for noncommercial distribution and only if you received the program in object code or
executable form with such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable
work, complete source code means all the source code for all modules it contains, plus any associated interface
definition files, plus the scripts used to control compilation and installation of the executable. However, as a special
exception, the source code distributed need not include anything that is normally distributed (in either source or binary
form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs,
unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering
equivalent access to copy the source code from the same place counts as distribution of the source code, even though
third parties are not compelled to copy the source along with the object code.

Section 4

You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any
attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your
rights under this License. However, parties who have received copies, or rights, from you under this License will not
have their licenses terminated so long as such parties remain in full compliance.

Section 5

You are not required to accept this License, since you have not signed it. However, nothing else grants you permission
to modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this
License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your
acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program
or works based on it.

Section 6

Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a
license from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You
may not impose any further restrictions on the recipients’ exercise of the rights granted herein. You are not responsible
for enforcing compliance by third parties to this License.

Section 7

If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to
patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the
conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to
satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence
you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution
of the Program by all those who receive copies directly or indirectly through you, then the only way you could satisfy
both it and this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the
section is intended to apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest
validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution
system, which is implemented by public license practices. Many people have made generous contributions to the wide
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range of software distributed through that system in reliance on consistent application of that system; it is up to the
author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot
impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

Section 8

If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted in-
terfaces, the original copyright holder who places the Program under this License may add an explicit geographical
distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus
excluded. In such case, this License incorporates the limitation as if written in the body of this License.

Section 9

The Free Software Foundation may publish revised and/or new versions of the General Public License from time to
time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems
or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which
applies to it and “any later version”, you have the option of following the terms and conditions either of that version or
of any later version published by the Free Software Foundation. If the Program does not specify a version number of
this License, you may choose any version ever published by the Free Software Foundation.

Section 10

If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different,
write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to
the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals
of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software
generally.

NO WARRANTY Section 11

BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM,
TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE
COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM “AS IS” WITHOUT WARRANTY OF
ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY
AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU
ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

Section 12

IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT
HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED
ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSE-
QUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT
NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU
OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN
IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

226 © 2011 — 2017 Ammonit Measurement GmbH



Data Logger Meteo-40 User’s Manual 227 / 234

How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve
this is to make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most
effectively convey the exclusion of warranty; and each file should have at least the “copyright” line and a pointer to
where the full notice is found.

<one line to give the program’s name and a brief idea of what it does.> Copyright (C) <year> <name of author>

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public
License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later
version.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied
warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free
Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

Gnomovision version 69, Copyright (C) year name of author Gnomovision comes with ABSOLUTELY NO WARRANTY;
for details type “show w”. This is free software, and you are welcome to redistribute it under certain conditions; type
“show c” for details.

The hypothetical commands “show w” and “show c” should show the appropriate parts of the General Public License.
Of course, the commands you use may be called something other than “show w” and “show c”; they could even be
mouse-clicks or menu items--whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a “copyright disclaimer”
for the program, if necessary. Here is a sample; alter the names:

Yoyodyne, Inc., hereby disclaims all copyright interest in the program “Gnomovision” (which makes passes at compil-
ers) written by James Hacker.

<signature of Ty Coon>, 1 April 1989 Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is
a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is
what you want to do, use the GNU Library General Public License instead of this License.
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Chapter 17

Glossary

APN
Access Point Name

CDMA
Code Division Multiple Access

CECS
Configuration, Evaluation, and Communication System

CPV
Concentrated Photovoltaics

CSP
Concentrated Solar Power

CSV
Comma Separated Values

DHCP
Dynamic Host Configuration Protocol

DHI
Diffuse Horizontal Irradiation

DNI
Direct Normal Irradiation

DNS
Domain Name System

FTP
File Transfer Protocol

GHI
Global Horizontal Irradiation

GIS
Geographic Information System

GNU
GNU’s Not Unix

GnuPG
GNU Privacy Guard

GPL
General Public License

GPRS
General Packet Radio Service
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GPS
Global Positioning System

GSM
Global System for Mobile communications

GTI
Global Tilted Irradiation

HTTP
HyperText Transfer Protocol

HTTPS
HTTP Secure

IEEE
Institute of Electrical and Electronics Engineers

IP
Internet Protocol

LAN
Local Area Network

LCD
Liquid Crystal Display

LED
Light-emitting diode

LGPL
Lesser General Public License

MARS
Measurement And Recording System

NTP
Network Time Protocol

OVP
Overvoltage Protection

PIN
Personal Identification Number

POT
Potentiometer - Measurement principle, e.g., Wind vane POT

PPP
Point-to-point protocol

PUK
PIN Unlock Key (or Personal Unblocking Code, PUC)

PV
Photovoltaic

RNDIS
Remote Network Driver Interface Specification

SCADA
Supervisory Control and Data Acquisition

SCP
Secure Copy Protocol/Program

SIM
Subscriber Identity Module

SMS
Short Message Service

SMSC
Short Message Service Center
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SSH

Secure Shell

SSL

Secure Sockets Layer

TCP/IP

Transmission Control Protocol/Internet Protocol

TLS

Transport Layer Security

TMR

Tunnel Magneto Resistance - Measurement principle, e.g. Wind vane TMR

UMTS

Universal Mobile Telecommunications System

USB

Universal Serial Bus

W-LAN

Wireless Local Area Network

WMO

World Meteorological Organization
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A
Access Point Name, 109
Access Rights, 29, 133

Admin, 29
Guest, 29
User, 29
Viewer, 29

Accessing Meteo-40
Ethernet, 9, 15
LAN, 9, 13
USB, 9, 20

Admin, 29
AES, 197
Air density evaluation, 62
Ammonit Tunnel Server, 87
AmmonitOR, 83, 87, 91
Analog Current, 168
Analog Voltage, 165
Anemometers, 55, 144
APN, 109

B
Barometric Pressure Sensors, 153
BGAN, 118, 119
Bonjour Print Services, 12

C
Camera, 49
Cascading, 129
CECS, 4, 6, 35, 121, 135
Change Passwords, 35
Channels, 60

Analog Current, 135, 168
Analog Voltage, 135
Counter, 135, 166
Digital, 135, 166
Period Measurement, 166
RS485, 169
Status, 135, 166

Communication
Ethernet, 9, 15, 138
LAN, 9, 13, 83, 138
Modem, 83, 109, 138
Satellite Modem, 83, 109, 118

Recommended Settings, 119
USB, 9, 20, 83, 138
W-LAN, 83, 108, 138

Communication Configuration, 85
Communication Methods, 7
Communication Schedule, 85
Configuration

Access Point Name, 112
Email Parameters, 93
LAN, 106
Modem, 109
Online Access, 87
W-LAN, 108

Configuration File, 33
Download, 33
Format, 33
Upload, 33

Configuration Status, 30
Connection Plans, 179
Connection Status, 30
Cookie, 15, 22
Counter Channels, 166
Cryptographic Software, 197
CSV File, 65, 71, 75, 76

D
Data Evaluation, 60, 65
Data Logger Name, 35
Data Retrieval

LAN, 7
Modbus RTU, 7
Modbus TPC/IP, 7
Modem, 7
USB, 7
W-LAN, 7

Data Storage, 6
Data Transmission, 83
Debian, 28
Delete Measurement Data, 35, 41
DHCP, 9, 13, 15, 106
Differential temperature evaluation, 62
Digital Channels, 166
Digital Wind Vanes, 146, 148
Display, 45, 133
Driver, 20

Update, 23
Dynamic IP Address, 87, 106, 109, 112

E
Electrical Characteristics, 172
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Email, 83, 93
Email Attachments, 93
Encryption, 197

Force Encryption, 39
Error List, 134
Ethernet, 138
Evaluation, 60

F
Factory Reset, 35, 41
FAQ, 201
File Interval, 65, 67
File Upload, 83

FTP, 105
SCP, 105

FileZilla
FTP server, 106

FTP, 83, 105
active mode, 105
passive mode, 105

FXT009, 115

G
Generic Modbus RTU sensors, 161
Generic Sensors

Modbus RTU, 161
Gill Ultrasonic Sensors, 151
Global Control Elements, 30
GnuPG, 197
GPS, 35
Guest, 29
Gust Data, 70

H
HTTPS, 197
Humidity Sensors, 151

I
IEEE 754, 126
Import CSV Files, 75, 76
Inflow angle evaluation, 64
INI File, 33
Ini File, 71
Input Channels, 2
Internet Explorer, ii
IP Address, 106, 138

J
JavaScript, 15

L
LAN, 7, 13, 83, 106, 138
Laser Precipitation Monitors, 160
LED Lights, 134
LibreOffice Calc, 75
Linear equation, 61
link-local, 15
Linux, ii, 4, 28
Live Data, 65
Location, 35
Logbook, 53
Login, 29

Lufft Ultrasonic Sensors, 150

M
Maintenance, 199
MARS, 4
Measurement Values, 60
Memory, 2, 134
Menu

Display, 134
Web Interface, 32

Meteo-32 Stream Map, 130
Microsoft Excel 2010, 76, 81
Modbus, 124
Modbus Register Map, 124
Modbus RTU, 7, 121
Modbus TCP/IP, 7, 121
Modem, 7, 83, 109, 135, 138, 179

FXT009, 115
Mozilla Firefox, ii, 13, 22

N
NTP Server, 35

O
Obukhov length evaluation, 63
Obukhov stability parameter evaluation, 63
Online Period, 87
OpenOffice Calc, 75
OpenSSL, 197
Output Channels, 2
Overvoltage Protection, 199

P
Period Measurement, 166
Photos, 93
Point-to-Point Ethernet Connection, 15
POP Server, 93
Potentiometric Wind Vanes, 147
Power Meters

RS485 Sensors, 163
Power Supply, 2
Precipitation Sensors, 159
Provider Helper, 112
Pyranometers, 55, 154

R
Rain Gauge, 159
Recording, 30, 135
Register Map, 121
Release Notes, 209
Restart Data Logger, 41
RNDIS USB Driver, 20
Rotating Shadowband Irradiometer, 159
RS485, 169

Wind Vanes, 148
RS485 Master Serial Console, 58
RS485 S, 121
RSA, 197

S
SCADA, 6, 7, 121

Configuration, 121
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Meteo-32 Stream Map, 130
SCP, 83, 105, 197
Security

Force Encryption, 39
Sensible heat flux evaluation, 64
Sensitivity, 154
Sensor Configuration, 55
Sensor Helper, 55, 57
Sensor Settings, 57, 58
Sensors, 55

Anemometers, 55, 144
Barometric Pressure Sensors, 153
Humidity Sensors, 151
Laser Precipitation Monitors, 160
Modbus RTU Sensors, 161
Precipitation Sensors, 159
Pyranometers, 154, 155
Rotating Shadowband Irradiometer, 159
RS485 Sensors, 163
Soiling Measurement, 158
Solar Trackers, 157
Temperature Sensors, 151
Ultrasonic Sensors, 149–151
Wind Vanes, 55, 146, 147
ZephIR 300, 164

SHA, 197
Sierra Wireless, 115
SIM Card, 87, 115
Sineax CAM Measuring Unit, 163
SMTP Server, 93
Soiling Measurement, 158
Solar Trackers, 157
Source Data, 81
SSH, 197
Static IP Address, 87, 106, 107, 109, 114
Statistics, 65

Configuration, 65
Statistics Interval, 65, 67
Status (Channel), 166
Status Box, 30, 135
Storage Size, 2, 134
Stream Map, 129
Subdomain, 87
Switch, 51

Configuration, 51
Switch Manager, 51

Switch Manager, 51
System

CECS, 4, 121
MARS, 4

System Administration, 35
System Information, 33

T
Technical Data, 171
Temperature Humidity Sensors, 151
Temperature Sensors, 151
Tethering, 7
Thies Ultrasonic Sensors, 150
Tunnel, 83
Tunnel Server, 87

U
Ubuntu, 28
Ultrasonics, 169

Gill Sensors, 151
Lufft Sensors, 150
Thies Sensors, 150

Upgrade Data Logger Software, 41
USB, 7, 20, 83, 138
USB Flash Drive, 46
User, 29
User Interface, 6

V
Viewer, 29

W
W-LAN, 7, 83, 108, 138
Web Interface Menu, 32
Webcam, 49
WiFi, 108
Wind Vanes, 55, 146, 147

Digital, 146, 148
Potentiometer, 147
RS485, 148
TMR, 146

Windows, ii, 12, 15, 20

Z
ZephIR 300, 164
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